summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-08-09 19:28:29 -0400
committerMatt Turner <mattst88@gentoo.org>2022-08-09 22:07:32 -0400
commit25bf0bf44eebef829150faa3fe79a79d5cad06cf (patch)
tree3ea6de475228def6f8fabbab74765662b8b6452f
parentnet-firewall/nftables: Sync 9999 (diff)
downloadgentoo-25bf0bf44eebef829150faa3fe79a79d5cad06cf.tar.gz
gentoo-25bf0bf44eebef829150faa3fe79a79d5cad06cf.tar.bz2
gentoo-25bf0bf44eebef829150faa3fe79a79d5cad06cf.zip
app-misc/tracker: Version bump to 3.3.3
Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--app-misc/tracker/Manifest1
-rw-r--r--app-misc/tracker/tracker-3.3.3.ebuild114
2 files changed, 115 insertions, 0 deletions
diff --git a/app-misc/tracker/Manifest b/app-misc/tracker/Manifest
index 0c8d3f1a159c..16f141447bc1 100644
--- a/app-misc/tracker/Manifest
+++ b/app-misc/tracker/Manifest
@@ -1,2 +1,3 @@
DIST tracker-3.3.1.tar.xz 1976268 BLAKE2B 34492aac5c7a5cae20cc3b246de7a7f9948be05356508cffeec56cd6aa83b89a875c01d58c299299723e1aed8bba55d641dc817f77cecbe1379b49ea853aa8b3 SHA512 34a86ac58bf8b31f3beb106d3f8db38b764624b800f4cb1c015102f02616e4c2d356f58f0e6a13f66cca79a4173828748ad5e4217b21e83b2fe1606ddcd7ce88
DIST tracker-3.3.2.tar.xz 1977512 BLAKE2B 92d8db9ad33b019f47194f086379e1f9370d9ce3643a2a2dc02d277be755e5a892ab4c6bead8c2d50db642aca37141c9961d2fd1f862be57a6e0f78b479eb03f SHA512 2009c7a9b82fd278e38bc71cb41ef1fccb23493bd84a71456c7568ed7a025ce68bab689b8f14b8008479a203a5fdc02acea1862f4f482467ed5c295bde3d4ad8
+DIST tracker-3.3.3.tar.xz 1976160 BLAKE2B aa61b83ac499736b1cc6273813ef0bf44dae9c4a30d49f28d97205b31ead7e55021312297973cf37be67edc76bf66ca19edd746ae2269e59da406d23bcc018c7 SHA512 0f8ad998a5de6914d1e24da1b2021967339a2e637996b3e672fe4991177e69b750cdd9eb894e5e6f5f394d991b680d40afc05b95f69171ec38278e30c9729a15
diff --git a/app-misc/tracker/tracker-3.3.3.ebuild b/app-misc/tracker/tracker-3.3.3.ebuild
new file mode 100644
index 000000000000..4c0399012f73
--- /dev/null
+++ b/app-misc/tracker/tracker-3.3.3.ebuild
@@ -0,0 +1,114 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{8..11} )
+VALA_MIN_API_VERSION="0.40"
+
+inherit bash-completion-r1 flag-o-matic gnome.org gnome2-utils linux-info meson python-any-r1 systemd vala xdg
+
+DESCRIPTION="A tagging metadata database, search tool and indexer"
+HOMEPAGE="https://wiki.gnome.org/Projects/Tracker https://gitlab.gnome.org/GNOME/tracker"
+
+LICENSE="GPL-2+ LGPL-2.1+"
+SLOT="3/0" # libtracker-sparql-3.0 soname version
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="gtk-doc +miners stemmer test"
+RESTRICT="!test? ( test )"
+
+PV_SERIES=$(ver_cut 1-2)
+
+RDEPEND="
+ >=dev-libs/glib-2.52:2
+ >=sys-apps/dbus-1.3.2
+ >=dev-libs/gobject-introspection-1.54:=
+ >=dev-libs/icu-4.8.1.2:=
+ >=dev-libs/json-glib-1.4
+ >=net-libs/libsoup-2.40.1:2.4
+ >=dev-libs/libxml2-2.7
+ >=dev-db/sqlite-3.29.0
+ stemmer? ( dev-libs/snowball-stemmer:= )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/glib-utils
+ app-text/asciidoc
+ dev-libs/libxslt
+ $(vala_depend)
+ gtk-doc? (
+ >=dev-util/gtk-doc-1.8
+ app-text/docbook-xml-dtd:4.1.2
+ app-text/docbook-xml-dtd:4.5
+ )
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ test? (
+ $(python_gen_any_dep 'dev-python/pygobject[${PYTHON_USEDEP}]')
+ $(python_gen_any_dep 'dev-python/tappy[${PYTHON_USEDEP}]')
+ )
+ ${PYTHON_DEPS}
+"
+PDEPEND="miners? ( >=app-misc/tracker-miners-${PV_SERIES} )"
+
+function inotify_enabled() {
+ if linux_config_exists; then
+ if ! linux_chkconfig_present INOTIFY_USER; then
+ ewarn "You should enable the INOTIFY support in your kernel."
+ ewarn "Check the 'Inotify support for userland' under the 'File systems'"
+ ewarn "option. It is marked as CONFIG_INOTIFY_USER in the config"
+ die 'missing CONFIG_INOTIFY'
+ fi
+ else
+ einfo "Could not check for INOTIFY support in your kernel."
+ fi
+}
+
+python_check_deps() {
+ python_has_version -b \
+ "dev-python/pygobject[${PYTHON_USEDEP}]" \
+ "dev-python/tappy[${PYTHON_USEDEP}]"
+}
+
+pkg_setup() {
+ linux-info_pkg_setup
+ inotify_enabled
+
+ use test && python-any-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+ vala_setup
+ xdg_environment_reset
+}
+
+src_configure() {
+ append-cflags -DTRACKER_DEBUG -DG_DISABLE_CAST_CHECKS
+
+ local emesonargs=(
+ $(meson_use gtk-doc docs)
+ -Dman=true
+ $(meson_feature stemmer)
+ -Dunicode_support=icu
+ -Dbash_completion_dir="$(get_bashcompdir)"
+ -Dsystemd_user_services_dir="$(systemd_get_userunitdir)"
+ $(meson_use test tests)
+ -Dintrospection=enabled
+ -Dsoup=soup2
+ )
+ meson_src_configure
+}
+
+src_test() {
+ dbus-run-session meson test -C "${BUILD_DIR}" || die 'tests failed'
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}