summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2016-04-28 16:52:01 -0500
committerAustin English <wizardedit@gentoo.org>2016-04-28 16:59:32 -0500
commit25e5fe7861d9eb70648fd3e12c4a0eee9a5ae91b (patch)
tree3ec9213b008d1cb758f8374ef8a4037352551025
parentnet-dialup/pptpd: remove pptpd-1.4.0 (diff)
downloadgentoo-25e5fe7861d9eb70648fd3e12c4a0eee9a5ae91b.tar.gz
gentoo-25e5fe7861d9eb70648fd3e12c4a0eee9a5ae91b.tar.bz2
gentoo-25e5fe7861d9eb70648fd3e12c4a0eee9a5ae91b.zip
net-dialup/rp-l2tp: use #!/sbin/openrc-run instead of #!/sbin/runscript
Gentoo-Bug: https://bugs.gentoo.org/573846 Package-Manager: portage-2.2.26
-rw-r--r--net-dialup/rp-l2tp/files/rp-l2tpd-init4
-rw-r--r--net-dialup/rp-l2tp/rp-l2tp-0.4-r4.ebuild36
2 files changed, 38 insertions, 2 deletions
diff --git a/net-dialup/rp-l2tp/files/rp-l2tpd-init b/net-dialup/rp-l2tp/files/rp-l2tpd-init
index a541255f5902..b8029c6d08c0 100644
--- a/net-dialup/rp-l2tp/files/rp-l2tpd-init
+++ b/net-dialup/rp-l2tp/files/rp-l2tpd-init
@@ -1,5 +1,5 @@
-#!/sbin/runscript
-# Copyright 1999-2004 Gentoo Foundation
+#!/sbin/openrc-run
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
diff --git a/net-dialup/rp-l2tp/rp-l2tp-0.4-r4.ebuild b/net-dialup/rp-l2tp/rp-l2tp-0.4-r4.ebuild
new file mode 100644
index 000000000000..315cdd8a5680
--- /dev/null
+++ b/net-dialup/rp-l2tp/rp-l2tp-0.4-r4.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="User-space implementation of L2TP for Linux and other UNIX systems"
+HOMEPAGE="http://sourceforge.net/projects/rp-l2tp/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="amd64 ~ppc x86"
+SLOT="0"
+
+src_prepare() {
+ tc-export AR CC RANLIB
+ epatch \
+ "${FILESDIR}/${P}-gentoo.patch" \
+ "${FILESDIR}/${P}-flags.patch" \
+ "${FILESDIR}/${P}-build.patch"
+ epatch_user
+}
+
+src_install() {
+ emake RPM_INSTALL_ROOT="${D}" install
+
+ dodoc README
+ newdoc l2tp.conf rp-l2tpd.conf
+ docinto libevent
+ dodoc libevent/Doc/*
+ docompress -x "/usr/share/doc/${PF}/libevent"
+
+ newinitd "${FILESDIR}/rp-l2tpd-init" rp-l2tpd
+}