summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEttore Di Giacinto <mudler@gentoo.org>2017-03-03 10:18:58 +0100
committerEttore Di Giacinto <mudler@gentoo.org>2017-03-03 10:47:36 +0100
commit25e645d04de4f20bb4105738133a43b950c4db0b (patch)
treea86e339877c5c3e2e03ddcf0c95a12149a2ed3ad
parentapp-editors/vim: arm arm64 ppc ppc64 stable (bug 611386). (diff)
downloadgentoo-25e645d04de4f20bb4105738133a43b950c4db0b.tar.gz
gentoo-25e645d04de4f20bb4105738133a43b950c4db0b.tar.bz2
gentoo-25e645d04de4f20bb4105738133a43b950c4db0b.zip
dev-vcs/git-lfs: Version bump
Package-Manager: Portage-2.3.3, Repoman-2.3.1
-rw-r--r--dev-vcs/git-lfs/Manifest1
-rw-r--r--dev-vcs/git-lfs/git-lfs-2.0.0.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-vcs/git-lfs/Manifest b/dev-vcs/git-lfs/Manifest
index 4cefe238fe31..11576d76d04c 100644
--- a/dev-vcs/git-lfs/Manifest
+++ b/dev-vcs/git-lfs/Manifest
@@ -1 +1,2 @@
DIST git-lfs-1.5.6.tar.gz 604139 SHA256 4efbc806cde1ea6ab4e1d61db3e1f6939796fd53bf6e9c94ac564610147ea5cd SHA512 f5f2da9ac44647335b25cad3104027cf5476e25ef9763019744123f9e1ef81edadbf5b08a146b8070487b32a18aa202c799f910aee6f2f0144ca411ad6d7cfd2 WHIRLPOOL 2f785abffc917a322fe59f4354980d5f565572620569b9b53e85ecdf84b5d7ad407ced8853c897814daa816cac6efd1f85c9098cae9fe48b179cd3381c5f840d
+DIST git-lfs-2.0.0.tar.gz 628995 SHA256 64597dc8c5460b22ec957b1d0fabec58abcd6f373b9473e419a74f8dff5c508b SHA512 2ccef0d8f4792118e227683a4b5a9b4aafccf12855f51d6bf5cda4e51e67ef9c74bf9b31fc953296ca46e2c264c0763613332db6b29bc25d003c77c216cd6683 WHIRLPOOL c11bcdfe5cd9169756e19bf42a4ec459e4a60b20726f8baed5a2b9977e490ff08ced5a8a60739718df21969cb76b2fd33d20b7263acc3a96d5050e45fde07106
diff --git a/dev-vcs/git-lfs/git-lfs-2.0.0.ebuild b/dev-vcs/git-lfs/git-lfs-2.0.0.ebuild
new file mode 100644
index 000000000000..59acb2d839a7
--- /dev/null
+++ b/dev-vcs/git-lfs/git-lfs-2.0.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+EGO_PN="github.com/git-lfs/${PN}"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit golang-vcs
+else
+ SRC_URI="https://${EGO_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+ inherit golang-vcs-snapshot
+fi
+
+DESCRIPTION="command line extension and specification for managing large files with Git"
+HOMEPAGE="https://git-lfs.github.com/"
+
+LICENSE="MIT BSD BSD-2 BSD-4 Apache-2.0"
+SLOT="0"
+IUSE="+doc"
+
+DEPEND="doc? ( app-text/ronn )"
+RDEPEND="dev-vcs/git"
+
+S="${WORKDIR}/${P}/src/${EGO_PN}"
+
+src_compile() {
+ # can't use golang-build_src_compile for go generate
+ # and others steps executed by build.go
+ GOPATH="${WORKDIR}/${P}:$(get_golibdir_gopath)" \
+ go run script/*.go -cmd build || die "build failed"
+
+ if use doc; then
+ ronn docs/man/*.ronn || die "man building failed"
+ fi
+}
+
+src_install() {
+ dobin bin/git-lfs
+
+ use doc && doman docs/man/*.1
+}