summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-02-08 07:52:20 +0100
committerMichał Górny <mgorny@gentoo.org>2020-02-09 17:46:43 +0100
commit268e7267b6975aaefad9af9c93eda3e296cbeddf (patch)
treeac3826a40ae288c9c5ac9fdb71e3677249aebcb0
parentnet-misc/pytvshows: Switch to PYTHON_MULTI_USEDEP API (diff)
downloadgentoo-268e7267b6975aaefad9af9c93eda3e296cbeddf.tar.gz
gentoo-268e7267b6975aaefad9af9c93eda3e296cbeddf.tar.bz2
gentoo-268e7267b6975aaefad9af9c93eda3e296cbeddf.zip
net-misc/streamlink: Switch to PYTHON_MULTI_USEDEP API
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--net-misc/streamlink/streamlink-1.3.0-r1.ebuild (renamed from net-misc/streamlink/streamlink-1.3.0.ebuild)42
-rw-r--r--net-misc/streamlink/streamlink-9999.ebuild42
2 files changed, 46 insertions, 38 deletions
diff --git a/net-misc/streamlink/streamlink-1.3.0.ebuild b/net-misc/streamlink/streamlink-1.3.0-r1.ebuild
index 04417d2b4e75..28994a6a0f82 100644
--- a/net-misc/streamlink/streamlink-1.3.0.ebuild
+++ b/net-misc/streamlink/streamlink-1.3.0-r1.ebuild
@@ -30,31 +30,35 @@ RESTRICT="!test? ( test )"
# >=urllib3-1.23 only needed for python2, but requests pulls some version anyways, so we might as well guarantee at least that ver for py3 too
DEPEND="
- virtual/python-futures[${PYTHON_USEDEP}]
- virtual/python-singledispatch[${PYTHON_USEDEP}]
- >dev-python/requests-2.21.0[${PYTHON_USEDEP}]
- >=dev-python/urllib3-1.23[${PYTHON_USEDEP}]
- dev-python/isodate[${PYTHON_USEDEP}]
- dev-python/websocket-client[${PYTHON_USEDEP}]
- dev-python/pycountry[${PYTHON_USEDEP}]
- >=dev-python/pycryptodome-3.4.3[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ virtual/python-futures[${PYTHON_MULTI_USEDEP}]
+ virtual/python-singledispatch[${PYTHON_MULTI_USEDEP}]
+ >dev-python/requests-2.21.0[${PYTHON_MULTI_USEDEP}]
+ >=dev-python/urllib3-1.23[${PYTHON_MULTI_USEDEP}]
+ dev-python/isodate[${PYTHON_MULTI_USEDEP}]
+ dev-python/websocket-client[${PYTHON_MULTI_USEDEP}]
+ dev-python/pycountry[${PYTHON_MULTI_USEDEP}]
+ >=dev-python/pycryptodome-3.4.3[${PYTHON_MULTI_USEDEP}]
+ ')
"
RDEPEND="${DEPEND}
media-video/rtmpdump
virtual/ffmpeg
"
BDEPEND="
- doc? (
- dev-python/sphinx[${PYTHON_USEDEP}]
- dev-python/docutils[${PYTHON_USEDEP}]
- dev-python/recommonmark[${PYTHON_USEDEP}]
- )
- test? (
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/requests-mock[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/freezegun[${PYTHON_USEDEP}]
- )"
+ $(python_gen_cond_dep '
+ doc? (
+ dev-python/sphinx[${PYTHON_MULTI_USEDEP}]
+ dev-python/docutils[${PYTHON_MULTI_USEDEP}]
+ dev-python/recommonmark[${PYTHON_MULTI_USEDEP}]
+ )
+ test? (
+ dev-python/mock[${PYTHON_MULTI_USEDEP}]
+ dev-python/requests-mock[${PYTHON_MULTI_USEDEP}]
+ dev-python/pytest[${PYTHON_MULTI_USEDEP}]
+ dev-python/freezegun[${PYTHON_MULTI_USEDEP}]
+ )
+ ')"
python_configure_all() {
# Avoid iso-639, iso3166 dependencies since we use pycountry.
diff --git a/net-misc/streamlink/streamlink-9999.ebuild b/net-misc/streamlink/streamlink-9999.ebuild
index 04417d2b4e75..28994a6a0f82 100644
--- a/net-misc/streamlink/streamlink-9999.ebuild
+++ b/net-misc/streamlink/streamlink-9999.ebuild
@@ -30,31 +30,35 @@ RESTRICT="!test? ( test )"
# >=urllib3-1.23 only needed for python2, but requests pulls some version anyways, so we might as well guarantee at least that ver for py3 too
DEPEND="
- virtual/python-futures[${PYTHON_USEDEP}]
- virtual/python-singledispatch[${PYTHON_USEDEP}]
- >dev-python/requests-2.21.0[${PYTHON_USEDEP}]
- >=dev-python/urllib3-1.23[${PYTHON_USEDEP}]
- dev-python/isodate[${PYTHON_USEDEP}]
- dev-python/websocket-client[${PYTHON_USEDEP}]
- dev-python/pycountry[${PYTHON_USEDEP}]
- >=dev-python/pycryptodome-3.4.3[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ virtual/python-futures[${PYTHON_MULTI_USEDEP}]
+ virtual/python-singledispatch[${PYTHON_MULTI_USEDEP}]
+ >dev-python/requests-2.21.0[${PYTHON_MULTI_USEDEP}]
+ >=dev-python/urllib3-1.23[${PYTHON_MULTI_USEDEP}]
+ dev-python/isodate[${PYTHON_MULTI_USEDEP}]
+ dev-python/websocket-client[${PYTHON_MULTI_USEDEP}]
+ dev-python/pycountry[${PYTHON_MULTI_USEDEP}]
+ >=dev-python/pycryptodome-3.4.3[${PYTHON_MULTI_USEDEP}]
+ ')
"
RDEPEND="${DEPEND}
media-video/rtmpdump
virtual/ffmpeg
"
BDEPEND="
- doc? (
- dev-python/sphinx[${PYTHON_USEDEP}]
- dev-python/docutils[${PYTHON_USEDEP}]
- dev-python/recommonmark[${PYTHON_USEDEP}]
- )
- test? (
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/requests-mock[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/freezegun[${PYTHON_USEDEP}]
- )"
+ $(python_gen_cond_dep '
+ doc? (
+ dev-python/sphinx[${PYTHON_MULTI_USEDEP}]
+ dev-python/docutils[${PYTHON_MULTI_USEDEP}]
+ dev-python/recommonmark[${PYTHON_MULTI_USEDEP}]
+ )
+ test? (
+ dev-python/mock[${PYTHON_MULTI_USEDEP}]
+ dev-python/requests-mock[${PYTHON_MULTI_USEDEP}]
+ dev-python/pytest[${PYTHON_MULTI_USEDEP}]
+ dev-python/freezegun[${PYTHON_MULTI_USEDEP}]
+ )
+ ')"
python_configure_all() {
# Avoid iso-639, iso3166 dependencies since we use pycountry.