summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJaco Kroon <jaco@uls.co.za>2020-07-07 22:04:23 +0200
committerJoonas Niilola <juippis@gentoo.org>2020-07-20 12:01:20 +0300
commit26e51de2b65e3d32d4e2efa9bb493a5b75fa8c84 (patch)
treebe4bc2ad92fc6e8b786ea77837543efcfe538a2e
parentnet-libs/pjproject: fix invalid LD build issue. (diff)
downloadgentoo-26e51de2b65e3d32d4e2efa9bb493a5b75fa8c84.tar.gz
gentoo-26e51de2b65e3d32d4e2efa9bb493a5b75fa8c84.tar.bz2
gentoo-26e51de2b65e3d32d4e2efa9bb493a5b75fa8c84.zip
net-misc/dahdi-tools: Fixups for perl, and fixing man pages build.
dahdi-tools uses perl for some stuff, so add applicable RDEPEND. Build failure caused by lack of perl and build time, so install the tools required such that this absolute gem of how not to do it works (xpp/Makefile): 1377 %.8: % 1378 @if file "$^" | cut -d: -f2 | grep -q -iw perl; then \ 1379 if pod2man --section 8 $^ > $@; then \ 1380 echo " GEN $@"; \ 1381 else \ 1382 rm -f "$@"; \ 1383 fi \ 1384 fi Closes: https://bugs.gentoo.org/728544 Signed-off-by: Jaco Kroon <jaco@uls.co.za> Closes: https://github.com/gentoo/gentoo/pull/16629 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
-rw-r--r--net-misc/dahdi-tools/dahdi-tools-3.1.0.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/net-misc/dahdi-tools/dahdi-tools-3.1.0.ebuild b/net-misc/dahdi-tools/dahdi-tools-3.1.0.ebuild
index 6b9aa9aac2d7..a731c4859433 100644
--- a/net-misc/dahdi-tools/dahdi-tools-3.1.0.ebuild
+++ b/net-misc/dahdi-tools/dahdi-tools-3.1.0.ebuild
@@ -26,7 +26,11 @@ DEPEND="dev-libs/newt
sys-kernel/linux-headers
virtual/libusb:0
ppp? ( net-dialup/ppp )"
-RDEPEND="${DEPEND}"
+RDEPEND="${DEPEND}
+ dev-lang/perl:=
+ dev-perl/CGI"
+BDEPEND="dev-lang/perl
+ sys-apps/file"
src_prepare() {
default