summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-04-29 12:53:04 +0200
committerDavid Seifert <soap@gentoo.org>2017-04-29 18:26:37 +0200
commit275184f532d830217acc89734247f7196ee91815 (patch)
treece6129938cb453be3589074319e2b9419da17704
parentwww-misc/surl: Remove unnecessary overrides (diff)
downloadgentoo-275184f532d830217acc89734247f7196ee91815.tar.gz
gentoo-275184f532d830217acc89734247f7196ee91815.tar.bz2
gentoo-275184f532d830217acc89734247f7196ee91815.zip
dev-python/webpy: [QA] Fix python_test() to die on failure
Package-Manager: Portage-2.3.5, Repoman-2.3.2
-rw-r--r--dev-python/webpy/webpy-0.38.ebuild11
1 files changed, 5 insertions, 6 deletions
diff --git a/dev-python/webpy/webpy-0.38.ebuild b/dev-python/webpy/webpy-0.38.ebuild
index 48dce6b4ac4b..f289a598c081 100644
--- a/dev-python/webpy/webpy-0.38.ebuild
+++ b/dev-python/webpy/webpy-0.38.ebuild
@@ -17,13 +17,12 @@ LICENSE="public-domain"
SLOT="0"
KEYWORDS="~amd64 ~hppa ~x86 ~amd64-linux ~x86-linux"
-S="${WORKDIR}/web.py-${PV}"
+S="${WORKDIR}/${MY_PN}-${PV}"
python_test() {
- local return_status="0" test tests="db http net template utils"
- for test in ${tests}; do
- echo "Running doctests in ${test}.py..."
- "${PYTHON}" web/${test}.py || return_status="$?"
+ local t
+ for t in db http net template utils; do
+ einfo "Running doctests in ${t}.py..."
+ "${EPYTHON}" web/${t}.py || die "Test ${t} failed with ${EPYTHON}"
done
- return "${return_status}"
}