summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2022-01-16 10:37:57 +0100
committerPacho Ramos <pacho@gentoo.org>2022-01-16 10:38:06 +0100
commit277ef13c7bb383657ee4628b45a37b62f66eb20e (patch)
treed61f46ee1af6c9540c6e1cb504e30114422e94e6
parentdev-python/easyprocess: Bump to 1.1 (diff)
downloadgentoo-277ef13c7bb383657ee4628b45a37b62f66eb20e.tar.gz
gentoo-277ef13c7bb383657ee4628b45a37b62f66eb20e.tar.bz2
gentoo-277ef13c7bb383657ee4628b45a37b62f66eb20e.zip
net-wireless/bluez: Sync with upstream fixes
For bug #827706 Bug: https://bugs.gentoo.org/827706 Bug: https://bugs.gentoo.org/829091 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
-rw-r--r--net-wireless/bluez/bluez-5.63-r1.ebuild295
-rw-r--r--net-wireless/bluez/files/0001-hog-Fix-read-order-of-attributes-rediffed.patch542
-rw-r--r--net-wireless/bluez/files/0002-hog-Add-input-queue-while-uhid-device-has-not-been-c-rediffed.patch90
3 files changed, 927 insertions, 0 deletions
diff --git a/net-wireless/bluez/bluez-5.63-r1.ebuild b/net-wireless/bluez/bluez-5.63-r1.ebuild
new file mode 100644
index 000000000000..baad2b48deaf
--- /dev/null
+++ b/net-wireless/bluez/bluez-5.63-r1.ebuild
@@ -0,0 +1,295 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit autotools linux-info python-single-r1 readme.gentoo-r1 systemd udev multilib-minimal
+
+DESCRIPTION="Bluetooth Tools and System Daemons for Linux"
+HOMEPAGE="http://www.bluez.org"
+SRC_URI="https://www.kernel.org/pub/linux/bluetooth/${P}.tar.xz"
+
+LICENSE="GPL-2+ LGPL-2.1+"
+SLOT="0/3"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~riscv ~x86"
+IUSE="btpclient cups doc debug deprecated extra-tools experimental +mesh midi +obex +readline selinux systemd test test-programs +udev"
+
+# Since this release all remaining extra-tools need readline support, but this could
+# change in the future, hence, this REQUIRED_USE constraint could be dropped
+# again in the future.
+# btpclient needs mesh, bug #790587
+REQUIRED_USE="
+ extra-tools? ( deprecated readline )
+ test? ( ${PYTHON_REQUIRED_USE} )
+ test-programs? ( ${PYTHON_REQUIRED_USE} )
+"
+
+TEST_DEPS="${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ >=dev-python/dbus-python-1[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ ')
+"
+BDEPEND="
+ dev-python/docutils
+ virtual/pkgconfig
+ test? ( ${TEST_DEPS} )
+"
+DEPEND="
+ >=dev-libs/glib-2.28:2[${MULTILIB_USEDEP}]
+ btpclient? ( >=dev-libs/ell-0.39 )
+ cups? ( net-print/cups:= )
+ mesh? (
+ >=dev-libs/ell-0.39
+ >=dev-libs/json-c-0.13:=
+ sys-libs/readline:0=
+ )
+ midi? ( media-libs/alsa-lib )
+ obex? ( dev-libs/libical:= )
+ readline? ( sys-libs/readline:0= )
+ systemd? ( sys-apps/systemd )
+ >=sys-apps/dbus-1.6:=
+ udev? ( >=virtual/udev-172 )
+"
+RDEPEND="${DEPEND}
+ selinux? ( sec-policy/selinux-bluetooth )
+ test-programs? ( ${TEST_DEPS} )
+"
+
+RESTRICT="!test? ( test )"
+
+PATCHES=(
+ # Try both udevadm paths to cover udev/systemd vs. eudev locations (#539844)
+ # http://www.spinics.net/lists/linux-bluetooth/msg58739.html
+ # https://bugs.gentoo.org/539844
+ # https://github.com/bluez/bluez/issues/268
+ "${FILESDIR}"/${PN}-udevadm-path-r1.patch
+
+ # https://github.com/bluez/bluez/issues/267
+ "${FILESDIR}"/${PN}-5.63-musl-limits.patch
+
+ # Fedora patches
+ # http://www.spinics.net/lists/linux-bluetooth/msg40136.html
+ "${FILESDIR}"/0001-obex-Use-GLib-helper-function-to-manipulate-paths.patch
+
+ # https://github.com/bluez/bluez/issues/220
+ "${FILESDIR}"/0001-hog-Fix-read-order-of-attributes-rediffed.patch
+ "${FILESDIR}"/0002-hog-Add-input-queue-while-uhid-device-has-not-been-c-rediffed.patch
+)
+
+pkg_setup() {
+ # From http://www.linuxfromscratch.org/blfs/view/svn/general/bluez.html
+ # to prevent bugs like:
+ # https://bugzilla.kernel.org/show_bug.cgi?id=196621
+ CONFIG_CHECK="~NET ~BT ~BT_RFCOMM ~BT_RFCOMM_TTY ~BT_BNEP ~BT_BNEP_MC_FILTER
+ ~BT_BNEP_PROTO_FILTER ~BT_HIDP ~CRYPTO_USER_API_HASH ~CRYPTO_USER_API_SKCIPHER ~RFKILL"
+ # https://bugzilla.kernel.org/show_bug.cgi?id=196621
+ # https://bugzilla.kernel.org/show_bug.cgi?id=206815
+ if use mesh || use test; then
+ CONFIG_CHECK="${CONFIG_CHECK} ~CRYPTO_USER
+ ~CRYPTO_USER_API ~CRYPTO_USER_API_AEAD ~CRYPTO_AES ~CRYPTO_CCM ~CRYPTO_AEAD ~CRYPTO_CMAC
+ ~CRYPTO_MD5 ~CRYPTO_SHA1 ~KEY_DH_OPERATIONS"
+ fi
+ linux-info_pkg_setup
+
+ if use test || use test-programs; then
+ python-single-r1_pkg_setup
+ fi
+
+ if ! use udev; then
+ ewarn
+ ewarn "You are installing ${PN} with USE=-udev. This means various bluetooth"
+ ewarn "devices and adapters from Apple, Dell, Logitech etc. will not work,"
+ ewarn "and hid2hci will not be available."
+ ewarn
+ fi
+}
+
+src_prepare() {
+ default
+
+ # http://www.spinics.net/lists/linux-bluetooth/msg38490.html
+ if ! use systemd; then
+ eapply "${FILESDIR}"/0001-Allow-using-obexd-without-systemd-in-the-user-session-r2.patch
+ fi
+
+ eautoreconf
+
+ if use cups; then
+ # Only not .am to not need to run eautoreconf only because of this
+ sed -i \
+ -e "s:cupsdir = \$(libdir)/cups:cupsdir = $(cups-config --serverbin):" \
+ Makefile.{in,tools} || die
+ fi
+
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ local myconf=(
+ # readline is automagic when client is enabled
+ # --enable-client always needs readline, bug #504038
+ # --enable-mesh is handled in the same way
+ ac_cv_header_readline_readline_h=$(multilib_native_usex readline)
+ ac_cv_header_readline_readline_h=$(multilib_native_usex mesh)
+ )
+
+ if ! multilib_is_native_abi; then
+ myconf+=(
+ # deps not used for the library
+ {DBUS,GLIB}_{CFLAGS,LIBS}=' '
+ )
+ fi
+
+ econf \
+ --localstatedir=/var \
+ --disable-android \
+ --enable-datafiles \
+ --enable-optimization \
+ $(use_enable debug) \
+ --enable-pie \
+ --enable-threads \
+ --enable-library \
+ --enable-tools \
+ --enable-manpages \
+ --enable-monitor \
+ --with-systemdsystemunitdir="$(systemd_get_systemunitdir)" \
+ --with-systemduserunitdir="$(systemd_get_userunitdir)" \
+ $(multilib_native_use_enable btpclient) \
+ $(multilib_native_use_enable btpclient external-ell) \
+ $(multilib_native_use_enable cups) \
+ $(multilib_native_use_enable deprecated) \
+ $(multilib_native_use_enable experimental) \
+ $(multilib_native_use_enable mesh) \
+ $(multilib_native_use_enable mesh external-ell) \
+ $(multilib_native_use_enable midi) \
+ $(multilib_native_use_enable obex) \
+ $(multilib_native_use_enable readline client) \
+ $(multilib_native_use_enable systemd) \
+ $(multilib_native_use_enable test-programs test) \
+ $(multilib_native_use_enable udev) \
+ $(multilib_native_use_enable udev hid2hci) \
+ $(multilib_native_use_enable udev sixaxis)
+}
+
+multilib_src_compile() {
+ if multilib_is_native_abi; then
+ default
+ else
+ emake -f Makefile -f - libs \
+ <<<'libs: $(lib_LTLIBRARIES)'
+ fi
+}
+
+multilib_src_test() {
+ multilib_is_native_abi && default
+}
+
+multilib_src_install() {
+ if multilib_is_native_abi; then
+ emake DESTDIR="${D}" install
+
+ # Only install extra-tools when relevant USE flag is enabled
+ if use extra-tools; then
+ ewarn "Upstream doesn't support using this tools and their bugs are"
+ ewarn "likely to be ignored forever, also they can break without"
+ ewarn "previous announcement."
+ ewarn "Upstream also states all this tools are not really needed,"
+ ewarn "then, if you still need to rely on them, you must ask them"
+ ewarn "to either install that tool by default or add the needed"
+ ewarn "functionality to the existing 'official' tools."
+ ewarn "Please report this issues to:"
+ ewarn "http://www.bluez.org/development/lists/"
+
+ # Upstream doesn't install this, bug #524640
+ # http://permalink.gmane.org/gmane.linux.bluez.kernel/53115
+ # http://comments.gmane.org/gmane.linux.bluez.kernel/54564
+ dobin tools/btmgmt
+ # gatttool is only built with readline, bug #530776
+ # https://bugzilla.redhat.com/show_bug.cgi?id=1141909
+ # https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=720486
+ # https://bugs.archlinux.org/task/37686
+ dobin attrib/gatttool
+ # https://bugzilla.redhat.com/show_bug.cgi?id=1699680
+ dobin tools/avinfo
+ fi
+
+ # Not installed by default after being built, bug #666756
+ use btpclient && dobin tools/btpclient
+
+ # Unittests are not that useful once installed, so make them optional
+ if use test-programs; then
+ # Drop python2 only test tools
+ # https://bugzilla.kernel.org/show_bug.cgi?id=206819
+ rm "${ED}"/usr/$(get_libdir)/bluez/test/simple-player || die
+ # https://bugzilla.kernel.org/show_bug.cgi?id=206821
+ rm "${ED}"/usr/$(get_libdir)/bluez/test/test-hfp || die
+ # https://bugzilla.kernel.org/show_bug.cgi?id=206823
+ rm "${ED}"/usr/$(get_libdir)/bluez/test/test-sap-server || die
+
+ python_fix_shebang "${ED}"/usr/$(get_libdir)/bluez/test
+
+ for i in $(find "${ED}"/usr/$(get_libdir)/bluez/test -maxdepth 1 -type f ! -name "*.*"); do
+ dosym "${i}" /usr/bin/bluez-"${i##*/}"
+ done
+ fi
+ else
+ emake DESTDIR="${D}" \
+ install-pkgincludeHEADERS \
+ install-libLTLIBRARIES \
+ install-pkgconfigDATA
+ fi
+}
+
+multilib_src_install_all() {
+ # We need to ensure obexd can be spawned automatically by systemd
+ # when user-session is enabled:
+ # http://marc.info/?l=linux-bluetooth&m=148096094716386&w=2
+ # https://bugs.gentoo.org/show_bug.cgi?id=577842
+ # https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=804908
+ # https://bugs.archlinux.org/task/45816
+ # https://bugzilla.redhat.com/show_bug.cgi?id=1318441
+ # https://bugzilla.redhat.com/show_bug.cgi?id=1389347
+ if use systemd; then
+ dosym obex.service /usr/lib/systemd/user/dbus-org.bluez.obex.service
+ fi
+
+ find "${D}" -name '*.la' -type f -delete || die
+
+ keepdir /var/lib/bluetooth
+
+ # Upstream don't want people to play with them
+ # But we keep installing them due to 'historical' reasons
+ insinto /etc/bluetooth
+ local d
+ for d in input network; do
+ doins profiles/${d}/${d}.conf
+ done
+ # Setup auto enable as Fedora does for allowing to use
+ # keyboards/mouse as soon as possible
+ sed -i 's/#\[Policy\]$/\[Policy\]/; s/#AutoEnable=false/AutoEnable=true/' src/main.conf || die
+ doins src/main.conf
+
+ newinitd "${FILESDIR}"/bluetooth-init.d-r5 bluetooth
+ newconfd "${FILESDIR}"/bluetooth-conf.d bluetooth
+
+ einstalldocs
+ use doc && dodoc doc/*.txt
+ # Install .json files as examples to be used by meshctl
+ if use mesh; then
+ dodoc tools/mesh-gatt/*.json
+ local DOC_CONTENTS="Some example .json files were installed into
+ /usr/share/doc/${PF} to be used with meshctl. Feel free to
+ uncompress and copy them to ~/.config/meshctl to use them."
+ readme.gentoo_create_doc
+ fi
+}
+
+pkg_postinst() {
+ use udev && udev_reload
+ systemd_reenable bluetooth.service
+
+ has_version net-dialup/ppp || elog "To use dial up networking you must install net-dialup/ppp"
+ use mesh && readme.gentoo_print_elog
+}
diff --git a/net-wireless/bluez/files/0001-hog-Fix-read-order-of-attributes-rediffed.patch b/net-wireless/bluez/files/0001-hog-Fix-read-order-of-attributes-rediffed.patch
new file mode 100644
index 000000000000..cd6dc44b5d3e
--- /dev/null
+++ b/net-wireless/bluez/files/0001-hog-Fix-read-order-of-attributes-rediffed.patch
@@ -0,0 +1,542 @@
+From 7fe38a17f6bee713fde587487fc224b0ae390e8f Mon Sep 17 00:00:00 2001
+From: Luiz Augusto von Dentz <luiz.von.dentz@intel.com>
+Date: Mon, 10 Jan 2022 17:35:15 -0800
+Subject: [PATCH 1/2] hog: Fix read order of attributes
+
+The Report Map must be read after all other attributes otherwise the
+Kernel driver may start using UHID_SET_REPORT which requires the
+report->id to be known in order to resolve the attribute to send to.
+
+Fixes: https://github.com/bluez/bluez/issues/220
+---
+ profiles/input/hog-lib.c | 191 ++++++++++++++++++++++++---------------
+ 1 file changed, 119 insertions(+), 72 deletions(-)
+
+diff --git a/profiles/input/hog-lib.c b/profiles/input/hog-lib.c
+index d37caa1f1..beb19af70 100644
+--- a/profiles/input/hog-lib.c
++++ b/profiles/input/hog-lib.c
+@@ -90,6 +90,7 @@ struct bt_hog {
+ uint16_t getrep_id;
+ unsigned int setrep_att;
+ uint16_t setrep_id;
++ unsigned int report_map_id;
+ struct bt_scpp *scpp;
+ struct bt_dis *dis;
+ struct queue *bas;
+@@ -146,13 +147,34 @@ static bool set_and_store_gatt_req(struct bt_hog *hog,
+ return queue_push_head(hog->gatt_op, req);
+ }
+
+-static void destroy_gatt_req(struct gatt_request *req)
++static void destroy_gatt_req(void *data)
+ {
+- queue_remove(req->hog->gatt_op, req);
++ struct gatt_request *req = data;
++
+ bt_hog_unref(req->hog);
+ free(req);
+ }
+
++static void read_report_map(struct bt_hog *hog);
++
++static void remove_gatt_req(struct gatt_request *req, uint8_t status)
++{
++ struct bt_hog *hog = req->hog;
++
++ queue_remove(hog->gatt_op, req);
++
++ if (!status && queue_isempty(hog->gatt_op)) {
++ /* Report Map must be read last since that can result
++ * in uhid being created and the driver may start to
++ * use UHID_SET_REPORT which requires the report->id to
++ * be known what attribute to send to.
++ */
++ read_report_map(hog);
++ }
++
++ destroy_gatt_req(req);
++}
++
+ static void write_char(struct bt_hog *hog, GAttrib *attrib, uint16_t handle,
+ const uint8_t *value, size_t vlen,
+ GAttribResultFunc func,
+@@ -178,27 +200,31 @@ static void write_char(struct bt_hog *hog, GAttrib *attrib, uint16_t handle,
+ }
+ }
+
+-static void read_char(struct bt_hog *hog, GAttrib *attrib, uint16_t handle,
+- GAttribResultFunc func, gpointer user_data)
++static unsigned int read_char(struct bt_hog *hog, GAttrib *attrib,
++ uint16_t handle, GAttribResultFunc func,
++ gpointer user_data)
+ {
+ struct gatt_request *req;
+ unsigned int id;
+
+ req = create_request(hog, user_data);
+ if (!req)
+- return;
++ return 0;
+
+ id = gatt_read_char(attrib, handle, func, req);
+ if (!id) {
+ error("hog: Could not read char");
+- return;
++ return 0;
+ }
+
+ if (!set_and_store_gatt_req(hog, req, id)) {
+ error("hog: Failed to queue read char req");
+ g_attrib_cancel(attrib, id);
+ free(req);
++ return 0;
+ }
++
++ return id;
+ }
+
+ static void discover_desc(struct bt_hog *hog, GAttrib *attrib,
+@@ -343,16 +369,14 @@ static void report_ccc_written_cb(guint8 status, const guint8 *pdu,
+ struct report *report = req->user_data;
+ struct bt_hog *hog = report->hog;
+
+- destroy_gatt_req(req);
+-
+ if (status != 0) {
+ error("Write report characteristic descriptor failed: %s",
+ att_ecode2str(status));
+- return;
++ goto remove;
+ }
+
+ if (report->notifyid)
+- return;
++ goto remove;
+
+ report->notifyid = g_attrib_register(hog->attrib,
+ ATT_OP_HANDLE_NOTIFY,
+@@ -360,6 +384,9 @@ static void report_ccc_written_cb(guint8 status, const guint8 *pdu,
+ report_value_cb, report, NULL);
+
+ DBG("Report characteristic descriptor written: notifications enabled");
++
++remove:
++ remove_gatt_req(req, status);
+ }
+
+ static void write_ccc(struct bt_hog *hog, GAttrib *attrib, uint16_t handle,
+@@ -379,14 +406,15 @@ static void ccc_read_cb(guint8 status, const guint8 *pdu, guint16 len,
+ struct gatt_request *req = user_data;
+ struct report *report = req->user_data;
+
+- destroy_gatt_req(req);
+-
+ if (status != 0) {
+ error("Error reading CCC value: %s", att_ecode2str(status));
+- return;
++ goto remove;
+ }
+
+ write_ccc(report->hog, report->hog->attrib, report->ccc_handle, report);
++
++remove:
++ remove_gatt_req(req, status);
+ }
+
+ static const char *type_to_string(uint8_t type)
+@@ -409,17 +437,15 @@ static void report_reference_cb(guint8 status, const guint8 *pdu,
+ struct gatt_request *req = user_data;
+ struct report *report = req->user_data;
+
+- destroy_gatt_req(req);
+-
+ if (status != 0) {
+ error("Read Report Reference descriptor failed: %s",
+ att_ecode2str(status));
+- return;
++ goto remove;
+ }
+
+ if (plen != 3) {
+ error("Malformed ATT read response");
+- return;
++ goto remove;
+ }
+
+ report->id = pdu[1];
+@@ -432,6 +458,9 @@ static void report_reference_cb(guint8 status, const guint8 *pdu,
+ if (report->type == HOG_REPORT_TYPE_INPUT)
+ read_char(report->hog, report->hog->attrib, report->ccc_handle,
+ ccc_read_cb, report);
++
++remove:
++ remove_gatt_req(req, status);
+ }
+
+ static void external_report_reference_cb(guint8 status, const guint8 *pdu,
+@@ -442,12 +471,10 @@ static void discover_external_cb(uint8_t status, GSList *descs, void *user_data)
+ struct gatt_request *req = user_data;
+ struct bt_hog *hog = req->user_data;
+
+- destroy_gatt_req(req);
+-
+ if (status != 0) {
+ error("Discover external descriptors failed: %s",
+ att_ecode2str(status));
+- return;
++ goto remove;
+ }
+
+ for ( ; descs; descs = descs->next) {
+@@ -457,6 +484,9 @@ static void discover_external_cb(uint8_t status, GSList *descs, void *user_data)
+ external_report_reference_cb,
+ hog);
+ }
++
++remove:
++ remove_gatt_req(req, status);
+ }
+
+ static void discover_external(struct bt_hog *hog, GAttrib *attrib,
+@@ -480,12 +510,10 @@ static void discover_report_cb(uint8_t status, GSList *descs, void *user_data)
+ struct report *report = req->user_data;
+ struct bt_hog *hog = report->hog;
+
+- destroy_gatt_req(req);
+-
+ if (status != 0) {
+ error("Discover report descriptors failed: %s",
+ att_ecode2str(status));
+- return;
++ goto remove;
+ }
+
+ for ( ; descs; descs = descs->next) {
+@@ -501,6 +529,9 @@ static void discover_report_cb(uint8_t status, GSList *descs, void *user_data)
+ break;
+ }
+ }
++
++remove:
++ remove_gatt_req(req, status);
+ }
+
+ static void discover_report(struct bt_hog *hog, GAttrib *attrib,
+@@ -519,11 +550,9 @@ static void report_read_cb(guint8 status, const guint8 *pdu, guint16 len,
+ struct gatt_request *req = user_data;
+ struct report *report = req->user_data;
+
+- destroy_gatt_req(req);
+-
+ if (status != 0) {
+ error("Error reading Report value: %s", att_ecode2str(status));
+- return;
++ goto remove;
+ }
+
+ if (report->value)
+@@ -531,6 +560,9 @@ static void report_read_cb(guint8 status, const guint8 *pdu, guint16 len,
+
+ report->value = g_memdup2(pdu, len);
+ report->len = len;
++
++remove:
++ remove_gatt_req(req, status);
+ }
+
+ static int report_chrc_cmp(const void *data, const void *user_data)
+@@ -572,12 +604,11 @@ static void external_service_char_cb(uint8_t status, GSList *chars,
+ struct report *report;
+ GSList *l;
+
+- destroy_gatt_req(req);
+-
+ if (status != 0) {
+ const char *str = att_ecode2str(status);
++
+ DBG("Discover external service characteristic failed: %s", str);
+- return;
++ goto remove;
+ }
+
+ for (l = chars; l; l = g_slist_next(l)) {
+@@ -595,6 +626,9 @@ static void external_service_char_cb(uint8_t status, GSList *chars,
+ end = (next ? next->handle - 1 : primary->range.end);
+ discover_report(hog, hog->attrib, start, end, report);
+ }
++
++remove:
++ remove_gatt_req(req, status);
+ }
+
+ static void external_report_reference_cb(guint8 status, const guint8 *pdu,
+@@ -605,17 +639,15 @@ static void external_report_reference_cb(guint8 status, const guint8 *pdu,
+ uint16_t uuid16;
+ bt_uuid_t uuid;
+
+- destroy_gatt_req(req);
+-
+ if (status != 0) {
+ error("Read External Report Reference descriptor failed: %s",
+ att_ecode2str(status));
+- return;
++ goto remove;
+ }
+
+ if (plen != 3) {
+ error("Malformed ATT read response");
+- return;
++ goto remove;
+ }
+
+ uuid16 = get_le16(&pdu[1]);
+@@ -624,11 +656,14 @@ static void external_report_reference_cb(guint8 status, const guint8 *pdu,
+
+ /* Do not discover if is not a Report */
+ if (uuid16 != HOG_REPORT_UUID)
+- return;
++ goto remove;
+
+ bt_uuid16_create(&uuid, uuid16);
+ discover_char(hog, hog->attrib, 0x0001, 0xffff, &uuid,
+ external_service_char_cb, hog);
++
++remove:
++ remove_gatt_req(req, status);
+ }
+
+ static int report_cmp(gconstpointer a, gconstpointer b)
+@@ -687,12 +722,10 @@ static void output_written_cb(guint8 status, const guint8 *pdu,
+ {
+ struct gatt_request *req = user_data;
+
+- destroy_gatt_req(req);
+-
+- if (status != 0) {
++ if (status != 0)
+ error("Write output report failed: %s", att_ecode2str(status));
+- return;
+- }
++
++ remove_gatt_req(req, status);
+ }
+
+ static void forward_report(struct uhid_event *ev, void *user_data)
+@@ -1056,7 +1089,7 @@ static void report_map_read_cb(guint8 status, const guint8 *pdu, guint16 plen,
+ uint8_t value[HOG_REPORT_MAP_MAX_SIZE];
+ ssize_t vlen;
+
+- destroy_gatt_req(req);
++ remove_gatt_req(req, status);
+
+ DBG("HoG inspecting report map");
+
+@@ -1081,6 +1114,19 @@ static void report_map_read_cb(guint8 status, const guint8 *pdu, guint16 plen,
+ }
+ }
+
++static void read_report_map(struct bt_hog *hog)
++{
++ uint16_t handle;
++
++ if (!hog->report_map_attr || hog->uhid_created || hog->report_map_id)
++ return;
++
++ handle = gatt_db_attribute_get_handle(hog->report_map_attr);
++
++ hog->report_map_id = read_char(hog, hog->attrib, handle,
++ report_map_read_cb, hog);
++}
++
+ static void info_read_cb(guint8 status, const guint8 *pdu, guint16 plen,
+ gpointer user_data)
+ {
+@@ -1089,18 +1135,16 @@ static void info_read_cb(guint8 status, const guint8 *pdu, guint16 plen,
+ uint8_t value[HID_INFO_SIZE];
+ ssize_t vlen;
+
+- destroy_gatt_req(req);
+-
+ if (status != 0) {
+ error("HID Information read failed: %s",
+ att_ecode2str(status));
+- return;
++ goto remove;
+ }
+
+ vlen = dec_read_resp(pdu, plen, value, sizeof(value));
+ if (vlen != 4) {
+ error("ATT protocol error");
+- return;
++ goto remove;
+ }
+
+ hog->bcdhid = get_le16(&value[0]);
+@@ -1109,6 +1153,9 @@ static void info_read_cb(guint8 status, const guint8 *pdu, guint16 plen,
+
+ DBG("bcdHID: 0x%04X bCountryCode: 0x%02X Flags: 0x%02X",
+ hog->bcdhid, hog->bcountrycode, hog->flags);
++
++remove:
++ remove_gatt_req(req, status);
+ }
+
+ static void proto_mode_read_cb(guint8 status, const guint8 *pdu, guint16 plen,
+@@ -1119,18 +1166,16 @@ static void proto_mode_read_cb(guint8 status, const guint8 *pdu, guint16 plen,
+ uint8_t value;
+ ssize_t vlen;
+
+- destroy_gatt_req(req);
+-
+ if (status != 0) {
+ error("Protocol Mode characteristic read failed: %s",
+ att_ecode2str(status));
+- return;
++ goto remove;
+ }
+
+ vlen = dec_read_resp(pdu, plen, &value, sizeof(value));
+ if (vlen < 0) {
+ error("ATT protocol error");
+- return;
++ goto remove;
+ }
+
+ if (value == HOG_PROTO_MODE_BOOT) {
+@@ -1142,6 +1187,9 @@ static void proto_mode_read_cb(guint8 status, const guint8 *pdu, guint16 plen,
+ sizeof(nval), NULL, NULL);
+ } else if (value == HOG_PROTO_MODE_REPORT)
+ DBG("HoG is operating in Report Protocol Mode");
++
++remove:
++ remove_gatt_req(req, status);
+ }
+
+ static void char_discovered_cb(uint8_t status, GSList *chars, void *user_data)
+@@ -1155,14 +1203,12 @@ static void char_discovered_cb(uint8_t status, GSList *chars, void *user_data)
+ GSList *l;
+ uint16_t info_handle = 0, proto_mode_handle = 0;
+
+- destroy_gatt_req(req);
+-
+ DBG("HoG inspecting characteristics");
+
+ if (status != 0) {
+- const char *str = att_ecode2str(status);
+- DBG("Discover all characteristics failed: %s", str);
+- return;
++ DBG("Discover all characteristics failed: %s",
++ att_ecode2str(status));
++ goto remove;
+ }
+
+ bt_uuid16_create(&report_uuid, HOG_REPORT_UUID);
+@@ -1211,6 +1257,9 @@ static void char_discovered_cb(uint8_t status, GSList *chars, void *user_data)
+
+ if (info_handle)
+ read_char(hog, hog->attrib, info_handle, info_read_cb, hog);
++
++remove:
++ remove_gatt_req(req, status);
+ }
+
+ static void report_free(void *data)
+@@ -1221,10 +1270,12 @@ static void report_free(void *data)
+ g_free(report);
+ }
+
+-static void cancel_gatt_req(struct gatt_request *req)
++static bool cancel_gatt_req(const void *data, const void *user_data)
+ {
+- if (g_attrib_cancel(req->hog->attrib, req->id))
+- destroy_gatt_req(req);
++ struct gatt_request *req = (void *) data;
++ const struct bt_hog *hog = user_data;
++
++ return g_attrib_cancel(hog->attrib, req->id);
+ }
+
+ static void hog_free(void *data)
+@@ -1386,13 +1437,9 @@ static void foreach_hog_chrc(struct gatt_db_attribute *attr, void *user_data)
+ * UHID to optimize reconnection.
+ */
+ uhid_create(hog, report_map.value, report_map.length);
+- } else {
+- read_char(hog, hog->attrib, value_handle,
+- report_map_read_cb, hog);
+ }
+
+ gatt_db_service_foreach_desc(attr, foreach_hog_external, hog);
+- return;
+ }
+
+ bt_uuid16_create(&info_uuid, HOG_INFO_UUID);
+@@ -1552,12 +1599,9 @@ static void find_included_cb(uint8_t status, GSList *services, void *user_data)
+
+ DBG("");
+
+- destroy_gatt_req(req);
+-
+ if (status) {
+- const char *str = att_ecode2str(status);
+- DBG("Find included failed: %s", str);
+- return;
++ DBG("Find included failed: %s", att_ecode2str(status));
++ goto remove;
+ }
+
+ for (l = services; l; l = l->next) {
+@@ -1566,6 +1610,9 @@ static void find_included_cb(uint8_t status, GSList *services, void *user_data)
+ DBG("included: handle %x, uuid %s",
+ include->handle, include->uuid);
+ }
++
++remove:
++ remove_gatt_req(req, status);
+ }
+
+ static void hog_attach_scpp(struct bt_hog *hog, struct gatt_primary *primary)
+@@ -1640,17 +1687,14 @@ static void primary_cb(uint8_t status, GSList *services, void *user_data)
+
+ DBG("");
+
+- destroy_gatt_req(req);
+-
+ if (status) {
+- const char *str = att_ecode2str(status);
+- DBG("Discover primary failed: %s", str);
+- return;
++ DBG("Discover primary failed: %s", att_ecode2str(status));
++ goto remove;
+ }
+
+ if (!services) {
+ DBG("No primary service found");
+- return;
++ goto remove;
+ }
+
+ for (l = services; l; l = l->next) {
+@@ -1674,6 +1718,9 @@ static void primary_cb(uint8_t status, GSList *services, void *user_data)
+ if (strcmp(primary->uuid, HOG_UUID) == 0)
+ hog_attach_hog(hog, primary);
+ }
++
++remove:
++ remove_gatt_req(req, status);
+ }
+
+ bool bt_hog_attach(struct bt_hog *hog, void *gatt)
+@@ -1790,7 +1837,7 @@ void bt_hog_detach(struct bt_hog *hog)
+ if (hog->dis)
+ bt_dis_detach(hog->dis);
+
+- queue_foreach(hog->gatt_op, (void *) cancel_gatt_req, NULL);
++ queue_remove_all(hog->gatt_op, cancel_gatt_req, hog, destroy_gatt_req);
+ g_attrib_unref(hog->attrib);
+ hog->attrib = NULL;
+ uhid_destroy(hog);
+--
+2.34.1
+
diff --git a/net-wireless/bluez/files/0002-hog-Add-input-queue-while-uhid-device-has-not-been-c-rediffed.patch b/net-wireless/bluez/files/0002-hog-Add-input-queue-while-uhid-device-has-not-been-c-rediffed.patch
new file mode 100644
index 000000000000..f39775785f4a
--- /dev/null
+++ b/net-wireless/bluez/files/0002-hog-Add-input-queue-while-uhid-device-has-not-been-c-rediffed.patch
@@ -0,0 +1,90 @@
+From 33d13bbc5703185ab3f15e4429df324987f3f225 Mon Sep 17 00:00:00 2001
+From: Luiz Augusto von Dentz <luiz.von.dentz@intel.com>
+Date: Wed, 12 Jan 2022 14:07:36 -0800
+Subject: [PATCH 2/2] hog: Add input queue while uhid device has not been
+ created
+
+Since report map is only read after all reports it is possible to start
+receiving notifications before uhid has been created, so this adds a
+queue to store the events while the report map is pending and once uhid
+has been created dequeue the events.
+---
+ profiles/input/hog-lib.c | 32 +++++++++++++++++++++++++++++---
+ 1 file changed, 29 insertions(+), 3 deletions(-)
+
+diff --git a/profiles/input/hog-lib.c b/profiles/input/hog-lib.c
+index beb19af70..0b375feb8 100644
+--- a/profiles/input/hog-lib.c
++++ b/profiles/input/hog-lib.c
+@@ -98,6 +98,7 @@ struct bt_hog {
+ struct queue *gatt_op;
+ struct gatt_db *gatt_db;
+ struct gatt_db_attribute *report_map_attr;
++ struct queue *input;
+ };
+
+ struct report_map {
+@@ -355,11 +356,18 @@ static void report_value_cb(const guint8 *pdu, guint16 len, gpointer user_data)
+ ev.u.input.size = len;
+ }
+
+- err = bt_uhid_send(hog->uhid, &ev);
+- if (err < 0) {
+- error("bt_uhid_send: %s (%d)", strerror(-err), -err);
++ /* If uhid had not been created yet queue up the input */
++ if (!hog->uhid_created) {
++ if (!hog->input)
++ hog->input = queue_new();
++
++ queue_push_tail(hog->input, g_memdup(&ev, sizeof(ev)));
+ return;
+ }
++
++ err = bt_uhid_send(hog->uhid, &ev);
++ if (err < 0)
++ error("bt_uhid_send: %s (%d)", strerror(-err), -err);
+ }
+
+ static void report_ccc_written_cb(guint8 status, const guint8 *pdu,
+@@ -993,6 +1001,21 @@ static char *item2string(char *str, uint8_t *buf, uint8_t len)
+ return str;
+ }
+
++static bool input_dequeue(const void *data, const void *match_data)
++{
++ const struct uhid_event *ev = data;
++ const struct bt_hog *hog = match_data;
++ int err;
++
++ err = bt_uhid_send(hog->uhid, ev);
++ if (err < 0) {
++ error("bt_uhid_send: %s (%d)", strerror(-err), -err);
++ return false;
++ }
++
++ return true;
++}
++
+ static void uhid_create(struct bt_hog *hog, uint8_t *report_map,
+ ssize_t report_map_len)
+ {
+@@ -1072,6 +1095,8 @@ static void uhid_create(struct bt_hog *hog, uint8_t *report_map,
+ hog->uhid_created = true;
+
+ DBG("HoG created uHID device");
++
++ queue_remove_all(hog->input, input_dequeue, hog, free);
+ }
+
+ static void db_report_map_write_value_cb(struct gatt_db_attribute *attr,
+@@ -1284,6 +1309,7 @@ static void hog_free(void *data)
+
+ bt_hog_detach(hog);
+
++ queue_destroy(hog->input, free);
+ queue_destroy(hog->bas, (void *) bt_bas_unref);
+ g_slist_free_full(hog->instances, hog_free);
+
+--
+2.34.1
+