summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2016-10-28 14:43:05 +0200
committerPatrick Lauer <patrick@gentoo.org>2016-10-28 14:43:47 +0200
commit289ef6b52e20da9318e2e879ad52bd61ab4d2aa7 (patch)
tree7575ca992986913bdb3f59a6d1c29a1c25efd82f
parentnet-analyzer/zabbix: Add init script for JMX proxy (diff)
downloadgentoo-289ef6b52e20da9318e2e879ad52bd61ab4d2aa7.tar.gz
gentoo-289ef6b52e20da9318e2e879ad52bd61ab4d2aa7.tar.bz2
gentoo-289ef6b52e20da9318e2e879ad52bd61ab4d2aa7.zip
net-misc/kafka-bin: Create logs directory on install to avoid automatic creation with root owner
Package-Manager: portage-2.3.2
-rw-r--r--net-misc/kafka-bin/kafka-bin-0.10.1.0-r1.ebuild63
1 files changed, 63 insertions, 0 deletions
diff --git a/net-misc/kafka-bin/kafka-bin-0.10.1.0-r1.ebuild b/net-misc/kafka-bin/kafka-bin-0.10.1.0-r1.ebuild
new file mode 100644
index 000000000000..89d1b4be2f02
--- /dev/null
+++ b/net-misc/kafka-bin/kafka-bin-0.10.1.0-r1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+inherit eutils user
+
+DESCRIPTION="A high-throughput distributed messaging system"
+HOMEPAGE="http://kafka.apache.org/"
+
+# pick recommended scala version
+SCALA_VERSION=2.11
+MY_PN="kafka"
+MY_P="${MY_PN}_${SCALA_VERSION}-${PV}"
+SRC_URI="mirror://apache/kafka/${PV}/${MY_P}.tgz"
+
+RESTRICT="mirror"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="internal-zookeeper"
+
+RDEPEND="
+ || ( virtual/jre:1.8 virtual/jre:1.7 )
+"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+INSTALL_DIR="/opt/${MY_PN}"
+
+pkg_setup() {
+ enewgroup kafka
+ enewuser kafka -1 /bin/sh /var/lib/kafka kafka
+}
+
+src_prepare() {
+ sed -i -e 's:/tmp/zookeeper:/var/lib/kafka/zookeeper:' "config/zookeeper.properties" || die
+ sed -i -e 's:/tmp/kafka-logs:/var/lib/kafka/logs:' "config/server.properties" || die
+}
+
+src_install() {
+ insinto /etc/kafka
+ doins config/zookeeper.properties config/server.properties
+ if use "internal-zookeeper"; then
+ keepdir /var/lib/kafka/zookeeper
+ newinitd "${FILESDIR}/${MY_PN}-zookeeper.init.d" "${MY_PN}-zookeeper"
+ fi
+
+ keepdir /var/lib/kafka
+ fowners -R kafka:kafka /var/lib/kafka
+
+ keepdir /var/log/kafka
+ fowners -R kafka:kafka /var/log/kafka
+
+ newinitd "${FILESDIR}/${MY_PN}.init.d" "${MY_PN}"
+
+ dodir "${INSTALL_DIR}"
+ cp -pRP bin config libs "${ED}/${INSTALL_DIR}" || die
+ keepdir "${INSTALL_DIR}/logs"
+ fowners -R kafka:kafka "${INSTALL_DIR}"
+}