summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2019-03-26 15:14:27 -0700
committerPatrick McLean <chutzpah@gentoo.org>2019-03-26 18:07:09 -0700
commit291e2cf92cb682c30c53ddf9bdf949e2c615d0db (patch)
tree1883b719f59e4c365baa1a988c76cf542c2b42b9
parentdev-python/objgraph: Version bump to 3.4.0 (diff)
downloadgentoo-291e2cf92cb682c30c53ddf9bdf949e2c615d0db.tar.gz
gentoo-291e2cf92cb682c30c53ddf9bdf949e2c615d0db.tar.bz2
gentoo-291e2cf92cb682c30c53ddf9bdf949e2c615d0db.zip
dev-python/kazoo: Version bumpt to 3.4.0
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
-rw-r--r--dev-python/kazoo/Manifest1
-rw-r--r--dev-python/kazoo/kazoo-2.6.1.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/kazoo/Manifest b/dev-python/kazoo/Manifest
index fc49ed6e4391..198e3cec410b 100644
--- a/dev-python/kazoo/Manifest
+++ b/dev-python/kazoo/Manifest
@@ -1,2 +1,3 @@
DIST kazoo-2.2.1.tar.gz 108037 BLAKE2B 23b6b762469df40304cb0d9228dee63875e7c062557e0dcfd383db792c7544b19fbb4fc91a62035a2455b5a2715a57bcd4a68521cf698f01815cec20765420c8 SHA512 a2590441a9e3bfb3d14913051453e195d275b82bd6a4ce5e32d0a7bbc09b00e475ffac68fd06cb065aa439ea580b61bbeaa3ccfefa413723e46f4b1d3ce05707
DIST kazoo-2.5.0.tar.gz 147189 BLAKE2B f90662d78698d4ba8c9a88cd4eba826df104dd746323ce92644707e22ab711ca5fafb79bbec71c4059637232eab4b510b9544871201ba8d6758618d5a79f97c8 SHA512 cb85a33f2d0aa71fc5a82e7046e5d331417df865c1a4bc18266cee65ffd6c36e12cd4058ee591214ec83225a9b3ee193587f3d07b5c1436cc715a403364ec1af
+DIST kazoo-2.6.1.tar.gz 157425 BLAKE2B af05ee5fb1d532ebc3352de004062f1ff976825f564212f2db76efc153566106ffa520745a8e8cc6a78ca2bf0d17556f978a6b462e4153e9b3ee5258e78a1d82 SHA512 613e8271bfd6c8f5ee976b6ee460478c7faad46b32995125a64312208b38755888690cd46b913ff44ba52aeb36de3ec3dd8e222985af77e99f43963a3eb48d48
diff --git a/dev-python/kazoo/kazoo-2.6.1.ebuild b/dev-python/kazoo/kazoo-2.6.1.ebuild
new file mode 100644
index 000000000000..d022ee5b2a43
--- /dev/null
+++ b/dev-python/kazoo/kazoo-2.6.1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="A high-level Python library that makes it easier to use Apache Zookeeper"
+HOMEPAGE="https://kazoo.readthedocs.org/ https://github.com/python-zk/kazoo/ https://pypi.org/project/kazoo/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="doc gevent test"
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ gevent? ( dev-python/gevent[$(python_gen_usedep 'python2*')] )
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/graphviz[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep dev-python/eventlet 'python2*')
+ $(python_gen_cond_dep dev-python/gevent 'python2*')
+ >=dev-python/objgraph-3.4.0[${PYTHON_USEDEP}]
+ )
+"
+
+# requires zookeeper running to test
+RESTRICT="test"
+
+python_compile_all() {
+ if use doc; then
+ sphinx-build -b html docs docs/_build/html || die
+ fi
+}
+
+python_test() {
+ ZOOKEEPER_VERSION="2.6.1" esetup.py test || die
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ local DOCS=( {CHANGES,CONTRIBUTING,README}.md )
+ distutils-r1_python_install_all
+}