summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVirgil Dupras <vdupras@gentoo.org>2018-11-18 16:59:53 -0500
committerVirgil Dupras <vdupras@gentoo.org>2018-11-18 16:59:53 -0500
commit2b16f5fcbdfab1bb434b1d6cb0be04bfd9ae2905 (patch)
tree8bd251e276b1baceb132991568feb127333f2b4f
parentdev-python/filelock: add missing Manifest (diff)
downloadgentoo-2b16f5fcbdfab1bb434b1d6cb0be04bfd9ae2905.tar.gz
gentoo-2b16f5fcbdfab1bb434b1d6cb0be04bfd9ae2905.tar.bz2
gentoo-2b16f5fcbdfab1bb434b1d6cb0be04bfd9ae2905.zip
dev-python/diskcache: bump to 3.1.0
Previous version didn't support newer django. Also, add missing "sqlite" in PYTHON_REQ_USE. Closes: https://bugs.gentoo.org/636554 Closes: https://bugs.gentoo.org/636406 Signed-off-by: Virgil Dupras <vdupras@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
-rw-r--r--dev-python/diskcache/Manifest1
-rw-r--r--dev-python/diskcache/diskcache-3.1.0.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/diskcache/Manifest b/dev-python/diskcache/Manifest
index d298e00b93ab..e16bb839277f 100644
--- a/dev-python/diskcache/Manifest
+++ b/dev-python/diskcache/Manifest
@@ -1 +1,2 @@
DIST diskcache-2.8.3.tar.gz 438587 BLAKE2B 3b7b50fe6cabe8a4eb92b3dd72a2b99d6cedc8b7d055fcdf7b445f016957e6c7692571e9f83aafe36141b69a0e93f638b9e3e2f210bb56e6358260a5ff4130d3 SHA512 d96ac76dfb68cb817febd3f4ed8927a8409c02b13b4112a739528cade40f9a588c732dfc3148392dd12676380c3a2b006ee63b86f30ad70f5d205273003bf23d
+DIST diskcache-3.1.0.tar.gz 489821 BLAKE2B 56b54662f31172f4f746ce885d57a3e9f34af9d7318300fe6906aee1b3373919f6ee33922ab30b7979cc6e271f2f780894438b4114483a7c76f198fb7b2213c1 SHA512 30ea3e6c1ed6430c1a7e3bf022bd9233e89a2486308d1f48f6e2f0b50ccc1ee50dade7c55d98a5611ef384bd193cd28f7e65f5737bae00845b17c159177dd345
diff --git a/dev-python/diskcache/diskcache-3.1.0.ebuild b/dev-python/diskcache/diskcache-3.1.0.ebuild
new file mode 100644
index 000000000000..e0c59c1bf649
--- /dev/null
+++ b/dev-python/diskcache/diskcache-3.1.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+PYTHON_REQ_USE="sqlite"
+
+inherit distutils-r1
+
+HOMEPAGE="http://www.grantjenks.com/docs/diskcache/"
+DESCRIPTION="Disk and file backed cache"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+
+RDEPEND="
+ dev-python/django[${PYTHON_USEDEP}]
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ )
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+"
+
+python_compile_all() {
+ if use doc; then
+ emake -C docs html
+ HTML_DOCS=( docs/_build/html/. )
+ fi
+}
+
+python_test() {
+ nosetests -v || die "failed with ${PYTHON}"
+}