summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-12-24 22:38:54 +0100
committerMichał Górny <mgorny@gentoo.org>2021-12-24 23:52:35 +0100
commit2c116e01b135765dd8dff752157b053d6681741d (patch)
tree0abfab26685100e9a08793dcf04c9332cbbf3fad
parentgames-engines/stratagus: Bump to 3.2.0 (diff)
downloadgentoo-2c116e01b135765dd8dff752157b053d6681741d.tar.gz
gentoo-2c116e01b135765dd8dff752157b053d6681741d.tar.bz2
gentoo-2c116e01b135765dd8dff752157b053d6681741d.zip
games-strategy/wargus: Bump to 3.2.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--games-strategy/wargus/Manifest1
-rw-r--r--games-strategy/wargus/wargus-3.2.0.ebuild73
2 files changed, 74 insertions, 0 deletions
diff --git a/games-strategy/wargus/Manifest b/games-strategy/wargus/Manifest
index 2c3f8bf8c483..3eabf6a8f07a 100644
--- a/games-strategy/wargus/Manifest
+++ b/games-strategy/wargus/Manifest
@@ -3,3 +3,4 @@ DIST wargus-3.0.0.tar.gz 4890178 BLAKE2B 7ab4a4b5e8171b2297e17f0338a5fd674cff7be
DIST wargus-3.1.0.tar.gz 4977868 BLAKE2B 063d47f53b58360c3ccc1aea301f4731a0108a52867b529a1f3935e500e569c11775074241ed8acd58ee7b33064831abebee693a9720927a1432c3f4ed9b17dc SHA512 9e4c3ed955cbf0ff38fd8a847a9590fb3588923b88065a8eb3d2e82fa20b10cd00d507b74c5440486237eb20b71435f72c219efdf288eb67fca594050622f169
DIST wargus-3.1.1.tar.gz 4982124 BLAKE2B 1dd583c46f841c03d0e859e3c79da72da5866c5f6c67d1e23bf186935f2ae8d539e6dec36bb7c41b6f74af3a4f93c308489c802890c982a13aa68ba2cfbc4626 SHA512 8ec6a3dd11db9cb5984c9d61882beac0851f744203f9d90f23783b8a6b7f2728a180d7354c2e85d7ec8105c731a3e6996f5a688ce6bf5fa9437040c09cea6a59
DIST wargus-3.1.2.tar.gz 4981468 BLAKE2B 76e925a6cd469a583adffe67f53a407f919b93c6700aeaa182db05b07691d64e6040d6f9f80461b14b81b412882bb58b976253b382d9e4aced7d1429c28832d2 SHA512 6925eab28b63222c4957b40c7b9a57ca231a18a7b36509c90f72d563a43a2ac4bd82bda3ca02e68099045fcddf10dd36c5a93c6f114f7bdcfb67afa7c7471b1e
+DIST wargus-3.2.0.tar.gz 5062175 BLAKE2B e742c2dae21aa5a8a05ef8a4cefc7d1245707d401aa9e14dfc633aeac0e4e4e54459c0ce07cbd32aed842c3dcf57ea8df39fcfc34a9316211146a61ce71464dc SHA512 bc85304c0994abf778cf157d1013d9dea18e1d761a3b432018641211824bcdb2e424c938842848d8c7a670d8660289b5860342a99be7af259cf8eaf883af1285
diff --git a/games-strategy/wargus/wargus-3.2.0.ebuild b/games-strategy/wargus/wargus-3.2.0.ebuild
new file mode 100644
index 000000000000..05c144af13dd
--- /dev/null
+++ b/games-strategy/wargus/wargus-3.2.0.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake xdg-utils
+
+DESCRIPTION="Warcraft II for the Stratagus game engine"
+HOMEPAGE="
+ https://stratagus.com/
+ https://github.com/Wargus/wargus"
+SRC_URI="https://github.com/Wargus/wargus/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+bne"
+
+RDEPEND="
+ =games-engines/stratagus-${PV}*[theora]
+ media-libs/libpng:0=
+ sys-libs/zlib:=
+ x11-libs/gtk+:2
+ x11-libs/libX11
+ bne? ( app-arch/stormlib:= )
+ !games-strategy/wargus-data"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig"
+
+pkg_pretend() {
+ if has_version games-strategy/wargus-data; then
+ ewarn "The system-wide install of game data via games-strategy/wargus-data"
+ ewarn "no longer works. The old data will be uninstalled after merging"
+ ewarn "this version of Wargus. If you would like to preserve it, please"
+ ewarn "abort the process and back /usr/share/stratagus/wargus up."
+ fi
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DGAMEDIR="${EPREFIX}/usr/bin"
+ -DBINDIR="${EPREFIX}/usr/bin"
+ -DSTRATAGUS="${EPREFIX}/usr/bin/stratagus"
+ -DSHAREDIR="${EPREFIX}/usr/share/stratagus/wargus"
+ -DICONDIR=/usr/share/icons/hicolor/64x64/apps
+ -DWITH_STORMLIB=$(usex bne)
+ )
+ cmake_src_configure
+}
+
+pkg_postinst() {
+ elog "Wargus requires the data from the original game to run. The game"
+ elog "will ask you for the location of the game data and extract/convert"
+ elog "it automatically on the first run."
+
+ if ! has_version media-video/ffmpeg ||
+ ! has_version media-sound/cdparanoia
+ then
+ elog
+ elog "If you did not convert the game data yet, you may want to install"
+ elog "the following optional dependencies:"
+ elog
+ elog "media-video/ffmpeg -- to convert game videos"
+ elog "media-sound/cdparanoia -- to rip game music from the CD"
+ fi
+
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}