summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-09-20 10:55:10 +0200
committerJustin Lecher <jlec@gentoo.org>2015-09-20 11:33:43 +0200
commit2d26b7f3ec173ee642b94bc593a656ecb2332f69 (patch)
tree519d80338e3a3eadefc11182fb1af45e66cf8004
parentdev-python/wheel: Version Bump (diff)
downloadgentoo-2d26b7f3ec173ee642b94bc593a656ecb2332f69.tar.gz
gentoo-2d26b7f3ec173ee642b94bc593a656ecb2332f69.tar.bz2
gentoo-2d26b7f3ec173ee642b94bc593a656ecb2332f69.zip
dev-python/manuel: Verison Bump
Package-Manager: portage-2.2.20.1 Signed-off-by: Justin Lecher <jlec@gentoo.org>
-rw-r--r--dev-python/manuel/Manifest1
-rw-r--r--dev-python/manuel/files/manuel-1.8.0-rm_zope_test.patch120
-rw-r--r--dev-python/manuel/manuel-1.8.0.ebuild32
3 files changed, 153 insertions, 0 deletions
diff --git a/dev-python/manuel/Manifest b/dev-python/manuel/Manifest
index 43cfad12c779..f0b48b42c365 100644
--- a/dev-python/manuel/Manifest
+++ b/dev-python/manuel/Manifest
@@ -1 +1,2 @@
DIST manuel-1.7.1-20130316.tar.bz2 24910 SHA256 4b23c562c84fe771d897b1ce237ba065940ffd5a847bc23bb6ec81070e0d0824 SHA512 94dab56165b92761aa710aba057338ba3062faa375600885e9943e067726ced492493bee5d203883dad604d424f8599fab35fd605e024e2a4139fb5e1a32698e WHIRLPOOL 75909a8fb55f264198733b3b0b0344c5a8e2039e23e55daab2a3dc4aba67ab7d0226ec4197e588a3625cf38062940008ebf0ca8c72a42b8b5077e2e1c38f39dd
+DIST manuel-1.8.0.tar.gz 207600 SHA256 a974d7e83652b26be30f6f513fac95d28b9ffa5ae2819a5c63e2ef8594913eb6 SHA512 8099df44cfd28c8ac6256f346bf8cd36091893a38d3c297099866b1a5db97286b9c9e69f3f12054d7eee9ae3985ca0a003d7b2cc082d28d59850bbcad6b57c57 WHIRLPOOL 7870484499d8c18916bf8349ed1a8a9be84eb074440b8c875f3a0468137edf45425a51545da3517a6c81a862708114eea2fa8561eaa219ccb1ff958d8fcb2afe
diff --git a/dev-python/manuel/files/manuel-1.8.0-rm_zope_test.patch b/dev-python/manuel/files/manuel-1.8.0-rm_zope_test.patch
new file mode 100644
index 000000000000..d1b61cc678ab
--- /dev/null
+++ b/dev-python/manuel/files/manuel-1.8.0-rm_zope_test.patch
@@ -0,0 +1,120 @@
+ setup.py | 6 ------
+ src/manuel/index.txt | 26 ++++++++------------------
+ src/manuel/tests.py | 13 +++++++++----
+ 3 files changed, 17 insertions(+), 28 deletions(-)
+
+diff --git a/setup.py b/setup.py
+index 4561779..b6730c8 100644
+--- a/setup.py
++++ b/setup.py
+@@ -20,8 +20,6 @@ with open('README.rst') as readme:
+ with open('CHANGES.rst') as changes:
+ long_description = readme.read() + '\n\n' + changes.read()
+
+-tests_require = ['zope.testing']
+-
+ setup(
+ name='manuel',
+ version='1.8.0',
+@@ -44,10 +42,6 @@ setup(
+ 'License :: OSI Approved :: Apache Software License',
+ ],
+ license='Apache Software License, Version 2.0',
+- extras_require={
+- 'tests': tests_require,
+- },
+- tests_require=tests_require,
+ test_suite='manuel.tests.test_suite',
+ install_requires=[
+ 'setuptools',
+diff --git a/src/manuel/index.txt b/src/manuel/index.txt
+index c1d85f3..a315317 100644
+--- a/src/manuel/index.txt
++++ b/src/manuel/index.txt
+@@ -166,16 +166,16 @@ can pass in your own class to `TestSuite`.
+
+ .. code-block:: python
+
+- import os.path
+- import manuel.testing
++ import os.path
++ import manuel.testing
+
+- class StripDirsTestCase(manuel.testing.TestCase):
+- def shortDescription(self):
+- return os.path.basename(str(self))
+- suite = manuel.testing.TestSuite(
+- m, path_to_test, TestCase=StripDirsTestCase)
++ class StripDirsTestCase(manuel.testing.TestCase):
++ def shortDescription(self):
++ return os.path.basename(str(self))
++ suite = manuel.testing.TestSuite(
++ m, path_to_test, TestCase=StripDirsTestCase)
+
+- >>> list(suite)[0].shortDescription()
++ list(suite)[0].shortDescription()
+ 'bugs.txt'
+
+
+@@ -236,16 +236,6 @@ checkers <http://docs.python.org/library/doctest.html#outputchecker-objects>`_
+ smoothes over the differences between CPython's and PyPy's NameError
+ messages:
+
+-.. code-block:: python
+-
+- import re
+- import zope.testing.renormalizing
+- checker = zope.testing.renormalizing.RENormalizing([
+- (re.compile(r"NameError: global name '([a-zA-Z0-9_]+)' is not defined"),
+- r"NameError: name '\1' is not defined"),
+- ])
+-
+-
+ .. reset-globs
+ .. _capture:
+
+diff --git a/src/manuel/tests.py b/src/manuel/tests.py
+index 07723a6..b1a3a76 100644
+--- a/src/manuel/tests.py
++++ b/src/manuel/tests.py
+@@ -11,11 +11,12 @@ import manuel.testing
+ import os.path
+ import re
+ import unittest
+-import zope.testing.renormalizing
+
+ here = os.path.dirname(os.path.abspath(__file__))
+
+-checker = zope.testing.renormalizing.RENormalizing([
++try:
++ import zope.testing.renormalizing
++ checker = zope.testing.renormalizing.RENormalizing([
+ (re.compile(r"<unittest\.result\.TestResult"), '<unittest.TestResult'),
+ # PyPy spells some error messages differently
+ (re.compile(r"NameError: global name '([a-zA-Z0-9_]+)' is not defined"),
+@@ -25,7 +26,9 @@ checker = zope.testing.renormalizing.RENormalizing([
+ r"<\1 object"),
+ (re.compile(r"<SRE_Match object"),
+ r"<_sre.SRE_Match object"),
+-])
++ ])
++except ImportError:
++ pass
+
+
+ def turtle_on_the_bottom_test():
+@@ -59,7 +62,6 @@ def test_suite():
+ optionflags = doctest.NORMALIZE_WHITESPACE | doctest.ELLIPSIS
+
+ m = manuel.ignore.Manuel()
+- m += manuel.doctest.Manuel(optionflags=optionflags, checker=checker)
+ m += manuel.codeblock.Manuel()
+ m += manuel.capture.Manuel()
+ m += manuel.testcase.SectionManuel()
+@@ -73,3 +75,6 @@ def test_suite():
+ suite,
+ doctest.DocTestSuite(),
+ ))
++
++if __name__ == '__main__':
++ unittest.TextTestRunner().run(test_suite())
diff --git a/dev-python/manuel/manuel-1.8.0.ebuild b/dev-python/manuel/manuel-1.8.0.ebuild
new file mode 100644
index 000000000000..23938d087bc5
--- /dev/null
+++ b/dev-python/manuel/manuel-1.8.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Manuel lets you build tested documentation"
+HOMEPAGE="https://github.com/benji-york/manuel/ https://pypi.python.org/pypi/manuel"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+# Required to run tests
+DISTUTILS_IN_SOURCE_BUILD=1
+
+DOCS=( CHANGES.rst )
+
+PATCHES=( "${FILESDIR}"/${P}-rm_zope_test.patch )
+
+python_test() {
+ PYTHONPATH=src/:${PYTHONPATH} esetup.py test
+}