summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2020-09-06 10:03:07 +0200
committerHans de Graaff <graaff@gentoo.org>2020-09-06 10:43:15 +0200
commit2eaa791a67435eb4748088f068a7db4990e23b39 (patch)
tree8e0d3dd74d95fd4bcffe009a76496a06b21c78c0
parentdev-ruby/turbolinks: add ruby27 (diff)
downloadgentoo-2eaa791a67435eb4748088f068a7db4990e23b39.tar.gz
gentoo-2eaa791a67435eb4748088f068a7db4990e23b39.tar.bz2
gentoo-2eaa791a67435eb4748088f068a7db4990e23b39.zip
dev-ruby/tty-which: add 0.4.2
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
-rw-r--r--dev-ruby/tty-which/Manifest1
-rw-r--r--dev-ruby/tty-which/tty-which-0.4.2.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-ruby/tty-which/Manifest b/dev-ruby/tty-which/Manifest
index ccb058bc7a06..12107e6961ce 100644
--- a/dev-ruby/tty-which/Manifest
+++ b/dev-ruby/tty-which/Manifest
@@ -1 +1,2 @@
DIST tty-which-0.4.1.gem 11264 BLAKE2B 540249aaeaa5458fef3572413cf673e04765c1ad41971ac3f9bd930a42855459db6c6f8f47c90ee1021993161db6a399ba6edd0384da7db91da999550d3e733b SHA512 e48b284abb3e4177b9f04acec5202a70d3fcaa2d477444c5a9d9920ac00eb192656bc48ca33d72c26845b415a0a90e907dab1dd35608b62bc8e4b1b1b25af51c
+DIST tty-which-0.4.2.tar.gz 9820 BLAKE2B 07ac2aa7a3e42127f456045fbdb92db2ea9834b08e0fccbe81767e01817ec2bf7304fb8a41408b0c4da8ecba3caf8bc236de9cb5637c6f197fe3835d0e9b231e SHA512 573b4ed1bfd4dd66dc3337d076a6559bda57b76c95c75f1aeef8bb6d4e0c81ef72057f5ef0521a10afb2a550b8850e6311aaa56ef2499146221f33403621ee54
diff --git a/dev-ruby/tty-which/tty-which-0.4.2.ebuild b/dev-ruby/tty-which/tty-which-0.4.2.ebuild
new file mode 100644
index 000000000000..bf34ebfeffa4
--- /dev/null
+++ b/dev-ruby/tty-which/tty-which-0.4.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby25 ruby26 ruby27"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_GEMSPEC="tty-which.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Platform independent implementation of Unix which command"
+HOMEPAGE="https://github.com/piotrmurach/tty-which"
+SRC_URI="https://github.com/piotrmurach/tty-which/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+all_ruby_prepare() {
+ echo '-rspec_helper' > .rspec || die
+ sed -i -e 's:_relative ": "./:' ${RUBY_FAKEGEM_GEMSPEC} || die
+
+ # Fix running specs without bundler, fixed upstream
+ sed -e 's/receive(:join)$/receive(:join).and_call_original/' \
+ -e '96iallow(::File).to receive(:join).and_call_original' \
+ -e '115iallow(::File).to receive(:join).and_call_original' \
+ -i spec/unit/which_spec.rb || die
+ sed -e '5iallow(::File).to receive(:join).and_call_original' \
+ -i spec/unit/executable_file_spec.rb || die
+}