summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason A. Donenfeld <zx2c4@gentoo.org>2019-12-28 09:29:53 +0100
committerJason A. Donenfeld <zx2c4@gentoo.org>2019-12-28 09:33:07 +0100
commit2f4720cf2b4f3109a572b8d8e816e373141357f6 (patch)
tree4e2abf9f7e003b5dc0f2fcd8b7d51110a0ca91ba
parentsys-process/glances: bump to 3.1.3 (diff)
downloadgentoo-2f4720cf2b4f3109a572b8d8e816e373141357f6.tar.gz
gentoo-2f4720cf2b4f3109a572b8d8e816e373141357f6.tar.bz2
gentoo-2f4720cf2b4f3109a572b8d8e816e373141357f6.zip
x11-libs/fox: put tools behind use flag
The earlier split packages paradigm is more maintenance burden than I'm willing to take on, and doing it this way lets us more easily unify things into one single ebuild. Besides, these are mostly example apps. Updates: https://bugs.gentoo.org/703088 Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Jason A. Donenfeld <zx2c4@gentoo.org>
-rw-r--r--profiles/package.mask4
-rw-r--r--x11-libs/fox/fox-1.7.67.ebuild13
-rw-r--r--x11-libs/fox/metadata.xml3
3 files changed, 14 insertions, 6 deletions
diff --git a/profiles/package.mask b/profiles/package.mask
index 0e79c12ce61f..5f6a0b3e0682 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -160,7 +160,9 @@ app-editors/emacs-vcs
app-benchmarks/spew
# Jason A. Donenfeld <zx2c4@gentoo.org> (2019-12-16)
-# Simplify FOX packages. Nobody uses the demo apps or the "stable" branch.
+# Simplify FOX packages. Adie, calculator, pathfinder, and shutterbug
+# can now be found behind x11-libs/fox[tools], and reswrap is always
+# installed by it.
# Removal in 30 days. Bug #703088. Bug #703084.
app-editors/adie
dev-util/reswrap
diff --git a/x11-libs/fox/fox-1.7.67.ebuild b/x11-libs/fox/fox-1.7.67.ebuild
index 564900ecba7d..aed93292abb6 100644
--- a/x11-libs/fox/fox-1.7.67.ebuild
+++ b/x11-libs/fox/fox-1.7.67.ebuild
@@ -12,7 +12,7 @@ SRC_URI="ftp://ftp.fox-toolkit.org/pub/${P}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="1.7"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
-IUSE="+bzip2 +jpeg +opengl +png tiff +truetype +zlib debug doc profile"
+IUSE="+bzip2 +jpeg +opengl +png tiff +truetype +zlib debug doc profile tools"
RDEPEND="x11-libs/libXrandr
x11-libs/libXcursor
@@ -37,10 +37,13 @@ src_prepare() {
default
sed -i '/#define REXDEBUG 1/d' lib/FXRex.cpp || die "Unable to remove spurious debug line."
- local d
- for d in windows adie calculator pathfinder shutterbug; do
- sed -i -e "s:${d}::" Makefile.am || die "Unable to remove $d."
- done
+ sed -i -e "s:windows::" Makefile.am
+ if ! use tools; then
+ local d
+ for d in adie calculator pathfinder shutterbug; do
+ sed -i -e "s:${d}::" Makefile.am
+ done
+ fi
# Respect system CXXFLAGS
sed -i -e 's:CXXFLAGS=""::' configure.ac || die "Unable to force cxxflags."
diff --git a/x11-libs/fox/metadata.xml b/x11-libs/fox/metadata.xml
index 915f00227065..a0084d6b4b7c 100644
--- a/x11-libs/fox/metadata.xml
+++ b/x11-libs/fox/metadata.xml
@@ -5,4 +5,7 @@
<email>zx2c4@gentoo.org</email>
<name>Jason A. Donenfeld</name>
</maintainer>
+ <use>
+ <flag name="tools">Install adie, calculator, shutterbug, and pathfinder apps.</flag>
+ </use>
</pkgmetadata>