summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2017-09-12 14:52:39 -0400
committerTim Harder <radhermit@gentoo.org>2017-09-12 15:02:46 -0400
commit2fa11af5996f2407fe6cb5d956c409bd2bae061a (patch)
treea3ed32dbdd8e6c327ad2f4fcfbc46ba7d36c26da
parentdev-java/jsch: version bump. (diff)
downloadgentoo-2fa11af5996f2407fe6cb5d956c409bd2bae061a.tar.gz
gentoo-2fa11af5996f2407fe6cb5d956c409bd2bae061a.tar.bz2
gentoo-2fa11af5996f2407fe6cb5d956c409bd2bae061a.zip
sys-apps/ripgrep: version bump to 0.6.0
Closes: https://bugs.gentoo.org/628032
-rw-r--r--sys-apps/ripgrep/Manifest1
-rw-r--r--sys-apps/ripgrep/ripgrep-0.6.0.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/sys-apps/ripgrep/Manifest b/sys-apps/ripgrep/Manifest
index f710a5330a6e..456bd957578b 100644
--- a/sys-apps/ripgrep/Manifest
+++ b/sys-apps/ripgrep/Manifest
@@ -1 +1,2 @@
DIST ripgrep-0.5.2.tar.xz 48910752 SHA256 e0fadefc1718d967ac15ccc22131255606cddf969b700ccc243c1f973be81d90 SHA512 d8bc86e12be80568de4565c911a03b0c3a15577b22dfa2f1fd9b44f4e77354da1e80852247b9955e225fd13a540acbb3ca7b5a00d686bfa65fdf3f5f329dfcd5 WHIRLPOOL c33a828471a925da2be2f6b3730c28146182ff79b2a75e4f193a0c94f540256cb1670d5cc79470a39d0b898e8c55e20fabe5fdec1c42124339001ad7b437d02c
+DIST ripgrep-0.6.0.tar.xz 58704516 SHA256 57a40c5f0937cc83bad5b2f92ec7d1044ea73fd32bc615cb9c6e81c2e2e1f703 SHA512 af5ab95f8c156e57f70bf0364a6bcb6c93d9ad25c4f6583c2d4bd71e1c77dc07213f549db4462d7c0df3bc5d638fb6d9df6699c85e8cfc357b21dfff59cbd0b5 WHIRLPOOL ad1789c75d3baa8e04dac8184f4f084e88ee7f08b1ddfcda6639e5ce4cffd34a2ba3e0049890cb98393499a6f4c09d1464601d868908476b774b7dd5a1012af8
diff --git a/sys-apps/ripgrep/ripgrep-0.6.0.ebuild b/sys-apps/ripgrep/ripgrep-0.6.0.ebuild
new file mode 100644
index 000000000000..38f06bfa6b30
--- /dev/null
+++ b/sys-apps/ripgrep/ripgrep-0.6.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="a search tool that combines the usability of ag with the raw speed of grep"
+HOMEPAGE="https://github.com/BurntSushi/ripgrep"
+#SRC_URI="https://github.com/BurntSushi/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+# custom tarball bundling all deps and index, otherwise cargo fetches from the network
+SRC_URI="https://dev.gentoo.org/~radhermit/dist/${P}.tar.xz"
+
+LICENSE="|| ( MIT Unlicense )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ dev-util/cargo
+ >=virtual/rust-1.17
+"
+
+src_prepare() {
+ default
+
+ # move cache dir where cargo expects it
+ mv .cargo "${HOME}" || die
+}
+
+src_compile() {
+ cargo build --release --verbose || die
+}
+
+src_test() {
+ cargo test || die "tests failed"
+}
+
+src_install() {
+ dobin target/release/rg
+ doman doc/rg.1
+ dodoc CHANGELOG.md README.md
+
+ insinto /usr/share/zsh/site-functions
+ doins complete/_rg
+}