summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWolfram Schlich <wschlich@gentoo.org>2016-01-25 14:34:12 +0100
committerWolfram Schlich <wschlich@gentoo.org>2016-01-25 14:39:48 +0100
commit2ffe23c24cd6f9140032982db318aff2174d7007 (patch)
treebd4babf673490603c70ccabad67f2a19ad82f4ee
parentsci-physics/lammps: Version bump (diff)
downloadgentoo-2ffe23c24cd6f9140032982db318aff2174d7007.tar.gz
gentoo-2ffe23c24cd6f9140032982db318aff2174d7007.tar.bz2
gentoo-2ffe23c24cd6f9140032982db318aff2174d7007.zip
net-libs/loudmouth: version bump (new upstream) with new USE=openssl; added myself as maintainer, removed the gnome herd as agreed upon with EvaSDK.
Package-Manager: portage-2.2.27
-rw-r--r--net-libs/loudmouth/Manifest1
-rw-r--r--net-libs/loudmouth/loudmouth-1.5.1.ebuild56
-rw-r--r--net-libs/loudmouth/metadata.xml21
3 files changed, 68 insertions, 10 deletions
diff --git a/net-libs/loudmouth/Manifest b/net-libs/loudmouth/Manifest
index 10f26611de42..bda372550a83 100644
--- a/net-libs/loudmouth/Manifest
+++ b/net-libs/loudmouth/Manifest
@@ -1 +1,2 @@
DIST loudmouth-1.4.3.tar.bz2 366818 SHA256 95a93f5d009b71ea8193d994aa11f311bc330a3efe1b7cd74dc48f11c7f929e3 SHA512 02d1de14a4d626a4c9100bd24c06d4b4203eabb0f95bab40ee18ea5e68ed81d47aa977625140157b2d9f7974ac748af857c2ee3a916f0db700e2a2d0934940ec WHIRLPOOL 4f9e3e8e4f2fd0a36996e84deebeb26c789d5334af11a3d6cc6c742b59508945a6279715f6fbb02bbbc04a0d9709e7aae4cc39803b2a60acfd47d76f0482f969
+DIST loudmouth-1.5.1.tar.gz 115811 SHA256 9b0219233004da2f159175ef189363851b3df607e3777c422da1f5545daa17b3 SHA512 d90096a2d10819b620f366a4d6998b281692ef65e0c27f2f59031e3f7495f278ec73a8d18ff38a7234f179b4f7f6adafa532a820023fd615dcf18c2ecd0d8982 WHIRLPOOL 4c3649c9d87088d68b01f0284d1fcd3abedf31dda6c8d9527785b79802ce2c7ac2a9fe4e0d0fe7a09926e4e9f6b06661ab857f272a3db5186125b20a9ba979f0
diff --git a/net-libs/loudmouth/loudmouth-1.5.1.ebuild b/net-libs/loudmouth/loudmouth-1.5.1.ebuild
new file mode 100644
index 000000000000..23def7ef5284
--- /dev/null
+++ b/net-libs/loudmouth/loudmouth-1.5.1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools eutils
+
+DESCRIPTION="Lightweight C Jabber library"
+HOMEPAGE="https://github.com/mcabber/loudmouth"
+SRC_URI="https://github.com/mcabber/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~ppc-macos"
+
+IUSE="asyncns ssl openssl static-libs test"
+
+# Automagic libidn dependency
+RDEPEND="
+ >=dev-libs/glib-2.16:2
+ net-dns/libidn
+ ssl? (
+ !openssl? ( >=net-libs/gnutls-1.4.0 )
+ openssl? ( dev-libs/openssl:0 )
+ )
+ asyncns? ( >=net-libs/libasyncns-0.3 )
+"
+DEPEND="${RDEPEND}
+ test? ( dev-libs/check )
+ virtual/pkgconfig
+ >=dev-util/gtk-doc-am-1
+"
+
+src_prepare() {
+ eautoreconf
+}
+
+src_configure() {
+ local myconf
+
+ if use ssl; then
+ if ! use openssl; then
+ myconf="${myconf} --with-ssl=gnutls"
+ else
+ myconf="${myconf} --with-ssl=openssl"
+ fi
+ else
+ myconf="${myconf} --with-ssl=no"
+ fi
+
+ econf \
+ $(use_enable static-libs static) \
+ $(use_with asyncns) \
+ ${myconf}
+}
diff --git a/net-libs/loudmouth/metadata.xml b/net-libs/loudmouth/metadata.xml
index 9b8477de6438..528027fd8a72 100644
--- a/net-libs/loudmouth/metadata.xml
+++ b/net-libs/loudmouth/metadata.xml
@@ -1,14 +1,15 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer type="project">
- <email>gnome@gentoo.org</email>
- <name>Gentoo GNOME Desktop</name>
- </maintainer>
- <use>
- <flag name="asyncns">Use libasyncns for asynchronous name resolution.</flag>
- </use>
- <upstream>
- <remote-id type="github">engineyard/loudmouth</remote-id>
- </upstream>
+ <maintainer type="person">
+ <email>wschlich@gentoo.org</email>
+ <name>Wolfram Schlich</name>
+ </maintainer>
+ <use>
+ <flag name="asyncns">Use <pkg>net-libs/libasyncns</pkg> for asynchronous name resolution.</flag>
+ <flag name="openssl">Enable <pkg>dev-libs/openssl</pkg> support instead of gnutls (which is the default).</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">mcabber/loudmouth</remote-id>
+ </upstream>
</pkgmetadata>