summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-11-21 22:59:28 +0100
committerMichał Górny <mgorny@gentoo.org>2020-11-22 09:22:37 +0100
commit300cbb5d658c2ab37a86c0e889954ac0ba704b55 (patch)
tree3f5c7c8f90d864a6a8461cbf09cf175b6ab08a96
parentprofiles: base: Drop obsolete www-client/chromium[system-libvpx] p.use.mask (diff)
downloadgentoo-300cbb5d658c2ab37a86c0e889954ac0ba704b55.tar.gz
gentoo-300cbb5d658c2ab37a86c0e889954ac0ba704b55.tar.bz2
gentoo-300cbb5d658c2ab37a86c0e889954ac0ba704b55.zip
dev-python/python-utils: Port up to py3.9
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/python-utils/python-utils-2.3.0.ebuild17
1 files changed, 7 insertions, 10 deletions
diff --git a/dev-python/python-utils/python-utils-2.3.0.ebuild b/dev-python/python-utils/python-utils-2.3.0.ebuild
index 24e371d90eb6..1e71d600470d 100644
--- a/dev-python/python-utils/python-utils-2.3.0.ebuild
+++ b/dev-python/python-utils/python-utils-2.3.0.ebuild
@@ -2,8 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{6,7} pypy3)
-PATCHES=( "${FILESDIR}"/${P}-pytest-runner.patch )
+PYTHON_COMPAT=( python3_{6..9} pypy3)
inherit distutils-r1
@@ -15,17 +14,15 @@ LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64"
-RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]"
-BDEPEND="${RDEPEND}
- dev-python/pytest-flakes[${PYTHON_USEDEP}]"
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+
+PATCHES=( "${FILESDIR}"/${P}-pytest-runner.patch )
+
+distutils_enable_tests pytest
python_prepare_all() {
find . -name '__pycache__' -prune -exec rm -rf {} \; || die "Cleaning __pycache__ failed"
find . -name '*.pyc' -exec rm -f {} \; || die "Cleaning *.pyc failed"
+ sed -i -e '/--cov/d' -e '/--pep8/d' -e '/--flakes/d' pytest.ini || die
distutils-r1_python_prepare_all
}
-
-python_test() {
- pytest -v || die
-}