summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-06-08 10:39:24 +0200
committerMichał Górny <mgorny@gentoo.org>2020-06-08 10:56:12 +0200
commit308958fbc03af9f15dbd9bd5ae80726fc17f733d (patch)
treefe027f8586d04b73d8653185ae117bc059cdebee
parentgames-emulation/pcsxr: Port to cmake.eclass (diff)
downloadgentoo-308958fbc03af9f15dbd9bd5ae80726fc17f733d.tar.gz
gentoo-308958fbc03af9f15dbd9bd5ae80726fc17f733d.tar.bz2
gentoo-308958fbc03af9f15dbd9bd5ae80726fc17f733d.zip
games-strategy/colobot-data: Port to cmake.eclass
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--games-strategy/colobot-data/colobot-data-0.1.12.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/games-strategy/colobot-data/colobot-data-0.1.12.ebuild b/games-strategy/colobot-data/colobot-data-0.1.12.ebuild
index 1a76b184e5b1..79e1a2927dc4 100644
--- a/games-strategy/colobot-data/colobot-data-0.1.12.ebuild
+++ b/games-strategy/colobot-data/colobot-data-0.1.12.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit cmake-utils
+inherit cmake
MY_P=colobot-gold-${PV}-alpha
MUSIC_P=colobot-music_ogg_${PV}-alpha
@@ -30,7 +30,7 @@ src_unpack() {
}
src_prepare() {
- cmake-utils_src_prepare
+ cmake_src_prepare
if use music; then
sed -i -e '/find_program(WGET wget)/d' -e '/if(NOT WGET)/,+2 d' music/CMakeLists.txt || die
@@ -42,5 +42,5 @@ src_configure() {
-DMUSIC=$(usex music)
-DMUSIC_FLAC=OFF
)
- cmake-utils_src_configure
+ cmake_src_configure
}