summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFrançois Bissey <frp.bissey@gmail.com>2021-01-22 09:10:40 +1300
committerMichael Orlitzky <mjo@gentoo.org>2021-01-23 10:30:52 -0500
commit309ad0dd85afb5347a059b761a0256d638346053 (patch)
tree8878409dff15d1c17e41a0a9a07b7416fbec04f5
parentsci-mathematics/flint: revert "sci-mathematics/flint: Remove old" (diff)
downloadgentoo-309ad0dd85afb5347a059b761a0256d638346053.tar.gz
gentoo-309ad0dd85afb5347a059b761a0256d638346053.tar.bz2
gentoo-309ad0dd85afb5347a059b761a0256d638346053.zip
sci-mathematics/flint: upstream bump and fix bugs
Package-Manager: Portage-3.0.13, Repoman-3.0.2 Bug: https://bugs.gentoo.org/761736 Bug: https://bugs.gentoo.org/760678 Closes: https://github.com/gentoo/gentoo/pull/19152 Signed-off-by: François René Pierre Bissey <frp.bissey@gmail.com> Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
-rw-r--r--sci-mathematics/flint/flint-2.7.1.ebuild69
1 files changed, 69 insertions, 0 deletions
diff --git a/sci-mathematics/flint/flint-2.7.1.ebuild b/sci-mathematics/flint/flint-2.7.1.ebuild
new file mode 100644
index 000000000000..1afcfef9754b
--- /dev/null
+++ b/sci-mathematics/flint/flint-2.7.1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+inherit cmake python-any-r1
+
+DESCRIPTION="Fast Library for Number Theory"
+HOMEPAGE="http://www.flintlib.org/"
+SRC_URI="http://www.flintlib.org/${P}.tar.gz"
+
+LICENSE="LGPL-2.1+"
+
+# Based off the soname, e.g. /usr/lib64/libflint.so -> libflint.so.15
+SLOT="0/15"
+
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86"
+IUSE="doc ntl test"
+
+RESTRICT="!test? ( test )"
+
+BDEPEND="doc? (
+ dev-python/sphinx
+ app-text/texlive-core
+ dev-texlive/texlive-latex
+ dev-texlive/texlive-latexextra
+ dev-tex/latexmk
+ )
+ ${PYTHON_DEPS}"
+DEPEND="dev-libs/gmp:=
+ dev-libs/mpfr:=
+ ntl? ( dev-libs/ntl:= )
+ virtual/cblas"
+RDEPEND="${DEPEND}"
+
+# ninja doesn't like "-lcblas" so using make.
+CMAKE_MAKEFILE_GENERATOR="emake"
+
+src_configure() {
+ local mycmakeargs=(
+ -DWITH_NTL="$(usex ntl)"
+ -DBUILD_TESTING="$(usex test)"
+ -DBUILD_DOCS="$(usex doc)"
+ -DCBLAS_INCLUDE_DIRS="${EPREFIX}/usr/include"
+ -DCBLAS_LIBRARIES="-lcblas"
+ )
+
+ cmake_src_configure
+
+ if use doc ; then
+ HTML_DOCS="${BUILD_DIR}/html/*"
+ DOCS=(
+ "${S}"/README
+ "${S}"/AUTHORS
+ "${S}"/NEWS
+ "${BUILD_DIR}"/latex/Flint.pdf
+ )
+ fi
+}
+
+src_compile() {
+ cmake_src_compile
+
+ if use doc ; then
+ cmake_build html
+ cmake_build pdf
+ fi
+}