summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2017-08-17 17:04:27 -0400
committerTim Harder <radhermit@gentoo.org>2017-08-17 17:04:27 -0400
commit30aa5beab0ca286c8759c3d84f20cc537d9cfef7 (patch)
tree57d3ddce9aaab79ca1713cb628b50886ba8f5509
parentapp-vim/bufexplorer: add live ebuild (diff)
downloadgentoo-30aa5beab0ca286c8759c3d84f20cc537d9cfef7.tar.gz
gentoo-30aa5beab0ca286c8759c3d84f20cc537d9cfef7.tar.bz2
gentoo-30aa5beab0ca286c8759c3d84f20cc537d9cfef7.zip
app-vim/gitv: version bump to 1.3.1
-rw-r--r--app-vim/gitv/Manifest1
-rw-r--r--app-vim/gitv/gitv-1.3.1.ebuild28
-rw-r--r--app-vim/gitv/gitv-9999.ebuild8
3 files changed, 36 insertions, 1 deletions
diff --git a/app-vim/gitv/Manifest b/app-vim/gitv/Manifest
index 10dc6e881458..b7b23cba4695 100644
--- a/app-vim/gitv/Manifest
+++ b/app-vim/gitv/Manifest
@@ -1 +1,2 @@
+DIST gitv-1.3.1.tar.gz 553719 SHA256 ad65999e64d1924a6c540efe7a3adebb949cf30be2dcb23a3ce41175ed21170c SHA512 e6a6773dcac18fdc36c891bd592d4dcb2eb20af6253df5886582fd223e040fb8296dc606d4fb25abd7a14f9dc1a712fe0e354821e234c8f54b1b5914af55dcbc WHIRLPOOL a200640371fce5a2af8be014b08a578a8e555a8b1a1ac1db138fe0f08cf8ffe4e36e24080043b61448f4653b0dc5d2df26ae56ec937219bb69b7159bb6e825d6
DIST gitv-1.3.tar.gz 21319 SHA256 6533196f9f2688846c7f4035ab1af82713f5e0e4aaf5c18335fa5007e0ad6555 SHA512 1a13d98ae9dd3e50a559d98881b6b0a8150186573e8f9fcdd9bd5cfdba1a679ea1c02b57f7d7be712dbfb5ec1bffbc4c0e8e1330cd64acf095c88400c499bfaf WHIRLPOOL 7c99b3e697c1e92ae829ad75a85ff2c777014420ed986a93d9d23a7df96af082d0c8c8a35949b1075fcbf8a754c203dd3055e787df075352f9d0fcafce199257
diff --git a/app-vim/gitv/gitv-1.3.1.ebuild b/app-vim/gitv/gitv-1.3.1.ebuild
new file mode 100644
index 000000000000..a772cbef62f2
--- /dev/null
+++ b/app-vim/gitv/gitv-1.3.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit vim-plugin
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/gregsexton/gitv.git"
+else
+ SRC_URI="https://github.com/gregsexton/gitv/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86 ~ppc-macos"
+fi
+
+DESCRIPTION="vim plugin: gitk for vim"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=3574 https://github.com/gregsexton/gitv/"
+LICENSE="vim"
+
+VIM_PLUGIN_HELPFILES="gitv"
+
+RDEPEND="dev-vcs/git
+ app-vim/fugitive"
+
+src_prepare() {
+ rm -f doc/tags addon-info.json roadmap.md || die
+ rm -r img || die
+ default
+}
diff --git a/app-vim/gitv/gitv-9999.ebuild b/app-vim/gitv/gitv-9999.ebuild
index 08b5ee320be5..a772cbef62f2 100644
--- a/app-vim/gitv/gitv-9999.ebuild
+++ b/app-vim/gitv/gitv-9999.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
inherit vim-plugin
if [[ ${PV} == 9999 ]]; then
@@ -20,3 +20,9 @@ VIM_PLUGIN_HELPFILES="gitv"
RDEPEND="dev-vcs/git
app-vim/fugitive"
+
+src_prepare() {
+ rm -f doc/tags addon-info.json roadmap.md || die
+ rm -r img || die
+ default
+}