summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-04-01 13:05:26 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-04-01 14:24:42 +0200
commit30d027ce0540ec121af283520e545d30b3513ea4 (patch)
treed827e87ac30302e0c98a057b64efc58d1431ee25
parentdev-ml/fmt: remove old (diff)
downloadgentoo-30d027ce0540ec121af283520e545d30b3513ea4.tar.gz
gentoo-30d027ce0540ec121af283520e545d30b3513ea4.tar.bz2
gentoo-30d027ce0540ec121af283520e545d30b3513ea4.zip
dev-ml/extlib: bump to 1.7.2
Package-Manager: Portage-2.3.5, Repoman-2.3.2
-rw-r--r--dev-ml/extlib/Manifest1
-rw-r--r--dev-ml/extlib/extlib-1.7.2.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-ml/extlib/Manifest b/dev-ml/extlib/Manifest
index 05bd833f6908..089f83d61326 100644
--- a/dev-ml/extlib/Manifest
+++ b/dev-ml/extlib/Manifest
@@ -1 +1,2 @@
DIST extlib-1.7.1.tar.gz 85397 SHA256 872a492be08bb99ddac7512ec190625718359458b79cfc710f40d5a967f628eb SHA512 42ea1be22a57ab31e5857df0c4c0f98a07e1b5958b34181cd5ab7c83ded112c208315d22cd3dd178d53e75ca109a70cb47ae479e95be8c47ea2087b1a158dc4d WHIRLPOOL 70be2855559fdf217ffb392ad47a2b0d3ec22467a5fcfe48158b85b64f64051cf43c8ae585949ccacdc7f6e257b26523fd91942bffd5c4b28a73a5c4566145fc
+DIST extlib-1.7.2.tar.gz 85934 SHA256 00fa8ad0990e75b94902ef013ba5ec9cc51532663e1e3059ebe7a850576eb90a SHA512 d9f34f5bbd5e94a8dccc5bdbc1ec0e5015608675469c4f513461fa587a5eb7e1398542388fd885d7656591ca85ce30c0e2a9ee26b9722a9dd65189aac35d64ed WHIRLPOOL d58deb139c22639730c6841782e30f5361173dec83566cdfe92cbf25017d06636c666a322f5a38b68cfe12d206751f4b0c2f20c08e7f38f60b719e1b8b170f2d
diff --git a/dev-ml/extlib/extlib-1.7.2.ebuild b/dev-ml/extlib/extlib-1.7.2.ebuild
new file mode 100644
index 000000000000..3ffa91ee32f4
--- /dev/null
+++ b/dev-ml/extlib/extlib-1.7.2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit findlib eutils
+
+DESCRIPTION="Standard library extensions for O'Caml"
+HOMEPAGE="https://github.com/ygrek/ocaml-extlib"
+SRC_URI="https://github.com/ygrek/ocaml-extlib/archive/${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="LGPL-2.1"
+DEPEND="
+ >=dev-lang/ocaml-3.10.2:=[ocamlopt?]
+ dev-ml/cppo:=
+"
+RDEPEND="${DEPEND}"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="doc +ocamlopt"
+S="${WORKDIR}/ocaml-${P}"
+
+src_compile() {
+ cd src
+ emake -j1 all
+ if use ocamlopt; then
+ emake opt cmxs
+ fi
+
+ if use doc; then
+ emake doc
+ fi
+}
+
+src_test() {
+ emake -j1 test
+}
+
+src_install () {
+ findlib_src_install
+
+ # install documentation
+ dodoc README.md
+
+ if use doc; then
+ dohtml src/doc/*
+ fi
+}