summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Bauman <bman@gentoo.org>2018-06-08 18:22:31 -0400
committerAaron Bauman <bman@gentoo.org>2018-06-08 18:22:31 -0400
commit316c4668a48eeba4ef79a21b58089cb0e2f6742d (patch)
tree65685561c22be842249fdd8b059ae3ae61a07583
parentdev-python/ipykernel: handle the multiple python3 case. (diff)
downloadgentoo-316c4668a48eeba4ef79a21b58089cb0e2f6742d.tar.gz
gentoo-316c4668a48eeba4ef79a21b58089cb0e2f6742d.tar.bz2
gentoo-316c4668a48eeba4ef79a21b58089cb0e2f6742d.zip
Revert "www-client/falkon: Drop USE=libressl"
This reverts commit 0d8d5fefb18d71066a9743c3d007d737b75faa2e.
-rw-r--r--www-client/falkon/falkon-3.0.1.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/www-client/falkon/falkon-3.0.1.ebuild b/www-client/falkon/falkon-3.0.1.ebuild
index 40f8820d99a8..89bfcfe00996 100644
--- a/www-client/falkon/falkon-3.0.1.ebuild
+++ b/www-client/falkon/falkon-3.0.1.ebuild
@@ -4,6 +4,7 @@
EAPI=6
KDE_TEST="true"
+QT_MINIMAL="5.9.2"
VIRTUALX_REQUIRED="test"
inherit kde5
@@ -16,7 +17,7 @@ fi
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="amd64 ~x86"
-IUSE="dbus gnome-keyring kwallet +X"
+IUSE="dbus gnome-keyring kwallet libressl +X"
COMMON_DEPEND="
$(add_qt_dep qtdeclarative 'widgets')
@@ -27,10 +28,11 @@ COMMON_DEPEND="
$(add_qt_dep qtwebchannel)
$(add_qt_dep qtwebengine 'widgets')
$(add_qt_dep qtwidgets)
- dev-libs/openssl:0=
dbus? ( $(add_qt_dep qtdbus) )
gnome-keyring? ( gnome-base/gnome-keyring )
kwallet? ( $(add_frameworks_dep kwallet) )
+ libressl? ( dev-libs/libressl:= )
+ !libressl? ( dev-libs/openssl:0= )
X? (
$(add_qt_dep qtx11extras)
x11-libs/libxcb:=