summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTed Tanberry <ted.tanberry@gmail.com>2015-12-25 00:32:17 +0100
committerJustin Lecher <jlec@gentoo.org>2015-12-25 12:44:51 +0100
commit319e280a8e026786b319d48de907e440049f490c (patch)
treedc4bd9d17371d75576fed0a64daa76f6441305d1
parentsci-biology/mcl: Version bump, fix bug 569040 and QA issues. (diff)
downloadgentoo-319e280a8e026786b319d48de907e440049f490c.tar.gz
gentoo-319e280a8e026786b319d48de907e440049f490c.tar.bz2
gentoo-319e280a8e026786b319d48de907e440049f490c.zip
sci-libs/libmems: Version bump, fix bug 529770 and QA issues.
Package-Manager: portage-2.2.26
-rw-r--r--sci-libs/libmems/files/libmems-1.6_p1-broken-constness.patch24
-rw-r--r--sci-libs/libmems/files/libmems-1.6_p1-build.patch10
-rw-r--r--sci-libs/libmems/libmems-1.6_p1-r1.ebuild36
3 files changed, 70 insertions, 0 deletions
diff --git a/sci-libs/libmems/files/libmems-1.6_p1-broken-constness.patch b/sci-libs/libmems/files/libmems-1.6_p1-broken-constness.patch
new file mode 100644
index 000000000000..0bd922c9e111
--- /dev/null
+++ b/sci-libs/libmems/files/libmems-1.6_p1-broken-constness.patch
@@ -0,0 +1,24 @@
+Fix bug 529770 caused by non-const copy constructor.
+
+--- libmems-1.6_p1/libMems/Aligner.cpp
++++ libmems-1.6_p1/libMems/Aligner.cpp
+@@ -939,7 +939,7 @@
+ MatchLeftEndComparator( unsigned seq = 0 ){
+ m_seq = seq;
+ }
+- MatchLeftEndComparator( MatchLeftEndComparator& msc ){
++ MatchLeftEndComparator( const MatchLeftEndComparator& msc ){
+ m_seq = msc.m_seq;
+ }
+ // TODO?? make this do a wraparound comparison if all is equal?
+--- libmems-1.6_p1/libMems/Aligner.h
++++ libmems-1.6_p1/libMems/Aligner.h
+@@ -49,7 +49,7 @@
+ LabeledMemComparator( uint seq ){
+ m_seq = seq;
+ }
+- LabeledMemComparator( LabeledMemComparator& lmc ){
++ LabeledMemComparator( const LabeledMemComparator& lmc ){
+ m_seq = lmc.m_seq;
+ }
+ boolean operator()(const LabeledMem& a, const LabeledMem& b) const{
diff --git a/sci-libs/libmems/files/libmems-1.6_p1-build.patch b/sci-libs/libmems/files/libmems-1.6_p1-build.patch
index 63e5f1216756..04d5dd9c82ac 100644
--- a/sci-libs/libmems/files/libmems-1.6_p1-build.patch
+++ b/sci-libs/libmems/files/libmems-1.6_p1-build.patch
@@ -17,3 +17,13 @@ index 6101f71..d66053d 100644
LIBMEMS_H = \
RepeatHash.h MatchHashEntry.h \
+--- a/libMems/dmSML/util.c
++++ b/libMems/dmSML/util.c
+@@ -2,6 +2,7 @@
+ #include "config.h"
+ #endif
+
++#include <stdlib.h>
+ #include <stdio.h>
+ #include "libMems/dmSML/util.h"
+
diff --git a/sci-libs/libmems/libmems-1.6_p1-r1.ebuild b/sci-libs/libmems/libmems-1.6_p1-r1.ebuild
new file mode 100644
index 000000000000..2e094ab42ce2
--- /dev/null
+++ b/sci-libs/libmems/libmems-1.6_p1-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="Library for sci-biology/mauve"
+HOMEPAGE="http://gel.ahabs.wisc.edu/mauve/"
+SRC_URI="https://dev.gentoo.org/~jlec/distfiles/${P}.tar.xz"
+
+SLOT="0"
+LICENSE="GPL-2"
+IUSE="doc"
+KEYWORDS="~amd64 ~x86"
+
+CDEPEND="
+ dev-libs/boost
+ sci-libs/libgenome
+ sci-libs/libmuscle"
+DEPEND="${CDEPEND}
+ doc? ( app-doc/doxygen )"
+RDEPEND="${CDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-build.patch
+ "${FILESDIR}"/${P}-boost.patch
+ "${FILESDIR}"/${P}-gcc-4.7.patch
+ "${FILESDIR}"/${P}-broken-constness.patch
+ )
+
+src_prepare() {
+ default
+ eautoreconf
+}