summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2015-11-10 12:12:23 -0600
committerWilliam Hubbs <williamh@gentoo.org>2015-11-11 11:39:18 -0600
commit31a23577a72ee55ac4a4002087b521596d0de51e (patch)
tree704bd18990fc1578b8f72bc7834fb6b98cd22c31
parentdev-lua/dkjson: initial commit (diff)
downloadgentoo-31a23577a72ee55ac4a4002087b521596d0de51e.tar.gz
gentoo-31a23577a72ee55ac4a4002087b521596d0de51e.tar.bz2
gentoo-31a23577a72ee55ac4a4002087b521596d0de51e.zip
dev-lua/lua_cliargs: initial commit
-rw-r--r--dev-lua/lua_cliargs/Manifest1
-rw-r--r--dev-lua/lua_cliargs/lua_cliargs-2.5_p5.ebuild37
-rw-r--r--dev-lua/lua_cliargs/metadata.xml14
3 files changed, 52 insertions, 0 deletions
diff --git a/dev-lua/lua_cliargs/Manifest b/dev-lua/lua_cliargs/Manifest
new file mode 100644
index 000000000000..52f1554f4b1d
--- /dev/null
+++ b/dev-lua/lua_cliargs/Manifest
@@ -0,0 +1 @@
+DIST lua_cliargs-2.5_p5.tar.gz 19513 SHA256 7b410dc3665b9bde5d954bfa73fb8254bfd5b4e72b20924f59006ce2f080baf4 SHA512 7c4d490f5d86b07bdf299c976b99bf83c9ba86fabeb321f348587f8ad207983292e3e9268ef72f3cc6ff9d6e32a43669de1d3c21c47499852f971c2cc2a4e746 WHIRLPOOL 07991c547513cc42d5596424651b4a119c30c5ff2dd7a1cabcd125a3198ceebf9f9d466f5110a684af2497cb48afff009aed922719c3115a34823481d194c53b
diff --git a/dev-lua/lua_cliargs/lua_cliargs-2.5_p5.ebuild b/dev-lua/lua_cliargs/lua_cliargs-2.5_p5.ebuild
new file mode 100644
index 000000000000..efa723cf5f6d
--- /dev/null
+++ b/dev-lua/lua_cliargs/lua_cliargs-2.5_p5.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit toolchain-funcs
+
+# Below is the upstream package version.
+# The final component of the version number has been mapped to the _px
+# component of the version number in portage so should be kept in sync.
+MY_PV="2.5-5"
+
+DESCRIPTION="A command-line argument parser."
+HOMEPAGE="https://github.com/amireh/lua_cliargs"
+SRC_URI="https://github.com/amireh/${PN}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+COMMON_DEPEND=">=dev-lang/lua-5.1:="
+DEPEND="${COMMON_DEPEND}
+virtual/pkgconfig"
+RDEPEND="${COMMON_DEPEND}"
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+src_install() {
+ insinto "$($(tc-getPKG_CONFIG) --variable INSTALL_LMOD lua)"
+ doins src/cliargs.lua
+ dodoc README.md
+dodoc -r examples
+ docinto html
+ dodoc -r doc/*
+}
diff --git a/dev-lua/lua_cliargs/metadata.xml b/dev-lua/lua_cliargs/metadata.xml
new file mode 100644
index 000000000000..c91d7bd3d1de
--- /dev/null
+++ b/dev-lua/lua_cliargs/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>williamh@gentoo.org</email>
+ <name>William Hubbs</name>
+ </maintainer>
+ <longdescription lang="en">
+ This module adds support for accepting CLI
+ arguments easily using multiple notations and argument types.
+
+ cliargs allows you to define required, optional, and flag arguments.
+ </longdescription>
+</pkgmetadata>