summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOleksandr Trotsenko <oleksandr.trotsenko@gmail.com>2018-09-01 19:34:00 -0500
committerPatrice Clement <monsieurp@gentoo.org>2018-09-10 15:23:24 +0200
commit31ba2e97f2e0f3a4fbbd1cbffed463ef8a1047b9 (patch)
treef77f379654a8f50c383bd94eb5cbabddadff79f5
parentapp-editors/neovim: add missing dependency on libnsl. (diff)
downloadgentoo-31ba2e97f2e0f3a4fbbd1cbffed463ef8a1047b9.tar.gz
gentoo-31ba2e97f2e0f3a4fbbd1cbffed463ef8a1047b9.tar.bz2
gentoo-31ba2e97f2e0f3a4fbbd1cbffed463ef8a1047b9.zip
dev-python/ldap3: version bump to 2.5.1.
Updating the package to latest upstream available. Closes: https://bugs.gentoo.org/665082 Package-Manager: Portage-2.3.48, Repoman-2.3.10 Closes: https://github.com/gentoo/gentoo/pull/9764
-rw-r--r--dev-python/ldap3/Manifest1
-rw-r--r--dev-python/ldap3/ldap3-2.5.1.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/ldap3/Manifest b/dev-python/ldap3/Manifest
index 75435c071eb3..98a95e565c04 100644
--- a/dev-python/ldap3/Manifest
+++ b/dev-python/ldap3/Manifest
@@ -1,2 +1,3 @@
DIST ldap3-2.2.3.tar.gz 331483 BLAKE2B a6479e6a02d0a0682b809cea2b63ff9ff3935f2d083b9dff3a02468d3a27cbc75dc69dff64f523c0b077f288b3e1e565433af13a607568617c309c3e894d7a62 SHA512 a954f6c582e88addf0bd6dc6fb24108d76d134b80c14a3dca0f9f667dbbfee484cb7b0444822f7e82a41af7dacf61ba111b6dcbf215b7f6df26a3784cfd2fc83
DIST ldap3-2.4.1.tar.gz 345220 BLAKE2B bcf2ea46d483fd4fbfa7ba48e2a2e72061e82b56ac5bcad0e28aec0d52a723d5e5b2aad1f1c335977edeb260264a5603aa2a2bb726c08fd46a0215c46ad2f287 SHA512 716671c2d07c53d1953aab4668562a1b59a1e642b19d50f3cf05d44c74b6848a34b4197aa2c77f5b1d6b556ec0ca473b0495c24da74e2395aa20dffc8a0a360d
+DIST ldap3-2.5.1.tar.gz 352262 BLAKE2B ddbc2146ab23ff2532290e54e8e92c9721c3a312d327f6ec408330335d7b8f30a698e38ea07d0bfc3b603985ce0b497cd8f69e0f0093379191f614fb8e02514a SHA512 8cf3e656f3b58ead391f45c44ec2175ecb7abf29047e4eb03d9f95983cb01900159a4e27bef596df5ffdf7fdf3827615663872c35bd57dede8c9b789aad191e7
diff --git a/dev-python/ldap3/ldap3-2.5.1.ebuild b/dev-python/ldap3/ldap3-2.5.1.ebuild
new file mode 100644
index 000000000000..0b8cb7a8fa84
--- /dev/null
+++ b/dev-python/ldap3/ldap3-2.5.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A strictly RFC 4511 conforming LDAP V3 pure Python client"
+HOMEPAGE="https://github.com/cannatag/ldap3 https://pypi.python.org/pypi/ldap3"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+# The tests are a mess, and the test config is not included in the
+# PyPi tarball (see https://travis-ci.org/cannatag/ldap3 and
+# https://github.com/cannatag/ldap3/blob/master/test/config.py).
+RESTRICT="test"
+
+RDEPEND="
+ dev-python/pyasn1[${PYTHON_USEDEP}]"
+
+DEPEND="
+ ${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+python_test() {
+ nosetests -v -s test || die
+}