summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-05-17 08:29:30 +0200
committerMichał Górny <mgorny@gentoo.org>2020-05-17 08:29:30 +0200
commit31da0bf13a1b35662ecc3c5bf4ba651cdeef7156 (patch)
treec9042a7ac99d6ad991c830ae31d259b0e2a302ee
parentdev-python/secretstorage: Add a test-dep on gnome-keyring (diff)
downloadgentoo-31da0bf13a1b35662ecc3c5bf4ba651cdeef7156.tar.gz
gentoo-31da0bf13a1b35662ecc3c5bf4ba651cdeef7156.tar.bz2
gentoo-31da0bf13a1b35662ecc3c5bf4ba651cdeef7156.zip
app-portage/gemato: Bump to 14.4
Closes: https://bugs.gentoo.org/718066 Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--app-portage/gemato/Manifest1
-rw-r--r--app-portage/gemato/gemato-14.4.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/app-portage/gemato/Manifest b/app-portage/gemato/Manifest
index 2903b73d3e69..82556c3a9150 100644
--- a/app-portage/gemato/Manifest
+++ b/app-portage/gemato/Manifest
@@ -1 +1,2 @@
DIST gemato-14.3.tar.gz 71325 BLAKE2B d42a5182c12bcc0281df47ddb6b933bb332b9b842b2a5c874c3fa4030ab5a8a16759ee289609d428a3fc1338078cd73d234060354513be88c184d5a6bbec545d SHA512 99904b1a38b8a05ff7bf7c265aa463a56ea3aa6c77dd844dc2d154faae5460e3535f4e9799e8863fda256ee6cd374e051ed98193c9b1fc52dc30c9c2655010cd
+DIST gemato-14.4.tar.gz 72630 BLAKE2B c8956b979d7c8629e245ba339e8ee707cd51ffe545a85c712c31b97ee2aaabef7a4964cac46c9cd8c4954c33529623293a94a26ae40b578a6b640aab15d47835 SHA512 0b514e4ff7773eefd2d9adc063a4fbc6a1e7d9ea3dfa783b1d5a8e6ec1e482533a8c70cd5e200a8b9671161d77e14254ad14aee6659e3c96eb9be3bbedcf11af
diff --git a/app-portage/gemato/gemato-14.4.ebuild b/app-portage/gemato/gemato-14.4.ebuild
new file mode 100644
index 000000000000..37b5909bc6e6
--- /dev/null
+++ b/app-portage/gemato/gemato-14.4.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python{3_6,3_7,3_8} pypy3 )
+PYTHON_REQ_USE='threads(+)'
+
+inherit distutils-r1
+
+DESCRIPTION="Stand-alone Manifest generation & verification tool"
+HOMEPAGE="https://github.com/mgorny/gemato"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux"
+IUSE="+gpg tools"
+
+RDEPEND="
+ gpg? ( app-crypt/gnupg )"
+
+distutils_enable_tests setup.py
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ if use tools; then
+ exeinto /usr/share/gemato
+ doexe utils/*.{bash,py}
+ fi
+}