summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-06-18 22:36:01 +0200
committerMichał Górny <mgorny@gentoo.org>2020-06-18 22:36:01 +0200
commit31f73030bb0b03360ec31f1a685b168f1bc46270 (patch)
tree1e1241f5176bda81bce69d8ddfb4810250b19605
parentdev-python/text-unidecode: New dep of python-slugify (diff)
downloadgentoo-31f73030bb0b03360ec31f1a685b168f1bc46270.tar.gz
gentoo-31f73030bb0b03360ec31f1a685b168f1bc46270.tar.bz2
gentoo-31f73030bb0b03360ec31f1a685b168f1bc46270.zip
dev-python/python-slugify: Bump to 4.0.0
Closes: https://bugs.gentoo.org/728636 Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/python-slugify/Manifest1
-rw-r--r--dev-python/python-slugify/python-slugify-4.0.0.ebuild22
2 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/python-slugify/Manifest b/dev-python/python-slugify/Manifest
index 07c93725a49e..269387bd6e96 100644
--- a/dev-python/python-slugify/Manifest
+++ b/dev-python/python-slugify/Manifest
@@ -1 +1,2 @@
DIST python-slugify-1.2.6.tar.gz 8439 BLAKE2B 74699bf80408e1b6a705525b0ada2612cc6224a2ac1e17ce21230ed684af144c0f72ad99b32674bf19bd716d2cfc3a2f0da6f74facc99acba16e3ebc1873f3f3 SHA512 ad45958d03892d8db75967b150f25509c05ab2a87d5ac4a2ed12fccccfe1f86d7db26c406c6de22ba759b77fe772cc0c00d0e517c71db085618f62094ddadfd2
+DIST python-slugify-4.0.0.tar.gz 9391 BLAKE2B 386e0186f9300bd00098ee534c5c5521b04b087e17a2530501291c17884c5ceb4895aa357dc0d4b573ba39aeaf4a69f60e2c110b3efede0e066f70ed9992f5f7 SHA512 a4b0da48ee887a24a022076c9b21fa5795ab104b1d382bae96fc7ba5ce6c09c0cc42e1f4c3b6874b44097d2246ea5b18302dc42386d8844fa41f495744e5ed90
diff --git a/dev-python/python-slugify/python-slugify-4.0.0.ebuild b/dev-python/python-slugify/python-slugify-4.0.0.ebuild
new file mode 100644
index 000000000000..979461ce2cee
--- /dev/null
+++ b/dev-python/python-slugify/python-slugify-4.0.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="A Python Slugify application that handles Unicode"
+HOMEPAGE="https://github.com/un33k/python-slugify https://pypi.org/project/python-slugify/"
+SRC_URI="https://github.com/un33k/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-python/text-unidecode[${PYTHON_USEDEP}]"
+
+distutils_enable_tests unittest