summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2017-12-17 07:20:08 -0500
committerAnthony G. Basile <blueness@gentoo.org>2017-12-17 07:26:07 -0500
commit3258d35cf63eb4b9ac8c833ffc52618e2764f0b1 (patch)
tree5b7ee05f1da2a7204886d6d45ce42518e6844234
parentmedia-plugins/amb-plugins: remove old (diff)
downloadgentoo-3258d35cf63eb4b9ac8c833ffc52618e2764f0b1.tar.gz
gentoo-3258d35cf63eb4b9ac8c833ffc52618e2764f0b1.tar.bz2
gentoo-3258d35cf63eb4b9ac8c833ffc52618e2764f0b1.zip
sys-apps/paxctld: version bump to 1.2.2
Package-Manager: Portage-2.3.13, Repoman-2.3.3
-rw-r--r--sys-apps/paxctld/Manifest1
-rw-r--r--sys-apps/paxctld/paxctld-1.2.2.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/sys-apps/paxctld/Manifest b/sys-apps/paxctld/Manifest
index 953d7a700ad3..7d9258e4e69e 100644
--- a/sys-apps/paxctld/Manifest
+++ b/sys-apps/paxctld/Manifest
@@ -1,3 +1,4 @@
DIST paxctld_1.1.orig.tar.gz 15977 BLAKE2B 695e1f9b09fc11ba3bebb5c5ad3f283f1572382f9ca6c1b532bee1583794ca715223e2dbe77d46588fd1c26dfe395535dabe6431cdeb59e0dad22a8c2f15a2cc SHA512 82b18d1b5d47831ac865b149dbd02c35062baf3da755312bbc2d7adeb31308b995be3441adb6d4a33ba19e79413df77bb4a7bc71d202bef6e1eb25f2c4f31631
DIST paxctld_1.2.1.orig.tar.gz 16347 BLAKE2B fdaceeb76110a128c6e6cc8eb65f903ab9e4df50ca6e4f95f9aedcb2c71f039c939c3112e4fdb9415f53c9ad3e7bbb2f8f3882806c7c93209a3f05efe5d2c5c8 SHA512 3daa072155d7eef6911fa716e2ffefe503d4351d375dfc89efaad0434da7e9f879a07f0da0f58f3a70361c5661cb1d5760b8c85fa88dc086dc8c1f113fdaa6a1
+DIST paxctld_1.2.2.orig.tar.gz 16302 BLAKE2B 051be5210704a0a8447eab46f3a8528fccbb43b6ab60725a38e6210da68ae0e60b83e563ab4796dbde9bccce93982ebfd14b4288466b5531c5b1e261a4020e6c SHA512 f3944b752bcaab2644c640a7992d8f267e882ff8528b85664cc3d7926de042d3540044030bac2f5c64121ff5ed0caff60ca41d3837a77fe2cdf19ad58c6b7c81
DIST paxctld_1.2.orig.tar.gz 16080 BLAKE2B 57cca82b7c60cddacc9fc3e4aa03d641aee33c78b269836b60e34d75b02174ebe89ee79aeec806fd911f236e6a60cf6eb81995406034e352d99d0c875000d605 SHA512 9b181fdc9e6b4d76fc7670e0773263c598164f90fe0db0c180601e8ba68e9baec4ef23281bba9ebac385e53edc20d8b79fbd7c9646e057334c21c6602013e198
diff --git a/sys-apps/paxctld/paxctld-1.2.2.ebuild b/sys-apps/paxctld/paxctld-1.2.2.ebuild
new file mode 100644
index 000000000000..164afa463567
--- /dev/null
+++ b/sys-apps/paxctld/paxctld-1.2.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit systemd
+
+DESCRIPTION="PaX flags maintenance daemon"
+HOMEPAGE="http://www.grsecurity.net/"
+SRC_URI="https://www.grsecurity.net/${PN}/${PN}_${PV}.orig.tar.gz
+ https://dev.gentoo.org/~blueness/hardened-sources/${PN}/${PN}_${PV}.orig.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="pam"
+
+RDEPEND=""
+DEPEND=""
+
+src_prepare() {
+ # Respect Gentoo flags and don't strip
+ sed -i \
+ -e '/^CC/d' \
+ -e '/^CFLAGS/d' \
+ -e '/^LDFLAGS/d' \
+ -e '/STRIP/d' \
+ Makefile
+
+ eapply_user
+}
+
+src_install() {
+ default
+
+ systemd_dounit "${S}"/rpm/${PN}.service
+}