summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2018-06-25 12:19:10 +0200
committerPatrice Clement <monsieurp@gentoo.org>2018-06-25 12:20:41 +0200
commit33b95c9c9dd898682730c3d6a9babe228c960754 (patch)
tree0260353b73ddfd7688aa41bd81361a66ebda4dda
parentx11-themes/skinenigmang-logos: Remove 20070214-r1 (diff)
downloadgentoo-33b95c9c9dd898682730c3d6a9babe228c960754.tar.gz
gentoo-33b95c9c9dd898682730c3d6a9babe228c960754.tar.bz2
gentoo-33b95c9c9dd898682730c3d6a9babe228c960754.zip
dev-java/ini4j: version bump.
Package-Manager: Portage-2.3.40, Repoman-2.3.9
-rw-r--r--dev-java/ini4j/Manifest1
-rw-r--r--dev-java/ini4j/files/ini4j-0.5.2-remove.patch22
-rw-r--r--dev-java/ini4j/ini4j-0.5.2.ebuild27
3 files changed, 50 insertions, 0 deletions
diff --git a/dev-java/ini4j/Manifest b/dev-java/ini4j/Manifest
index 098039f45833..49b2d201133e 100644
--- a/dev-java/ini4j/Manifest
+++ b/dev-java/ini4j/Manifest
@@ -1 +1,2 @@
DIST ini4j-0.5.1.jar 61117 BLAKE2B dedeefed13b66d21f185b786ed9cf5b045a06cf6ab8db108258597ed51e2625ec41e9c23fb032b4d77110f415a10641ad3e673f958842dfcde192bfb9d693d68 SHA512 1c4b5218d092cab9374070c8ae55c7a2483b30893f5af5cfe5d74054b2f5261fe2e1a477a650589d2fc7518b4dcce91a2308ab35bba6b3d918f5e5c19a55eb9a
+DIST ini4j-0.5.2.jar 63258 BLAKE2B 130cf84292295138f8893bcc30aed5b5dcd9eadb6d7f0b984a40388a160ce1f007b4728a13b06cb291a67436fad3bd987b28a068c22cb31e480b35378ff95263 SHA512 eab45f21a9f8f8bc8fdb8654e914ffc9e7eb829169f56a7e1b548a4237eb94e616abe84d78649037ff6254fb00e83b9167bafaf1fe5d97fbf3787838e9bf0fab
diff --git a/dev-java/ini4j/files/ini4j-0.5.2-remove.patch b/dev-java/ini4j/files/ini4j-0.5.2-remove.patch
new file mode 100644
index 000000000000..444cdb3cd5c0
--- /dev/null
+++ b/dev-java/ini4j/files/ini4j-0.5.2-remove.patch
@@ -0,0 +1,22 @@
+--- a/org/ini4j/Profile.java 2015-11-03 22:49:34.854486000 +0000
++++ b/org/ini4j/Profile.java 2015-11-03 22:49:53.412486000 +0000
+@@ -43,7 +43,7 @@
+
+ Section remove(Profile.Section section);
+
+- String remove(Object sectionName, Object optionName);
++ String removeString(Object sectionName, Object optionName);
+
+ interface Section extends OptionMap
+ {
+--- a/org/ini4j/BasicProfile.java 2015-11-03 22:50:28.101486000 +0000
++++ b/org/ini4j/BasicProfile.java 2015-11-03 22:51:09.338486000 +0000
+@@ -138,7 +138,7 @@
+ return remove((Object) section.getName());
+ }
+
+- @Override public String remove(Object sectionName, Object optionName)
++ @Override public String removeString(Object sectionName, Object optionName)
+ {
+ Section sec = get(sectionName);
+
diff --git a/dev-java/ini4j/ini4j-0.5.2.ebuild b/dev-java/ini4j/ini4j-0.5.2.ebuild
new file mode 100644
index 000000000000..25ecc920c18b
--- /dev/null
+++ b/dev-java/ini4j/ini4j-0.5.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+JAVA_PKG_IUSE="doc source"
+
+inherit eutils java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Simple Java API Windows style .ini file handling"
+HOMEPAGE="http://ini4j.sourceforge.net/"
+SRC_URI="http://central.maven.org/maven2/org/${PN}/${PN}/${PV}/${P}-sources.jar -> ${P}.jar"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+RDEPEND="
+ >=virtual/jre-1.6"
+
+DEPEND="
+ >=virtual/jdk-1.6"
+
+src_prepare() {
+ default
+ epatch "${FILESDIR}"/"${P}-remove.patch"
+}