summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Mozes <hydrapolic@gmail.com>2017-09-21 10:05:51 +0200
committerAmy Liffey <amynka@gentoo.org>2017-09-21 17:05:11 +0200
commit345f5c25b61a107b4c6f2115ad722905564e9f58 (patch)
tree24e8f24a5bff092b35cd8abcb24b19e1f79bd645
parentx11-wm/stumpwm-contrib: Installs stumpwm-pinentry (diff)
downloadgentoo-345f5c25b61a107b4c6f2115ad722905564e9f58.tar.gz
gentoo-345f5c25b61a107b4c6f2115ad722905564e9f58.tar.bz2
gentoo-345f5c25b61a107b4c6f2115ad722905564e9f58.zip
app-misc/elasticsearch: bump to 5.6.1
Closes:#5745 Package-Manager: Portage-2.3.10, Repoman-2.3.2
-rw-r--r--app-misc/elasticsearch/Manifest1
-rw-r--r--app-misc/elasticsearch/elasticsearch-5.6.1.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/app-misc/elasticsearch/Manifest b/app-misc/elasticsearch/Manifest
index f9a39b4bc0e9..d96895317860 100644
--- a/app-misc/elasticsearch/Manifest
+++ b/app-misc/elasticsearch/Manifest
@@ -1 +1,2 @@
DIST elasticsearch-5.5.2.tar.gz 33485703 SHA256 0870e2c0c72e6eda976effa07aa1cdd06a9500302320b5c22ed292ce21665bf1 SHA512 62048f15b43e38a61e3a19a1599c25cd0d9009cc1172db5b450b04dec349ecd313b1f20e3d1c7ed1c101ae3e6f6c6d2cdf004a9713ad803576277f93e3adbdb9 WHIRLPOOL 3a71cef2858b76b11e1693907e745912a83f23e26c35a3456c6324fc19c317c53d4404e20134b034e41e162c1ea8d58c38bbd4afe0394d886ab32f6b698172ec
+DIST elasticsearch-5.6.1.tar.gz 33747853 SHA256 006f9cb3886877df845e3c3dea8a688777fb739a862d3afe1a113c16a732715f SHA512 be4ec7b16628bcf217ccf2035399a0729f4a46a2243fdb070535b1e36169fe31f36f1f78d7aa54e44c411b2f33bf76eb5833b2531339c2f040407774990986aa WHIRLPOOL ef12806fd3f00738f8544893ff895174a8af5891c730c1dd308e5537bee23ead429f14448ba0cbfe13766393b88593eb07cd1a7144485b105877cf8d7e84ccd5
diff --git a/app-misc/elasticsearch/elasticsearch-5.6.1.ebuild b/app-misc/elasticsearch/elasticsearch-5.6.1.ebuild
new file mode 100644
index 000000000000..b2ac22fbd6cd
--- /dev/null
+++ b/app-misc/elasticsearch/elasticsearch-5.6.1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit systemd user
+
+DESCRIPTION="Open Source, Distributed, RESTful, Search Engine"
+HOMEPAGE="https://www.elastic.co/products/elasticsearch"
+SRC_URI="https://artifacts.elastic.co/downloads/${PN}/${P}.tar.gz"
+LICENSE="Apache-2.0 BSD-2 LGPL-3 MIT public-domain"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="virtual/jre:1.8"
+
+pkg_setup() {
+ enewgroup ${PN}
+ enewuser ${PN} -1 /bin/bash /usr/share/${PN} ${PN}
+}
+
+src_prepare() {
+ rm -v bin/*.{bat,exe} LICENSE.txt || die
+
+ default
+}
+
+src_install() {
+ keepdir /etc/${PN}
+ keepdir /etc/${PN}/scripts
+
+ insinto /etc/${PN}
+ doins config/*
+ rm -rv config || die
+
+ insinto /usr/share/${PN}
+ doins -r ./*
+
+ exeinto /usr/share/${PN}/bin
+ doexe "${FILESDIR}/elasticsearch-systemd-pre-exec"
+
+ chmod +x "${ED}"/usr/share/${PN}/bin/* || die
+
+ keepdir /var/{lib,log}/${PN}
+ dodir /usr/share/${PN}/plugins
+
+ systemd_newtmpfilesd "${FILESDIR}/${PN}.tmpfiles.d" "${PN}.conf"
+
+ insinto /etc/sysctl.d
+ newins "${FILESDIR}/${PN}.sysctl.d" "${PN}.conf"
+
+ newinitd "${FILESDIR}/${PN}.init" "${PN}"
+ newconfd "${FILESDIR}/${PN}.conf" "${PN}"
+ systemd_newunit "${FILESDIR}"/${PN}.service "${PN}.service"
+}
+
+pkg_postinst() {
+ elog
+ elog "You may create multiple instances of ${PN} by"
+ elog "symlinking the init script:"
+ elog "ln -sf /etc/init.d/${PN} /etc/init.d/${PN}.instance"
+ elog
+ elog "Please make sure you put elasticsearch.yml, log4j2.properties and scripts"
+ elog "from /etc/elasticsearch into the configuration directory of the instance:"
+ elog "/etc/${PN}/instance"
+ elog
+}