summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2021-01-03 14:17:34 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2021-01-03 14:19:20 -0600
commit347f8c2803e76172fd7568d3880513a50c4f8790 (patch)
tree98450856973b91f50cbc8ef6ce437305242894c3
parentnet-misc/realtek-r8152: new package. (diff)
downloadgentoo-347f8c2803e76172fd7568d3880513a50c4f8790.tar.gz
gentoo-347f8c2803e76172fd7568d3880513a50c4f8790.tar.bz2
gentoo-347f8c2803e76172fd7568d3880513a50c4f8790.zip
app-admin/ansible: 2.10.4 stable amd64/x86/arm64 with cleanup
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
-rw-r--r--app-admin/ansible/Manifest2
-rw-r--r--app-admin/ansible/ansible-2.10.0-r2.ebuild82
-rw-r--r--app-admin/ansible/ansible-2.10.1.ebuild79
-rw-r--r--app-admin/ansible/ansible-2.10.4.ebuild4
-rw-r--r--app-admin/ansible/ansible-9999.ebuild4
5 files changed, 3 insertions, 168 deletions
diff --git a/app-admin/ansible/Manifest b/app-admin/ansible/Manifest
index 695ac00500f4..fd15caffe385 100644
--- a/app-admin/ansible/Manifest
+++ b/app-admin/ansible/Manifest
@@ -1,3 +1 @@
-DIST ansible-2.10.0.tar.gz 25454980 BLAKE2B 91f930518b90b36aa2c21f553092233059fada86fd1674c9c6e881484b1bd4e68a3eaa05d82e15115906e55da99c43394c3de36a898e26bb222f780b82f8a5bd SHA512 878036f06e1705e4392223bda210b2acae0232069d0cec02a47f13f6b3bc6c9538fb515a2d2dc6003695bcf0915fdd3dfc5b8dc59355e37e2ca8fa48bbd79657
-DIST ansible-2.10.1.tar.gz 25851704 BLAKE2B f9f42ab9f7864a48f0d960b4e8149dfba3ece6c4b01c08db59f9ba5fbcd39771c7b315bf7c9853641d15c2bb6319c9b9ebc791440fc8933780895024c9b74c12 SHA512 46bbbfb22e5c3715df0069d420b174877dffd59f91613779e7057648d15751d528a9cb57357709d0c04a507a60e20c87b109ba1904e1f313441cf5832ba93b5e
DIST ansible-2.10.4.tar.gz 28622006 BLAKE2B 94551986f5e8ef54dd4f806a264f8373b19564f74b32bfc6d852d49b7b9ff1030ad3c2fdda2f16bc78c0dae5e07cc750a3992bca23fd9bff0f2466716ac32374 SHA512 da9517ad1f478eb8ccab3bad15f3f6ca4d6151798b5aab6db261c4b19a0ac023db1e294745a06748788820ece8980bf1c2c6274314fa0a2943b76c0658383b72
diff --git a/app-admin/ansible/ansible-2.10.0-r2.ebuild b/app-admin/ansible/ansible-2.10.0-r2.ebuild
deleted file mode 100644
index eae0967a94af..000000000000
--- a/app-admin/ansible/ansible-2.10.0-r2.ebuild
+++ /dev/null
@@ -1,82 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6..9} )
-DISTUTILS_USE_SETUPTOOLS=bdepend
-
-inherit distutils-r1 eutils
-
-DESCRIPTION="Model-driven deployment, config management, and command execution framework"
-HOMEPAGE="https://ansible.com/"
-
-if [[ ${PV} == 9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/ansible/ansible.git"
- EGIT_BRANCH="devel"
- KEYWORDS=""
-else
- SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
- KEYWORDS="amd64 ~arm arm64 ~ppc64 x86 ~x64-macos"
-fi
-
-LICENSE="GPL-3"
-SLOT="0"
-IUSE="doc test"
-RESTRICT="test"
-
-RDEPEND="
- dev-python/paramiko[${PYTHON_USEDEP}]
- dev-python/jinja[${PYTHON_USEDEP}]
- dev-python/pyyaml[${PYTHON_USEDEP}]
- dev-python/cryptography[${PYTHON_USEDEP}]
- dev-python/httplib2[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- dev-python/netaddr[${PYTHON_USEDEP}]
- dev-python/pexpect[${PYTHON_USEDEP}]
- net-misc/sshpass
- virtual/ssh
- app-admin/ansible-base
-"
-DEPEND="
- >=dev-python/packaging-16.6[${PYTHON_USEDEP}]
- app-admin/ansible-base
- doc? (
- dev-python/sphinx[${PYTHON_USEDEP}]
- dev-python/sphinx-notfound-page[${PYTHON_USEDEP}]
- >=dev-python/pygments-2.4.0[${PYTHON_USEDEP}]
- )
- test? (
- ${RDEPEND}
- dev-python/nose[${PYTHON_USEDEP}]
- >=dev-python/mock-1.0.1[${PYTHON_USEDEP}]
- dev-python/passlib[${PYTHON_USEDEP}]
- dev-python/coverage[${PYTHON_USEDEP}]
- dev-python/unittest2[${PYTHON_USEDEP}]
- dev-vcs/git
- )"
-
-PATCHES=( "${FILESDIR}/ansible-2.10.0-CVE-2020-25635-6.patch" )
-
-python_compile() {
- export ANSIBLE_SKIP_CONFLICT_CHECK=1
- distutils-r1_python_compile
-}
-
-python_compile_all() {
- if use doc; then
- cd docs/docsite || die
- export CPUS=4
- emake -f Makefile.sphinx html
- fi
-}
-
-python_test() {
- nosetests -d -w test/units -v --with-coverage --cover-package=ansible --cover-branches || die
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/docsite/_build/html/. )
- distutils-r1_python_install_all
-}
diff --git a/app-admin/ansible/ansible-2.10.1.ebuild b/app-admin/ansible/ansible-2.10.1.ebuild
deleted file mode 100644
index e14d7dc95522..000000000000
--- a/app-admin/ansible/ansible-2.10.1.ebuild
+++ /dev/null
@@ -1,79 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6..9} )
-DISTUTILS_USE_SETUPTOOLS=bdepend
-
-inherit distutils-r1 eutils
-
-DESCRIPTION="Model-driven deployment, config management, and command execution framework"
-HOMEPAGE="https://ansible.com/"
-
-if [[ ${PV} == 9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/ansible/ansible.git"
- EGIT_BRANCH="devel"
-else
- SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
- KEYWORDS="amd64 ~arm ~arm64 ~ppc64 x86 ~x64-macos"
-fi
-
-LICENSE="GPL-3"
-SLOT="0"
-IUSE="doc test"
-RESTRICT="test"
-
-RDEPEND="
- dev-python/paramiko[${PYTHON_USEDEP}]
- dev-python/jinja[${PYTHON_USEDEP}]
- dev-python/pyyaml[${PYTHON_USEDEP}]
- dev-python/cryptography[${PYTHON_USEDEP}]
- dev-python/httplib2[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- dev-python/netaddr[${PYTHON_USEDEP}]
- dev-python/pexpect[${PYTHON_USEDEP}]
- net-misc/sshpass
- virtual/ssh
- app-admin/ansible-base
-"
-DEPEND="
- >=dev-python/packaging-16.6[${PYTHON_USEDEP}]
- app-admin/ansible-base
- doc? (
- dev-python/sphinx[${PYTHON_USEDEP}]
- dev-python/sphinx-notfound-page[${PYTHON_USEDEP}]
- >=dev-python/pygments-2.4.0[${PYTHON_USEDEP}]
- )
- test? (
- ${RDEPEND}
- dev-python/nose[${PYTHON_USEDEP}]
- >=dev-python/mock-1.0.1[${PYTHON_USEDEP}]
- dev-python/passlib[${PYTHON_USEDEP}]
- dev-python/coverage[${PYTHON_USEDEP}]
- dev-python/unittest2[${PYTHON_USEDEP}]
- dev-vcs/git
- )"
-
-python_compile() {
- export ANSIBLE_SKIP_CONFLICT_CHECK=1
- distutils-r1_python_compile
-}
-
-python_compile_all() {
- if use doc; then
- cd docs/docsite || die
- export CPUS=4
- emake -f Makefile.sphinx html
- fi
-}
-
-python_test() {
- nosetests -d -w test/units -v --with-coverage --cover-package=ansible --cover-branches || die
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/docsite/_build/html/. )
- distutils-r1_python_install_all
-}
diff --git a/app-admin/ansible/ansible-2.10.4.ebuild b/app-admin/ansible/ansible-2.10.4.ebuild
index cfb7d42b3a3d..3927ed75daf0 100644
--- a/app-admin/ansible/ansible-2.10.4.ebuild
+++ b/app-admin/ansible/ansible-2.10.4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -17,7 +17,7 @@ if [[ ${PV} == 9999 ]]; then
EGIT_BRANCH="devel"
else
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
- KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~x64-macos"
+ KEYWORDS="amd64 ~arm arm64 ~ppc64 x86 ~x64-macos"
fi
LICENSE="GPL-3"
diff --git a/app-admin/ansible/ansible-9999.ebuild b/app-admin/ansible/ansible-9999.ebuild
index 04de5dc07690..77a14c34734d 100644
--- a/app-admin/ansible/ansible-9999.ebuild
+++ b/app-admin/ansible/ansible-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -15,7 +15,6 @@ if [[ ${PV} == 9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/ansible/ansible.git"
EGIT_BRANCH="devel"
- KEYWORDS=""
else
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~x64-macos"
@@ -23,7 +22,6 @@ fi
LICENSE="GPL-3"
SLOT="0"
-KEYWORDS=""
IUSE="test"
RESTRICT="test"