summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-08-11 12:33:27 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-08-11 12:33:27 +0200
commit348a173ce9ef47821c1a26cafed5fc4277e3d019 (patch)
tree176c4b900cc8740c1aa5d635b389571faa8d4626
parentnet-im/choqok: Fix missing header with Frameworks 5.61 (diff)
downloadgentoo-348a173ce9ef47821c1a26cafed5fc4277e3d019.tar.gz
gentoo-348a173ce9ef47821c1a26cafed5fc4277e3d019.tar.bz2
gentoo-348a173ce9ef47821c1a26cafed5fc4277e3d019.zip
net-irc/konversation: Fix missing header with Frameworks 5.61, EAPI-7
Package-Manager: Portage-2.3.71, Repoman-2.3.17 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--net-irc/konversation/files/konversation-1.7.5-fix-regex-for-cap-ack.patch25
-rw-r--r--net-irc/konversation/files/konversation-1.7.5-missing-header.patch23
-rw-r--r--net-irc/konversation/konversation-1.7.5-r1.ebuild75
3 files changed, 123 insertions, 0 deletions
diff --git a/net-irc/konversation/files/konversation-1.7.5-fix-regex-for-cap-ack.patch b/net-irc/konversation/files/konversation-1.7.5-fix-regex-for-cap-ack.patch
new file mode 100644
index 000000000000..f351dd00134f
--- /dev/null
+++ b/net-irc/konversation/files/konversation-1.7.5-fix-regex-for-cap-ack.patch
@@ -0,0 +1,25 @@
+From 6d896b4efc93c18246ce4db7c788929b0ce75559 Mon Sep 17 00:00:00 2001
+From: Peter Simonsson <peter.simonsson@gmail.com>
+Date: Sun, 23 Sep 2018 08:29:43 +0200
+Subject: Fix regex for cap ack
+
+Seems to have worked despite being broken
+---
+ src/irc/inputfilter.cpp | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/irc/inputfilter.cpp b/src/irc/inputfilter.cpp
+index fbd268b..45d4f88 100644
+--- a/src/irc/inputfilter.cpp
++++ b/src/irc/inputfilter.cpp
+@@ -795,7 +795,7 @@ void InputFilter::parseServerCommand(const QString &prefix, const QString &comma
+
+ foreach(const QString& capability, capabilities)
+ {
+- int nameStart = capability.indexOf(QRegExp(QStringLiteral("[a-z0-9"), Qt::CaseInsensitive));
++ int nameStart = capability.indexOf(QRegExp(QStringLiteral("[a-z0-9]"), Qt::CaseInsensitive));
+ QString modifierString = capability.left(nameStart);
+ QString name = capability.mid(nameStart);
+
+--
+cgit v1.1
diff --git a/net-irc/konversation/files/konversation-1.7.5-missing-header.patch b/net-irc/konversation/files/konversation-1.7.5-missing-header.patch
new file mode 100644
index 000000000000..1ff14b81ec58
--- /dev/null
+++ b/net-irc/konversation/files/konversation-1.7.5-missing-header.patch
@@ -0,0 +1,23 @@
+From 4d0036617becc26a76fd021138c98aceec4c7b53 Mon Sep 17 00:00:00 2001
+From: Luca Beltrame <lbeltrame@kde.org>
+Date: Sun, 21 Jul 2019 09:14:32 +0200
+Subject: Fix build with Qt 5.13
+
+---
+ src/irc/outputfilter.cpp | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/irc/outputfilter.cpp b/src/irc/outputfilter.cpp
+index f9e6253..45d11fb 100644
+--- a/src/irc/outputfilter.cpp
++++ b/src/irc/outputfilter.cpp
+@@ -32,6 +32,7 @@
+
+ #include <QStringList>
+ #include <QFile>
++#include <QMetaMethod>
+ #include <QRegExp>
+ #include <QTextCodec>
+ #include <QByteArray>
+--
+cgit v1.1
diff --git a/net-irc/konversation/konversation-1.7.5-r1.ebuild b/net-irc/konversation/konversation-1.7.5-r1.ebuild
new file mode 100644
index 000000000000..6232ab88eb8f
--- /dev/null
+++ b/net-irc/konversation/konversation-1.7.5-r1.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KDE_HANDBOOK="forceoptional"
+inherit kde5
+
+DESCRIPTION="User friendly IRC Client"
+HOMEPAGE="https://kde.org/applications/internet/konversation/ https://konversation.kde.org"
+SRC_URI="mirror://kde/stable/${PN}/${PV/_/-}/src/${P/_/-}.tar.xz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE="+crypt"
+
+BDEPEND="sys-devel/gettext"
+DEPEND="
+ $(add_frameworks_dep karchive)
+ $(add_frameworks_dep kbookmarks)
+ $(add_frameworks_dep kcodecs)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kcrash)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep kemoticons)
+ $(add_frameworks_dep kglobalaccel)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kidletime)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kitemviews)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep knotifyconfig)
+ $(add_frameworks_dep kparts)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep ktextwidgets)
+ $(add_frameworks_dep kwallet)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_frameworks_dep kxmlgui)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtnetwork)
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtxml)
+ media-libs/phonon[qt5(+)]
+ crypt? ( app-crypt/qca:2[qt5(+)] )
+"
+RDEPEND="${DEPEND}
+ crypt? ( app-crypt/qca:2[ssl] )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-fix-regex-for-cap-ack.patch
+ "${FILESDIR}"/${P}-missing-header.patch
+)
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package crypt Qca-qt5)
+ )
+
+ kde5_src_configure
+}
+
+src_install() {
+ kde5_src_install
+
+ # Bug 616162
+ insinto /etc/xdg
+ doins "${FILESDIR}"/konversationrc
+}