summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron W. Swenson <titanofold@gentoo.org>2017-12-15 10:15:25 -0500
committerAaron W. Swenson <titanofold@gentoo.org>2017-12-15 10:15:25 -0500
commit352570a0f7ba0d4ba07cf06fd7aa56a33d269537 (patch)
tree41851160ecf0326d0ae8bf82a426bacdfefd6393
parentdev-db/pspg: Bump 0.8.0 (diff)
downloadgentoo-352570a0f7ba0d4ba07cf06fd7aa56a33d269537.tar.gz
gentoo-352570a0f7ba0d4ba07cf06fd7aa56a33d269537.tar.bz2
gentoo-352570a0f7ba0d4ba07cf06fd7aa56a33d269537.zip
dev-libs/libpqxx: Bump to 5.1.1
Package-Manager: Portage-2.3.13, Repoman-2.3.3
-rw-r--r--dev-libs/libpqxx/Manifest1
-rw-r--r--dev-libs/libpqxx/libpqxx-5.1.1.ebuild86
2 files changed, 87 insertions, 0 deletions
diff --git a/dev-libs/libpqxx/Manifest b/dev-libs/libpqxx/Manifest
index 54b59a37e0e4..cc4edb9ded82 100644
--- a/dev-libs/libpqxx/Manifest
+++ b/dev-libs/libpqxx/Manifest
@@ -1,2 +1,3 @@
DIST libpqxx-4.0.1.tar.gz 1582532 BLAKE2B e84f455de3cdce1bbcdb29ae0ff5fea6e5c624f910a3612976eea1f50e054b785b9b7f2b816fa5d0e11ec4f53498404eb2ec1d9c80fc60a8be27d0e0cef0de14 SHA512 00204985097ef8bb0a3376d6ba541dbb471d7c52d7135f6244a9f4acbf6c8e5254d6f813e4411421e49bb56f4a520fc6ac67e300141d724396ce0ac11bd3a95e
DIST libpqxx-5.1.0.tar.gz 677998 BLAKE2B 5d486beff9d45249d191b380b2a552dcab621c0509c318e8745abfcb5d6d30b0c31dbe3431fea0c1c212b7a3d6d48abf15d537c6f5a6b3869963dd7615f3e4d3 SHA512 4e881bb509b36b6b48d18dddd0895ab6864ba0430630d3e1417036ff8ff0008b446467868f2672e0b49b46cc3a86c6a61a8a3e5c6b63e0bf422be3268d7f9702
+DIST libpqxx-5.1.1.tar.gz 678031 BLAKE2B c615094b7d872355ad45eb49c3f2e9776f314bca0fbf393ab9ec96daeae5732082c9907eef4793f575cf2cbb95ffa30e1d83cbfb9c4a2938019d9d207ebcc9cf SHA512 fbbefe37d01ef58dd7f73629b5174c7285c0fe7d2f2ae10d3118d55d944f7e92b88d0e9c8ac72425c3bc55bdcc12f3e110e1974b303b7fb227be805e935982dd
diff --git a/dev-libs/libpqxx/libpqxx-5.1.1.ebuild b/dev-libs/libpqxx/libpqxx-5.1.1.ebuild
new file mode 100644
index 000000000000..83c831e8738d
--- /dev/null
+++ b/dev-libs/libpqxx/libpqxx-5.1.1.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+PYTHON_COMPAT=( python2_7 )
+inherit python-any-r1
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+
+DESCRIPTION="Standard front-end for writing C++ programs that use PostgreSQL"
+SRC_URI="https://github.com/jtv/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+HOMEPAGE="http://pqxx.org/development/libpqxx/"
+LICENSE="BSD"
+SLOT="0"
+IUSE="doc static-libs"
+
+RDEPEND="dev-db/postgresql:="
+DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
+ doc? (
+ app-doc/doxygen
+ app-text/xmlto
+ )
+"
+
+DOCS=( AUTHORS NEWS README{.md,-UPGRADE} )
+
+src_prepare() {
+ default
+
+ sed -e 's/python/python2/' \
+ -i tools/{splitconfig,template2mak.py} \
+ || die "Couldn't fix Python shebangs"
+}
+
+src_configure() {
+ econf \
+ --enable-shared \
+ $(use_enable doc documentation) \
+ $(use_enable static-libs static)
+}
+
+src_test() {
+ einfo "The tests need a running PostgreSQL server and an existing database."
+ einfo "Test requires PGDATABASE and PGUSER to be set at a minimum. Optionally,"
+ einfo "set PGPORT and PGHOST. Define them at the command line or in:"
+ einfo " ${EROOT%/}/etc/libpqxx_test_env"
+
+ if [[ -z $PGDATABASE || -z $PGUSER ]] ; then
+ if [[ -f ${EROOT%/}/etc/libpqxx_test_env ]] ; then
+ source "${EROOT%/}/etc/libpqxx_test_env"
+ [[ -n $PGDATABASE ]] && export PGDATABASE
+ [[ -n $PGHOST ]] && export PGHOST
+ [[ -n $PGPORT ]] && export PGPORT
+ [[ -n $PGUSER ]] && export PGUSER
+ fi
+ fi
+
+ if [[ -n $PGDATABASE && -n $PGUSER ]] ; then
+ local server_version
+ server_version=$(psql -Aqtc 'SELECT version();' 2> /dev/null)
+ if [[ $? = 0 ]] ; then
+ cd "${S}/test" || die
+ emake check
+ else
+ eerror "Is the server running?"
+ eerror "Verify role and database exist, and are permitted in pg_hba.conf for:"
+ eerror " Role: ${PGUSER}"
+ eerror " Database: ${PGDATABASE}"
+ die "Couldn't connect to server."
+ fi
+ else
+ eerror "PGDATABASE and PGUSER must be set to perform tests."
+ eerror "Skipping tests."
+ fi
+}
+
+src_install () {
+ use doc && HTML_DOCS=( doc/html/. )
+ default
+
+ if ! use static-libs; then
+ find "${D}" -name '*.la' -delete || die
+ fi
+}