summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-02-17 09:16:58 +0100
committerMichał Górny <mgorny@gentoo.org>2021-02-17 09:33:18 +0100
commit3623aface44b2c99652bb2bf7f826cc10215d439 (patch)
treeff6380e4b03ee0f5589955c59bacb61178461bab
parentdev-python/flask-compress: Bump to 1.9.0 (diff)
downloadgentoo-3623aface44b2c99652bb2bf7f826cc10215d439.tar.gz
gentoo-3623aface44b2c99652bb2bf7f826cc10215d439.tar.bz2
gentoo-3623aface44b2c99652bb2bf7f826cc10215d439.zip
dev-python/botocore: Bump to 1.20.9
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.20.9.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index 4c6f6241612d..486db3f3898d 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -14,3 +14,4 @@ DIST botocore-1.20.5.tar.gz 7447859 BLAKE2B 56b6ecbec1834c414983679e4f3cd01f295c
DIST botocore-1.20.6.tar.gz 7450975 BLAKE2B 56ad69b958233a94f6bacff28bffb644bde8cc87dcb8d842f542059548d2aaf5762666077f9b429bc0487808282b806725a05dcd3def6c975f4418f209fc2ec8 SHA512 558c3c3b123aeeeb5aff420e7ff3edbba9165e1cf434f8136ead21e9d94dd85d857732902b10e09386ddc80754d7be37970573ce039296e532b593a101a97950
DIST botocore-1.20.7.tar.gz 7458254 BLAKE2B 8b9a1edda73e2564d3a3d67c6b3542d1ec9372403cb4d88396e58dfbcb5987821f278f2757e079e1ab32e03243ed3a6d1023ecc591b965512b3af5e2d43ea7b0 SHA512 9b023a31be866a50b94017a28aca40b5fe2e720959c928a3fd93db96041f3886049717f50461222a09572c0c56c5961a4614b80e400e4fa6d8b3ff4b4ab681df
DIST botocore-1.20.8.tar.gz 7460687 BLAKE2B 51a11afa10058fee4cfcd17ce9181bb39910833f2f1e002041ebf713b292ed8fe6b5622c1742a641691e9d662d8d21e66bcabcf1ebf25b1ce1663f251050550f SHA512 6ec14c1c81c3f4d79a6783d5bba934140703a63bd0c852e71a9e1ec78016b531300ac6932f349561a4018487c82e8a4b44315cdf9eae4394920b710fcf4adbbb
+DIST botocore-1.20.9.tar.gz 7461420 BLAKE2B 114c2e491dc7ee38e67cbe257aee01be067172ce999b5ac4ef506faa50878fd902ff5e77cabd482919a11d4962f10acc3ac03b837b8bb97d22985e05c9908111 SHA512 e3ec9eb16afd33ff576fcd023ca161a54768738d79af884724594cfb4a9317bddb24404a01cf3e8f9278cec7305feb0a887ab22d9a2deb1b169e3eec27ffa9a2
diff --git a/dev-python/botocore/botocore-1.20.9.ebuild b/dev-python/botocore/botocore-1.20.9.ebuild
new file mode 100644
index 000000000000..4e5d698e619b
--- /dev/null
+++ b/dev-python/botocore/botocore-1.20.9.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="https://github.com/boto/botocore"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/jmespath[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/1.8.6-tests-pass-all-env-vars-to-cmd-runner.patch"
+)
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests nose
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+ # very unstable
+ sed -i -e 's:test_stress_test_token_bucket:_&:' \
+ tests/functional/retries/test_bucket.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ # note: suites need to be run separately as one of the unit tests
+ # seems to be leaking mocks and breaking a few functional tests
+ nosetests -v tests/unit ||
+ die "unit tests failed under ${EPYTHON}"
+ nosetests -v tests/functional ||
+ die "functional tests failed under ${EPYTHON}"
+}