summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUltrabug <ultrabug@gentoo.org>2016-04-05 09:15:19 +0200
committerUltrabug <ultrabug@gentoo.org>2016-04-05 09:15:19 +0200
commit367180f0a88422a1615e31a85cf709ef1e52c43f (patch)
treeceed2b1b509ddbb8b2f727e57a15c49e6814cd1b
parentdev-util/geany-plugins: Stable for PPC64 (bug #570902). (diff)
downloadgentoo-367180f0a88422a1615e31a85cf709ef1e52c43f.tar.gz
gentoo-367180f0a88422a1615e31a85cf709ef1e52c43f.tar.bz2
gentoo-367180f0a88422a1615e31a85cf709ef1e52c43f.zip
dev-python/gevent: version bump
Package-Manager: portage-2.2.27
-rw-r--r--dev-python/gevent/Manifest1
-rw-r--r--dev-python/gevent/gevent-1.1.1.ebuild76
2 files changed, 77 insertions, 0 deletions
diff --git a/dev-python/gevent/Manifest b/dev-python/gevent/Manifest
index 5d7fd7508161..3bfa5f5c42ef 100644
--- a/dev-python/gevent/Manifest
+++ b/dev-python/gevent/Manifest
@@ -2,3 +2,4 @@ DIST gevent-1.0.1.tar.gz 1455636 SHA256 4627e215d058f71d95e6b26d9e7be4c263788a47
DIST gevent-1.0.2.tar.gz 1735721 SHA256 3ae1ca0f533ddcb17aab16ce66b424b3f3b855ff3b9508526915d3c6b73fba31 SHA512 95b8a24e53ad1ac135e63cb13942c5af6f7efb0fdb4fc2737759d07b09c2408b0d569dd30f63b45a342f81501211e98b5b6116ba9574c8a7801b9c551c14bd53 WHIRLPOOL 402d2af5993a0c04cb0c371190edbd6d4b56bbade2062beb4e7bedb522c0dd32c89452d6d7c1400884043d2f3bcae9ab718a5bccc1d98a563b7b92aeeff38f4e
DIST gevent-1.0.tar.gz 1437122 SHA256 bfa9d846db91a7d8b6a36e87353eed641c7e3e7d0bfa0b9975796d227f2db4eb SHA512 5f452c799323e8c16172e04a538dfd8ef4066781207ec06ad0bc2d4892a7309b46146e4ab819bf8b99ad4f6ce226d013ded98800efc16458e2626dcc7a77d853 WHIRLPOOL 799fc6402ec3d0e7cc2580d0af8fab06eb01c3cd3dc61e85672e0abb211ba768dea4585ee8a3d204455f19a537974509d992275aaf243ff4948231603b828c6a
DIST gevent-1.1.0.tar.gz 1968902 SHA256 34f7a5eca1326affe149eaa5467220d89002facd338028d2340868015407ae75 SHA512 e4dcb117e3c18359faefe9e9233dcda2089fdb6a4149b048881af3925f6c7b1e91447dbdcbaadd1c840c3161555f30054e60563cf78f000821cf7f12716c051d WHIRLPOOL a3508d805e24c3d10580127bb97a3c8c4f87ea928fa1d70096553e2e51bfa4497b8dda327d2418d916aedf4661478cdac25a42f951f13b698060f1b5187806cf
+DIST gevent-1.1.1.tar.gz 2008368 SHA256 6ee5b9851b2acde08df7ab9b9a2903f58b4b0e555405c444f4b1dd16f71caeea SHA512 b6342249695232532824f8ba643c4727bc409f9869aca7c26f95f8d6cb09c8fbd4ad7b04f7b4f37db9ac11e1d824a9bf9b67bf393fe183afc1b21c68959e4f78 WHIRLPOOL 8f6dd5fb848851e2c6d1fa4e4792c4c6ad4ceaeed429bac2052c4e40cc918ca5755be0f9b70663e89295a3860a9ac02f89b00e6503db26ab8881e1cc2dedca64
diff --git a/dev-python/gevent/gevent-1.1.1.ebuild b/dev-python/gevent/gevent-1.1.1.ebuild
new file mode 100644
index 000000000000..bed0b54d9e00
--- /dev/null
+++ b/dev-python/gevent/gevent-1.1.1.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# Note: pypy3 not supported
+# Note: py3.5 preliminary support
+# http://www.gevent.org/whatsnew_1_1.html#broader-platform-support
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy )
+PYTHON_REQ_USE="ssl(+),threads(+)"
+
+inherit distutils-r1 flag-o-matic
+
+MY_PV=${PV/_beta/b}
+MY_P=${PN}-${MY_PV}
+
+DESCRIPTION="Coroutine-based network library"
+HOMEPAGE="http://gevent.org/ https://pypi.python.org/pypi/gevent/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~mips ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples"
+
+RDEPEND="
+ dev-libs/libev
+ >=net-dns/c-ares-1.10
+ >=dev-python/greenlet-0.4.9
+ virtual/python-greenlet[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+
+# Tests take long and fail terribly a few times.
+# It also seems that they require network access.
+RESTRICT="test"
+
+S=${WORKDIR}/${MY_P}
+
+python_prepare_all() {
+ export LIBEV_EMBED="false"
+ export CARES_EMBED="false"
+ export EMBED="false"
+
+ distutils-r1_python_prepare_all
+}
+
+python_configure_all() {
+ append-flags -fno-strict-aliasing
+}
+
+python_compile_all() {
+ use doc && emake -C doc html
+}
+
+python_test() {
+ cd greentest || die
+
+ GEVENT_RESOLVER=thread \
+ "${PYTHON}" testrunner.py --config ../known_failures.py || die
+ GEVENT_RESOLVER=ares GEVENTARES_SERVERS=8.8.8.8 \
+ "${PYTHON}" testrunner.py --config ../known_failures.py \
+ --ignore tests_that_dont_use_resolver.txt || die
+ GEVENT_FILE=thread \
+ "${PYTHON}" testrunner.py --config ../known_failures.py $(grep -l subprocess test_*.py) || die
+}
+
+python_install_all() {
+ DOCS+=( changelog.rst )
+ use doc && local HTML_DOCS=( doc/_build/html/. )
+ use examples && local EXMAPLES=( examples/. )
+
+ distutils-r1_python_install_all
+}