summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2018-05-02 19:40:34 +0200
committerPacho Ramos <pacho@gentoo.org>2018-05-02 21:27:43 +0200
commit3785c745d4b345ced648508c8421e0e1dc55d9cd (patch)
treeaf6a346095c86a09ef1c049fb608c1ec29f7a2c5
parentgames-strategy/heroes3-demo: Stop using games.eclass (diff)
downloadgentoo-3785c745d4b345ced648508c8421e0e1dc55d9cd.tar.gz
gentoo-3785c745d4b345ced648508c8421e0e1dc55d9cd.tar.bz2
gentoo-3785c745d4b345ced648508c8421e0e1dc55d9cd.zip
Revert "games-strategy/heroes3-demo: Stop using games.eclass"
This reverts commit 61f208d74e0e5a039ba17d025e75fba437e2ddae.
-rw-r--r--games-strategy/heroes3-demo/heroes3-demo-1.3.1a-r1.ebuild72
1 files changed, 0 insertions, 72 deletions
diff --git a/games-strategy/heroes3-demo/heroes3-demo-1.3.1a-r1.ebuild b/games-strategy/heroes3-demo/heroes3-demo-1.3.1a-r1.ebuild
deleted file mode 100644
index 0c4fee131adb..000000000000
--- a/games-strategy/heroes3-demo/heroes3-demo-1.3.1a-r1.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit eutils unpacker
-
-MY_PN="${PN%-demo}"
-
-DESCRIPTION="Turn-based 2D medieval combat"
-HOMEPAGE="http://www.lokigames.com/products/heroes3/"
-SRC_URI="mirror://lokigames/loki_demos/${PN}.run"
-
-LICENSE="all-rights-reserved"
-SLOT="0"
-# Should also work on ppc
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-RESTRICT="mirror bindist strip"
-
-DEPEND="games-util/loki_patch"
-RDEPEND="
- >=sys-libs/lib-compat-loki-0.2
- || (
- ppc? (
- x11-libs/libX11
- )
- !ppc? (
- x11-libs/libX11[abi_x86_32(-)]
- )
- )
-"
-
-dir="/opt/${PN}"
-QA_PREBUILT="${dir:1}/*"
-
-S="${WORKDIR}"
-
-src_install() {
- # Apply patch
- loki_patch patch.dat data/ || die
-
- local demo="data/demos/${MY_PN}_demo"
-
- local exe_stub="${MY_PN}_demo"
- if use ppc ; then
- exe="${exe_stub}.ppc"
- else
- exe="${exe_stub}.x86"
- fi
-
- insinto "${dir}"
- exeinto "${dir}"
- doins -r "${demo}"/*
- rm "${D}/${dir}"/{${exe_stub}*,*.sh} || die
- doexe "${demo}/${exe}"
-
- einfo "Linking libs provided by 'sys-libs/lib-compat-loki' to '${dir}'."
- if use amd64; then
- dosym /lib32/loki_ld-linux.so.2 "${dir}"/ld-linux.so.2
- dosym /usr/lib32/loki_libc.so.6 "${dir}"/libc.so.6
- dosym /usr/lib32/loki_libnss_files.so.2 "${dir}"/libnss_files.so.2
- else
- dosym /lib/loki_ld-linux.so.2 "${dir}"/ld-linux.so.2
- dosym /usr/lib/loki_libc.so.6 "${dir}"/libc.so.6
- dosym /usr/lib/loki_libnss_files.so.2 "${dir}"/libnss_files.so.2
- fi
- make_wrapper ${PN} "./${exe}" "${dir}"
- newicon "${demo}/icon.xpm" ${PN}.png
- make_desktop_entry ${PN} "Heroes of Might and Magic III (Demo)" ${PN}
-
- einstalldocs
-}