summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorbrahmajit das <listout@protonmail.com>2022-09-20 22:09:23 +0530
committerMatt Turner <mattst88@gentoo.org>2022-10-09 19:00:33 -0400
commit378e7c94d14988c295369a302fd2984d3e01ec5b (patch)
tree982921169b9ece9bf0e3d3879d2512a894b61c8b
parentapp-misc/tracker: Add revbump that uses libsoup:3.0 (diff)
downloadgentoo-378e7c94d14988c295369a302fd2984d3e01ec5b.tar.gz
gentoo-378e7c94d14988c295369a302fd2984d3e01ec5b.tar.bz2
gentoo-378e7c94d14988c295369a302fd2984d3e01ec5b.zip
gnome-extra/gnome-boxes: Version bump to 43.0
Closes: https://github.com/gentoo/gentoo/pull/27364 Signed-off-by: brahmajit das <listout@protonmail.com> Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--gnome-extra/gnome-boxes/Manifest1
-rw-r--r--gnome-extra/gnome-boxes/gnome-boxes-43.0.ebuild121
-rw-r--r--profiles/package.mask1
3 files changed, 123 insertions, 0 deletions
diff --git a/gnome-extra/gnome-boxes/Manifest b/gnome-extra/gnome-boxes/Manifest
index f7343c50c880..5a899c5e4761 100644
--- a/gnome-extra/gnome-boxes/Manifest
+++ b/gnome-extra/gnome-boxes/Manifest
@@ -1 +1,2 @@
DIST gnome-boxes-42.3.tar.xz 1235916 BLAKE2B 69a52117b0ef459b4f6c11287f3961283c0493522875958ae65cf1838d9359b60e1c376bf86c1bc1899e69b6b9aed72a32aa39c7e687afef6a23de50d599b8e8 SHA512 2c455830b76cffc647838b797dc7667d9dec0be45658972075b203553bd73bb54dd6b9b22891da9eb12bea7f157b26980a172685a10e1d252f32014f38eb8805
+DIST gnome-boxes-43.0.tar.xz 1232476 BLAKE2B be12499c8a155d47d4d0479b33a7947e6df0382eda0be84497c5f60391e2b36c96dca30d48840d9c23034fa79f9f2bbb2fb534403d0da92f0d653ae22382c00c SHA512 64e549694bead564fe0f3754e55576d259cf404f13f3db4fd2f1b56e80ce7c126d0e4c07a91fa168d27c511539cd0cf4b56cb39bea0c758930b61d356f9f110c
diff --git a/gnome-extra/gnome-boxes/gnome-boxes-43.0.ebuild b/gnome-extra/gnome-boxes/gnome-boxes-43.0.ebuild
new file mode 100644
index 000000000000..7af9bb261f0c
--- /dev/null
+++ b/gnome-extra/gnome-boxes/gnome-boxes-43.0.ebuild
@@ -0,0 +1,121 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+VALA_MIN_API_VERSION="0.40"
+
+inherit gnome.org gnome2-utils linux-info meson readme.gentoo-r1 vala xdg
+
+DESCRIPTION="Simple GNOME application to access remote or virtual systems"
+HOMEPAGE="https://wiki.gnome.org/Apps/Boxes"
+
+LICENSE="LGPL-2+ CC-BY-2.0"
+SLOT="0"
+
+KEYWORDS="~amd64"
+
+# FIXME: qemu probably needs to depend on spice[smartcard] directly with USE=spice
+# FIXME: Check over libvirt USE=libvirtd,qemu and the smartcard/usbredir requirements
+# Technically vala itself still ships a libsoup vapi, but that may change, and it should be better to use the .vapi from the same libsoup version
+DEPEND="
+ >=app-arch/libarchive-3.0.0:=
+ >=dev-libs/glib-2.52:2
+ >=x11-libs/gtk+-3.24.1:3
+ >=gui-libs/libhandy-1.5.0:1
+ >=sys-libs/libosinfo-1.10.0-r1
+ app-crypt/libsecret
+ net-libs/libsoup:3.0
+ virtual/libusb:1
+ >=app-emulation/libvirt-glib-4.0.0
+ >=dev-libs/libxml2-2.7.8:2
+ >=net-misc/spice-gtk-0.32[gtk3(+),smartcard,usbredir]
+ app-misc/tracker:3
+ >=net-libs/webkit-gtk-2.38.0:4.1
+
+ >=dev-libs/gobject-introspection-1.56:=
+ >=dev-libs/libgudev-165:=
+" # gobject-introspection needed for libovf subproject
+# These are called via exec():
+# sys-fs/mtools mcopy for unattended file copying for files that libarchive doesn't support
+# app-cdr/cdrtools mkisofs is needed for unattended installer secondary disk image creation
+# app-emulation/libguestfs virt-sysprep is used for VM cloing, if not there, it logs debug and doesn't function
+# sys-apps/policycoreutils restorecon is used for checking selinux context
+# app-emulation/libvirt virsh used for various checks (and we need the library anyways)
+# sys-auth/polkit used for making all libvirt system disks readable via "pkexec chmod a+r" that aren't already readable to the user (libvirt system importer)
+# app-emulation/qemu qemu-img used to convert image to QCOW2 format during copy
+RDEPEND="${DEPEND}
+ app-cdr/cdrtools
+ app-misc/tracker-miners:3[iso]
+ app-emulation/spice[smartcard]
+ >=app-emulation/libvirt-0.9.3[libvirtd,qemu]
+ >=app-emulation/qemu-1.3.1[spice,smartcard,usbredir]
+ sys-fs/mtools
+ sys-auth/polkit
+"
+# This is only needed for creating the .vapi file, but gnome-boxes needs it
+BDEPEND="
+ $(vala_depend)
+ sys-libs/libosinfo[vala]
+ app-crypt/libsecret[vala]
+ net-libs/libsoup:3.0[vala]
+ app-emulation/libvirt-glib[vala]
+ net-misc/spice-gtk[vala]
+ x11-libs/vte:2.91[vala]
+ dev-libs/appstream-glib
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+DISABLE_AUTOFORMATTING="yes"
+DOC_CONTENTS="Before running gnome-boxes for local VMs, you will need to load the KVM modules.
+If you have an Intel Processor, run:
+# modprobe kvm-intel
+
+If you have an AMD Processor, run:
+# modprobe kvm-amd"
+
+pkg_pretend() {
+ linux-info_get_any_version
+
+ if linux_config_exists; then
+ if ! { linux_chkconfig_present KVM_AMD || \
+ linux_chkconfig_present KVM_INTEL; }; then
+ ewarn "You need KVM support in your kernel to use GNOME Boxes local VM support!"
+ fi
+ fi
+}
+
+src_prepare() {
+ default
+ vala_setup
+ xdg_environment_reset
+}
+
+src_configure() {
+ local emesonargs=(
+ -Ddistributor_name=Gentoo
+ -Ddistributor_version=${PVR}
+ -Dinstalled_tests=false
+ -Dflatpak=false
+ -Dprofile=default
+ -Duefi=true
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+ readme.gentoo_print_elog
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}
diff --git a/profiles/package.mask b/profiles/package.mask
index 4c82a68cf49b..7883a3053eed 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -490,6 +490,7 @@ sys-devel/automake:1.11
>=gnome-base/nautilus-43
>=gnome-extra/evolution-data-server-3.46
>=gnome-extra/evolution-ews-3.46
+>=gnome-extra/gnome-boxes-43
>=gnome-extra/gnome-calculator-43
>=gnome-extra/gnome-clocks-43
>=gnome-extra/gnome-shell-extensions-43