summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-10-06 03:41:41 +0200
committerMaciej Barć <xgqt@gentoo.org>2022-10-06 03:59:19 +0200
commit37b9a827c71c1c947fc90817b07f3b795cf70820 (patch)
treec0e1c272764c36435c57549bd0842b035d664775
parentapp-text/convertlit: fix build with upcoming clang16 (diff)
downloadgentoo-37b9a827c71c1c947fc90817b07f3b795cf70820.tar.gz
gentoo-37b9a827c71c1c947fc90817b07f3b795cf70820.tar.bz2
gentoo-37b9a827c71c1c947fc90817b07f3b795cf70820.zip
dev-python/youtube-search-python: bump to 1.6.6
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
-rw-r--r--dev-python/youtube-search-python/Manifest1
-rw-r--r--dev-python/youtube-search-python/youtube-search-python-1.6.6.ebuild22
2 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/youtube-search-python/Manifest b/dev-python/youtube-search-python/Manifest
index caf70ac39fa2..20434c2282ad 100644
--- a/dev-python/youtube-search-python/Manifest
+++ b/dev-python/youtube-search-python/Manifest
@@ -1 +1,2 @@
DIST youtube-search-python-1.6.5.tar.gz 115469 BLAKE2B 80e3732155113ee6764f370af894c3cf261812dc5ae6d44a1a7f614645a7a85482c4c35736d8319246f3b2e3cb66188908253bfed910700ad6b83d7fd2d9d92f SHA512 1d319401fb6e24064c3235d82680fd6f156bc600155b4d8157cb1b69ae61cffb587d5ac59ea5b5a353657cd3a1275b038dd9af9939da7fe7ac81c7866de10832
+DIST youtube-search-python-1.6.6.tar.gz 115732 BLAKE2B d53f99272917c488709a2b7b6273e430e1831d5d34930ad39a5cbb838fec1ee9694b8d7fc8aefcac643dfec0fc91bb278a40224b2e0bc865a93db17d647c8ac8 SHA512 b03ead324e7684f7bf28a4c05a104a558dce8bb4e126b42853bcd875675a4a39876bb47cad3e57a618eaffdc1561fd523021be3dd77dd1180b9bf7d752faa2ee
diff --git a/dev-python/youtube-search-python/youtube-search-python-1.6.6.ebuild b/dev-python/youtube-search-python/youtube-search-python-1.6.6.ebuild
new file mode 100644
index 000000000000..923cfa88f17f
--- /dev/null
+++ b/dev-python/youtube-search-python/youtube-search-python-1.6.6.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Get YouTube video information using link WITHOUT YouTube Data API v3"
+HOMEPAGE="https://github.com/alexmercerind/youtube-search-python/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/httpx[${PYTHON_USEDEP}]
+ net-misc/yt-dlp[${PYTHON_USEDEP}]
+"