summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2017-10-21 07:46:15 +0200
committerHans de Graaff <graaff@gentoo.org>2017-10-21 07:46:15 +0200
commit381ce3fa4938fc63e210844af75fb979e222b747 (patch)
tree948fb4aebfc10a7aaf22523f87a727b4b66b1091
parentdev-ruby/rspec-expectations: Add rspec 3.7 (diff)
downloadgentoo-381ce3fa4938fc63e210844af75fb979e222b747.tar.gz
gentoo-381ce3fa4938fc63e210844af75fb979e222b747.tar.bz2
gentoo-381ce3fa4938fc63e210844af75fb979e222b747.zip
dev-ruby/rspec-core: Add rspec 3.7
Package-Manager: Portage-2.3.8, Repoman-2.3.3
-rw-r--r--dev-ruby/rspec-core/Manifest1
-rw-r--r--dev-ruby/rspec-core/rspec-core-3.7.0.ebuild101
2 files changed, 102 insertions, 0 deletions
diff --git a/dev-ruby/rspec-core/Manifest b/dev-ruby/rspec-core/Manifest
index 87a84b6a1bd1..278eb166d787 100644
--- a/dev-ruby/rspec-core/Manifest
+++ b/dev-ruby/rspec-core/Manifest
@@ -4,3 +4,4 @@ DIST rspec-core-3.3.2-git.tgz 332730 SHA256 aef9a2867a435aa7be57826c850e88e59323
DIST rspec-core-3.5.3-git.tgz 368960 SHA256 26a5788977ba1ce6889924e6e944d1a08becb059593f297b4f4dd58b600b037a SHA512 c8f983018e33bd111c75671d7208b38704dd0fddb22cca2b08a59a1e5ceb0939ed56ee4015df758f5d766fbe2390279c1d670f6fff4eef222f44621f48c581ef WHIRLPOOL 86afe335378b5e9e94ee53546d6e87c531bee71cc1ed5a79f1549d593f6912a6a07dfac2b783aaaaf808bba8405e6e1cbc5b20fc275ca80ce504bed1b4991fd2
DIST rspec-core-3.5.4-git.tgz 369170 SHA256 6e7f0cbccf13f774936b25100f743682bb4359040f926a7aa83dce9d7e80209e SHA512 c672381e9233b6f8c6e92ed70d084ff7a558edd6ca7d5a09a28fff1554975b952b6fab94483324b5bd6a62ff7aac576e7a216dbb3972749ef0210fe1cd05411d WHIRLPOOL 816b9dc1648afd11965457b147a5748ea50fd9cef8b5e266a83131b532642f5882bde9099e037ee9f5bea2fa2bc2bca1140494d33f252ea7819b033a4b8dda99
DIST rspec-core-3.6.0-git.tgz 375590 SHA256 8994ff9ef23e11262d2c0cc7c54ffaa3ce73c3d2fd01fc0c089f46a31e7667fa SHA512 cecd3885652e18ba1ffed45e40d12c932ba0d880e96b2f1d264709f55dbda8d6b0c78c3bf4bb940d246b84261d1b80038618735f65302ff62646165b2e932be1 WHIRLPOOL 7923ccf7959f5fdc23f27ba0a4619b582a6a16ff20dc27eee82a17436ba9c278eaf996f4e851fac8c9a2802cda30ef1928ab5a4bc20269fe66ac4df540d6b827
+DIST rspec-core-3.7.0-git.tgz 376565 SHA256 502b7dc92919e593c748840bbcbdf74e27d0b4a58e58838b9ffc13bdaea3bc34 SHA512 071bd2a5c905d4ce621f2d7255b882a9d34cf42001cb2995fdb05a91387805929198c32e53cf4c2df2a43d179d2c49337214066be87eb50ab044b5f70aba8c54 WHIRLPOOL 48d98d14f716a836a75d25ee523b10ce64e4a1dce91df953ab60320f41d9661c12509e9f788625311b3217eb10f760249c3aa454b28cee4c8d196206d6c26d2f
diff --git a/dev-ruby/rspec-core/rspec-core-3.7.0.ebuild b/dev-ruby/rspec-core/rspec-core-3.7.0.ebuild
new file mode 100644
index 000000000000..312b06640370
--- /dev/null
+++ b/dev-ruby/rspec-core/rspec-core-3.7.0.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_TASK_TEST="none"
+RUBY_FAKEGEM_TASK_DOC="none"
+
+RUBY_FAKEGEM_EXTRADOC="Changelog.md README.md"
+
+# Also install this custom path since internal paths depend on it.
+RUBY_FAKEGEM_EXTRAINSTALL="exe"
+
+RUBY_FAKEGEM_GEMSPEC="rspec-core.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Behaviour Driven Development (BDD) framework for Ruby"
+HOMEPAGE="https://github.com/rspec/rspec-core"
+SRC_URI="https://github.com/rspec/${PN}/archive/v${PV}.tar.gz -> ${P}-git.tgz"
+
+LICENSE="MIT"
+SLOT="3"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="highlight"
+
+SUBVERSION="$(get_version_component_range 1-2)"
+
+ruby_add_rdepend "
+ =dev-ruby/rspec-support-${SUBVERSION}*
+ !!<dev-ruby/rspec-core-2.14.8-r4
+ highlight? ( >=dev-ruby/coderay-1.0.9 )
+"
+
+ruby_add_bdepend "test? (
+ >=dev-ruby/nokogiri-1.5.2
+ >=dev-ruby/coderay-1.0.9
+ dev-ruby/syntax
+ >=dev-ruby/thread_order-1.1.0
+ >=dev-ruby/rspec-expectations-3.3.0:3
+ >=dev-ruby/rspec-mocks-2.99.0:3
+ )"
+
+all_ruby_prepare() {
+ # Don't set up bundler: it doesn't understand our setup.
+ sed -i -e '/[Bb]undler/d' Rakefile || die
+
+ # Avoid dependency on cucumber since we can't run the features anyway.
+ sed -i -e '/[Cc]ucumber/ s:^:#:' Rakefile || die
+
+ # Duplicate exe also in bin. We can't change it since internal stuff
+ # also depends on this and fixing that is going to be fragile. This
+ # way we can at least install proper bin scripts.
+ cp -R exe bin || die
+
+ # Avoid unneeded dependency on git.
+ sed -i -e 's/git ls-files --/find/' rspec-core.gemspec || die
+
+ # Avoid aruba dependency so that we don't end up in dependency hell.
+ sed -i -e '/ArubaLoader/,/^end/ s:^:#:' -e '/Aruba/ s:^:#:' spec/spec_helper.rb || die
+ rm -f spec/support/aruba_support.rb || die
+ rm -f spec/integration/{failed_line_detection,filtering,order,persistence_failures,suite_hooks_errors}_spec.rb || die
+ rm -f spec/integration/{spec_file_load_errors,output_stream,fail_if_no_examples}_spec.rb || die
+
+ # Avoid a spec failing due to path issues
+ sed -i -e '/does not load files in the default path when run by ruby/,/end/ s:^:#:' \
+ spec/rspec/core/configuration_spec.rb || die
+
+ # Work around coderay incompatibilities
+ sed -i -e '/be_highlighted/,/end/ s/32/33/' \
+ -e '/highlights core RSpec keyword-like methods/,/^ end/ s:^:#:' \
+ spec/rspec/core/formatters/syntax_highlighter_spec.rb || die
+}
+
+each_ruby_prepare() {
+ sed -i -e 's:ruby -e:'${RUBY}' -e:' spec/rspec/core_spec.rb || die
+
+ # case ${RUBY} in
+ # *ruby22)
+ # # The rubygems version bundled with ruby 2.2 causes warnings.
+ # sed -i -e '/a library that issues no warnings when loaded/,/^ end/ s:^:#:' spec/rspec/core_spec.rb || die
+ # ;;
+ # esac
+}
+
+all_ruby_compile() {
+ if use doc ; then
+ yardoc || die
+ fi
+}
+
+each_ruby_test() {
+ PATH="${S}/bin:${PATH}" RUBYLIB="${S}/lib" ${RUBY} -Ilib bin/rspec spec || die "Tests failed."
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ ruby_fakegem_binwrapper rspec /usr/bin/rspec-3 'gem "rspec", "~>3.0"'
+}