summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-12-05 01:52:02 +0100
committerMichael Palimaka <kensington@gentoo.org>2017-12-05 22:21:26 +1100
commit38591f8810ec877e3be5965f0ed753c5fcbf9f2b (patch)
tree8d540ec88a1d58a15b769e96de0f38a47ba00148
parentdev-util/drone: Version bump to 0.8.3 (diff)
downloadgentoo-38591f8810ec877e3be5965f0ed753c5fcbf9f2b.tar.gz
gentoo-38591f8810ec877e3be5965f0ed753c5fcbf9f2b.tar.bz2
gentoo-38591f8810ec877e3be5965f0ed753c5fcbf9f2b.zip
dev-qt/qtwebengine: Fix build with >=ICU-60
Closes: https://bugs.gentoo.org/639220 Package-Manager: Portage-2.3.16, Repoman-2.3.6
-rw-r--r--dev-qt/qtwebengine/files/qtwebengine-5.9.3-icu-60.1.patch16
-rw-r--r--dev-qt/qtwebengine/qtwebengine-5.9.3.ebuild2
2 files changed, 18 insertions, 0 deletions
diff --git a/dev-qt/qtwebengine/files/qtwebengine-5.9.3-icu-60.1.patch b/dev-qt/qtwebengine/files/qtwebengine-5.9.3-icu-60.1.patch
new file mode 100644
index 000000000000..9866ab929194
--- /dev/null
+++ b/dev-qt/qtwebengine/files/qtwebengine-5.9.3-icu-60.1.patch
@@ -0,0 +1,16 @@
+Fix build with >=ICU-60
+
+Bug: https://bugs.gentoo.org/639220
+Bug: https://bugreports.qt.io/browse/QTBUG-64925
+
+--- a/src/3rdparty/chromium/components/url_formatter/url_formatter.cc
++++ b/src/3rdparty/chromium/components/url_formatter/url_formatter.cc
+@@ -488,7 +488,7 @@
+ // are added to the allowed set. The list has to be updated when a new
+ // version of Unicode is released. The current version is 9.0.0 and ICU 60
+ // will have Unicode 10.0 data.
+-#if U_ICU_VERSION_MAJOR_NUM < 60
++#if U_ICU_VERSION_MAJOR_NUM < 60 || defined(TOOLKIT_QT)
+ const icu::UnicodeSet aspirational_scripts(
+ icu::UnicodeString(
+ // Unified Canadian Syllabics
diff --git a/dev-qt/qtwebengine/qtwebengine-5.9.3.ebuild b/dev-qt/qtwebengine/qtwebengine-5.9.3.ebuild
index 2c0bd6388d55..afb0d89df444 100644
--- a/dev-qt/qtwebengine/qtwebengine-5.9.3.ebuild
+++ b/dev-qt/qtwebengine/qtwebengine-5.9.3.ebuild
@@ -73,6 +73,8 @@ DEPEND="${RDEPEND}
pax_kernel? ( sys-apps/elfix )
"
+PATCHES=( "${FILESDIR}/${P}-icu-60.1.patch" )
+
src_prepare() {
use pax_kernel && PATCHES+=( "${FILESDIR}/${PN}-5.9.0-paxmark-mksnapshot.patch" )