summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-10-11 12:14:53 +0200
committerJustin Lecher <jlec@gentoo.org>2015-10-11 13:24:29 +0200
commit3925aa5a1417b41c01c4450501b6017e8889d7db (patch)
tree7d993ac49ebf651c832c934f19d7193eca02ca06
parentdev-python/cffi: Add python3.5 support (diff)
downloadgentoo-3925aa5a1417b41c01c4450501b6017e8889d7db.tar.gz
gentoo-3925aa5a1417b41c01c4450501b6017e8889d7db.tar.bz2
gentoo-3925aa5a1417b41c01c4450501b6017e8889d7db.zip
dev-python/colorama: Add python3.5 support
Package-Manager: portage-2.2.23 Signed-off-by: Justin Lecher <jlec@gentoo.org>
-rw-r--r--dev-python/colorama/colorama-0.3.3-r1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/colorama/colorama-0.3.3-r1.ebuild b/dev-python/colorama/colorama-0.3.3-r1.ebuild
new file mode 100644
index 000000000000..7f861fa6464f
--- /dev/null
+++ b/dev-python/colorama/colorama-0.3.3-r1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Makes ANSI escape character sequences for producing colored terminal text & cursor positioning"
+HOMEPAGE="https://code.google.com/p/colorama/ https://pypi.python.org/pypi/colorama https://github.com/tartley/colorama"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples"
+
+python_install_all() {
+ use examples && local EXAMPLES=( demos/. )
+ distutils-r1_python_install_all
+}