summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2016-11-01 19:19:35 +0100
committerMichał Górny <mgorny@gentoo.org>2016-11-06 16:34:33 +0100
commit39f0ae3fe1259d17abc10cc0b21e2c9820089292 (patch)
tree2489afef4a4c5ab36207b5f499518dabce5ee2ba
parentapp-portage/eix: Major ebuild cleanup (diff)
downloadgentoo-39f0ae3fe1259d17abc10cc0b21e2c9820089292.tar.gz
gentoo-39f0ae3fe1259d17abc10cc0b21e2c9820089292.tar.bz2
gentoo-39f0ae3fe1259d17abc10cc0b21e2c9820089292.zip
app-portage/eix: Remove invalid and useless USE flags
Remove the USE flags violating different QA policies or being useless, in particular: flags used to control *FLAGS, flags used to alter configuration file, flags used to switch between building separate executables and symlinks to one executable. For the former, unconditionally disable altering user's *FLAGS. For the latter, force the defaults.
-rw-r--r--app-portage/eix/eix-0.32.1.ebuild35
1 files changed, 22 insertions, 13 deletions
diff --git a/app-portage/eix/eix-0.32.1.ebuild b/app-portage/eix/eix-0.32.1.ebuild
index c6effcda1372..57695a9fba1c 100644
--- a/app-portage/eix/eix-0.32.1.ebuild
+++ b/app-portage/eix/eix-0.32.1.ebuild
@@ -14,8 +14,7 @@ SRC_URI="https://github.com/vaeth/eix/releases/download/v${PV}/${P}.tar.xz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~ia64-hpux ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="debug +dep doc nls optimization +required-use security strong-optimization
- strong-security sqlite swap-remote tools"
+IUSE="debug doc nls sqlite"
BOTHDEPEND="nls? ( virtual/libintl )
sqlite? ( >=dev-db/sqlite-3:= )"
@@ -41,22 +40,32 @@ src_prepare() {
src_configure() {
local myconf=(
- $(use_enable debug debugging)
+ $(use_enable debug paranoicasserts)
$(use_enable nls)
- $(use_enable optimization)
- $(use_enable security)
- $(use_enable strong-optimization)
- $(use_enable strong-security)
- $(use_enable swap-remote)
- $(use_enable tools separate-tools)
- $(use_with dep dep-default)
$(use_with doc extra-doc)
- $(use_with prefix always-accept-keywords)
- $(use_with required-use required-use-default)
$(use_with sqlite)
- --with-zsh-completion
+
+ # default configuration
+ $(use_with prefix always-accept-keywords)
+ --with-dep-default
+ --with-required-use-default
+
+ # paths
--with-portage-rootpath="${ROOTPATH}"
--with-eprefix-default="${EPREFIX}"
+
+ # build a single executable with symlinks
+ --disable-separate-binaries
+ --disable-separate-tools
+
+ # used purely to control/disrespect *FLAGS
+ --disable-debugging
+ --disable-new_dialect
+ --disable-optimization
+ --disable-strong-optimization
+ --disable-security
+ --disable-nopie-security
+ --disable-strong-security
)
econf "${myconf[@]}"