summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-11-09 12:32:03 +0100
committerJustin Lecher <jlec@gentoo.org>2015-11-09 12:49:41 +0100
commit3a2589be8fc25633e19b8683ce0b9edb16d97cd9 (patch)
treeeebc17314c7fa2d56a1ef8e761ce00f2b51d67cc
parentdev-python/pytest-django: Version Bump (diff)
downloadgentoo-3a2589be8fc25633e19b8683ce0b9edb16d97cd9.tar.gz
gentoo-3a2589be8fc25633e19b8683ce0b9edb16d97cd9.tar.bz2
gentoo-3a2589be8fc25633e19b8683ce0b9edb16d97cd9.zip
dev-python/nosexcover: Add python3.5 support and tests
Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=565194 Package-Manager: portage-2.2.23 Signed-off-by: Justin Lecher <jlec@gentoo.org>
-rw-r--r--dev-python/nosexcover/nosexcover-1.0.10.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/dev-python/nosexcover/nosexcover-1.0.10.ebuild b/dev-python/nosexcover/nosexcover-1.0.10.ebuild
index 17af62484522..3d1a794add35 100644
--- a/dev-python/nosexcover/nosexcover-1.0.10.ebuild
+++ b/dev-python/nosexcover/nosexcover-1.0.10.ebuild
@@ -4,7 +4,7 @@
EAPI=5
-PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy )
inherit distutils-r1
@@ -22,3 +22,7 @@ DEPEND="
dev-python/nose[${PYTHON_USEDEP}]
>=dev-python/coverage-3.4[${PYTHON_USEDEP}]"
RDEPEND="${DEPEND}"
+
+python_test() {
+ nosetests -v nosexcover/tests.py || die
+}