summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2017-03-28 19:30:32 +0200
committerJeroen Roovers <jer@gentoo.org>2017-03-28 19:32:50 +0200
commit3bd746e24f62c411b16248c0856ad95b24bca3f2 (patch)
treeefea42e27eb57ee6694617912f8bcaef3aed2460
parentdev-python/unittest2: fix unit tests for python3.6 (bug 613652) (diff)
downloadgentoo-3bd746e24f62c411b16248c0856ad95b24bca3f2.tar.gz
gentoo-3bd746e24f62c411b16248c0856ad95b24bca3f2.tar.bz2
gentoo-3bd746e24f62c411b16248c0856ad95b24bca3f2.zip
net-misc/youtube-dl: Version bump.
Package-Manager: Portage-2.3.5, Repoman-2.3.2
-rw-r--r--net-misc/youtube-dl/Manifest1
-rw-r--r--net-misc/youtube-dl/youtube-dl-2017.03.26.ebuild98
2 files changed, 99 insertions, 0 deletions
diff --git a/net-misc/youtube-dl/Manifest b/net-misc/youtube-dl/Manifest
index aa2dc0e91945..c7f5248661ae 100644
--- a/net-misc/youtube-dl/Manifest
+++ b/net-misc/youtube-dl/Manifest
@@ -1,3 +1,4 @@
DIST youtube-dl-2017.03.16.tar.gz 2631620 SHA256 55df3cbda9cf86e49baf54040340ec74c692bb3d6da3d2f5a1bc1238017dd492 SHA512 f3b8942f6b2be3b1cfd4bddfb74c17bad48c8ef4bea34114970ecb9d65b5a3dcbe71beba6d7c2dbda168371bbb2e8bbaddce58039bd9d158bf23950a2a88123c WHIRLPOOL 8345da00074e62ec9a9c244cb9ef64930fbd0e5e9e5bc1709bfcf56517cc6312031a09523c3016db2a1542c16a0297bea9d6883a201ae94e347e358307e92422
DIST youtube-dl-2017.03.22.tar.gz 2644766 SHA256 c9c0d929f887c2044a0cee88f314f2746a19f34b5842f1b065efc536c43be9ff SHA512 b04af0535e7d0a396769e01b04f8e7f3f8dfb79a59daa258b339065a420c06e73d2917c81021b4522114df738be0091fa3d8e38307922671c5bd4908f18c172f WHIRLPOOL 4f7241662057280a30c5b731e831a7cd444893419691b7ce933cef7e412cc0ac838431cce5f25fa17c10c7980a16288d3339cb688c10a5064886a26af629e2a3
DIST youtube-dl-2017.03.24.tar.gz 2643234 SHA256 b772e58ff9f156cfcff0308a3f13c5ea75b0cf4dc297d1fe9aa4ad2b870c8803 SHA512 8eb7002dc1d38945373910ef2697bb691f43827237621495ba5501c1a2efd63055b022aaeac403183af58fac8990c733655c28559edf77069a849a1d58b438d0 WHIRLPOOL 739d6924dd16dcf6fc469255aed4fd34c704c496d38b833782d6bc8c470cd763479e7ef517701690fe9a2b1dbb1cccbe0e7dd89f2f6e0ddeb6eff998edfb709e
+DIST youtube-dl-2017.03.26.tar.gz 2647102 SHA256 321558b19c485b2269c394de5546a8d6c0a876ad57dec5b53e0f677251d8da03 SHA512 24a5c8b85db51efdca828bd5c0b5d1b4e5da8464e627a4cff2c8043be5b73c57d1de962d1d2035f51158cd47785563c8ed3f3d8c83ddd473649ea67844c083a9 WHIRLPOOL 375fe45c8ff4bddbe0445027fdc8b605e016cb5963ce710c880ab926e8f7486ef79f8b482a14487a0b91c09e8f4815e61dd7759fbebdefb2bc350639b1490f73
diff --git a/net-misc/youtube-dl/youtube-dl-2017.03.26.ebuild b/net-misc/youtube-dl/youtube-dl-2017.03.26.ebuild
new file mode 100644
index 000000000000..0527ae290b0e
--- /dev/null
+++ b/net-misc/youtube-dl/youtube-dl-2017.03.26.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=(python{2_7,3_4,3_5})
+inherit bash-completion-r1 distutils-r1 eutils
+
+DESCRIPTION="Download videos from YouTube.com (and more sites...)"
+HOMEPAGE="https://rg3.github.com/youtube-dl/"
+SRC_URI="http://youtube-dl.org/downloads/${PV}/${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE="+offensive test"
+
+RDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+DEPEND="
+ ${RDEPEND}
+ test? ( dev-python/nose[coverage(+)] )
+"
+
+S="${WORKDIR}/${PN}"
+
+python_prepare_all() {
+ if ! use offensive; then
+ sed -i -e "/__version__/s|'$|-gentoo_no_offensive_sites'|g" \
+ youtube_dl/version.py || die
+ # these have single line import statements
+ local xxx=(
+ alphaporno anysex behindkink camwithher chaturbate eporner
+ eroprofile extremetube fourtube foxgay goshgay hellporno
+ hentaistigma hornbunny keezmovies lovehomeporn mofosex motherless
+ myvidster porn91 porncom pornflip pornhd pornotube pornovoisines
+ pornoxo ruleporn sexu slutload spankbang spankwire sunporno thisav
+ tube8 vporn watchindianporn xbef xnxx xtube xvideos xxxymovies
+ youjizz youporn
+ )
+ # these have multi-line import statements
+ local mxxx=(
+ drtuber pornhub redtube tnaflix xhamster
+ )
+ # do single line imports
+ sed -i \
+ -e $( printf '/%s/d;' ${xxx[@]} ) \
+ youtube_dl/extractor/extractors.py \
+ || die
+
+ # do multiple line imports
+ sed -i \
+ -e $( printf '/%s/,/)/d;' ${mxxx[@]} ) \
+ youtube_dl/extractor/extractors.py \
+ || die
+
+ sed -i \
+ -e $( printf '/%s/d;' ${mxxx[@]} ) \
+ youtube_dl/extractor/generic.py \
+ || die
+
+ rm \
+ $( printf 'youtube_dl/extractor/%s.py ' ${xxx[@]} ) \
+ $( printf 'youtube_dl/extractor/%s.py ' ${mxxx[@]} ) \
+ test/test_age_restriction.py \
+ || die
+ fi
+
+ epatch_user
+
+ distutils-r1_python_prepare_all
+}
+
+src_compile() {
+ distutils-r1_src_compile
+}
+
+python_test() {
+ emake test
+}
+
+python_install_all() {
+ dodoc README.txt
+ doman ${PN}.1
+
+ newbashcomp ${PN}.bash-completion ${PN}
+
+ insinto /usr/share/zsh/site-functions
+ newins youtube-dl.zsh _youtube-dl
+
+ insinto /usr/share/fish/completions
+ doins youtube-dl.fish
+
+ distutils-r1_python_install_all
+
+ rm -r "${ED}"/usr/etc || die
+}