summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2020-05-15 08:54:13 -0400
committerBrian Evans <grknight@gentoo.org>2020-05-15 08:54:13 -0400
commit3c895ba6a694a240a5ec276f47b993e8271e2c79 (patch)
treeefd16badda2020f157fe934c715cea6bbb15c221
parentdev-php/pecl-amqp: Drop old (diff)
downloadgentoo-3c895ba6a694a240a5ec276f47b993e8271e2c79.tar.gz
gentoo-3c895ba6a694a240a5ec276f47b993e8271e2c79.tar.bz2
gentoo-3c895ba6a694a240a5ec276f47b993e8271e2c79.zip
dev-php/pecl-apcu: Drop old
Signed-off-by: Brian Evans <grknight@gentoo.org>
-rw-r--r--dev-php/pecl-apcu/Manifest2
-rw-r--r--dev-php/pecl-apcu/pecl-apcu-5.1.12.ebuild80
-rw-r--r--dev-php/pecl-apcu/pecl-apcu-5.1.17-r1.ebuild67
3 files changed, 0 insertions, 149 deletions
diff --git a/dev-php/pecl-apcu/Manifest b/dev-php/pecl-apcu/Manifest
index a81dc6696d60..9fd8e3794437 100644
--- a/dev-php/pecl-apcu/Manifest
+++ b/dev-php/pecl-apcu/Manifest
@@ -1,3 +1 @@
-DIST apcu-5.1.12.tgz 105890 BLAKE2B 110a56ed1da8e33bd39c9d694007acdca2deb42219ae5d31b57296ff3729bab3fdbc508965b2cd0fccc425b2c2fea9249933cd7f45586beeee7cd3bd38ef2473 SHA512 f53b7840d5aecfc899e3e878f0bb9a5dc4a83628543963c20c25ce2b2a2adf14dd40d39a6a2014c139962453e0e9e5038fca7b1d0be205c0b9b2aa6e3fefb054
-DIST apcu-5.1.17.tgz 94814 BLAKE2B 2e49f08b9445f04fd036bc949c9099ee045c3ecd460b323e371a4906fdef77f8d3e7d338af14fe3e116a94aa548c7fb79cc0003556ed739e258370095cbec075 SHA512 7f6a6cd927ed4ff251497c2c79e8d832d1a44ddd59abdb175886d3c12ea27f26142e6b851ac5bb5acb49a0e3a998e9741ba0ff03310f51b9cd188cdf6cf12793
DIST apcu-5.1.18.tgz 94668 BLAKE2B c88af867a5f0f3feb550b4b93b83451d972d8f9c2281af8b000b45cb42e2d005f82fe626da8665e0490c79bc378cf9ee5c9a0136d0b490a1155a885bb56fe4f2 SHA512 5e9c5b4540be7abdf2f473d2f8955d8708934a1d6e05cb2c99154cc7ba8a2bbf9afde51769e20f46ef278efd6f60b9172e0864c31e0976b9d3096a337035e7a9
diff --git a/dev-php/pecl-apcu/pecl-apcu-5.1.12.ebuild b/dev-php/pecl-apcu/pecl-apcu-5.1.12.ebuild
deleted file mode 100644
index da6a7f85c523..000000000000
--- a/dev-php/pecl-apcu/pecl-apcu-5.1.12.ebuild
+++ /dev/null
@@ -1,80 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PHP_EXT_NAME="apcu"
-PHP_EXT_INI="yes"
-PHP_EXT_ZENDEXT="no"
-DOCS=( NOTICE README.md TECHNOTES.txt TODO )
-
-# Define 5.6 here so we get the USE and REQUIRED_USE from the eclass
-# This allows us to depend on the other slot
-USE_PHP="php5-6 php7-0 php7-1 php7-2 php7-3"
-
-inherit php-ext-pecl-r3
-
-# However, we only really build for 7.x; so redefine it here
-USE_PHP="php7-0 php7-1 php7-2 php7-3"
-
-KEYWORDS="amd64 x86"
-
-DESCRIPTION="Stripped down version of APC supporting only user cache"
-LICENSE="PHP-3.01"
-SLOT="7"
-IUSE="+mmap"
-
-DEPEND=""
-RDEPEND="${DEPEND} php_targets_php5-6? ( dev-php/pecl-apcu:0[php_targets_php5-6] )"
-
-LOCKS="pthreadmutex pthreadrw spinlock semaphore"
-
-LUSE=""
-for l in ${LOCKS}; do
- LUSE+="lock-${l} "
-done
-
-IUSE+=" ${LUSE/lock-pthreadrw/+lock-pthreadrw}"
-
-REQUIRED_USE="^^ ( $LUSE )"
-
-src_prepare() {
- if use php_targets_php7-0 || use php_targets_php7-1 || use php_targets_php7-2 || use php_targets_php7-3 ; then
- php-ext-source-r3_src_prepare
- else
- eapply_user
- fi
-}
-
-src_configure() {
- if use php_targets_php7-0 || use php_targets_php7-1 || use php_targets_php7-2 || use php_targets_php7-3 ; then
- local PHP_EXT_ECONF_ARGS=(
- --enable-apcu
- $(use_enable mmap apcu-mmap)
- $(use_enable lock-pthreadrw apcu-rwlocks)
- $(use_enable lock-spinlock apcu-spinlocks)
- )
-
- php-ext-source-r3_src_configure
- fi
-}
-
-src_install() {
- if use php_targets_php7-0 || use php_targets_php7-1 || use php_targets_php7-2 || use php_targets_php7-3 ; then
- php-ext-pecl-r3_src_install
-
- insinto /usr/share/php7/apcu
- doins apc.php
- fi
-}
-
-pkg_postinst() {
- if use php_targets_php7-0 || use php_targets_php7-1 || use php_targets_php7-2 || use php_targets_php7-3 ; then
- elog "The apc.php file shipped with this release of pecl-apcu was"
- elog "installed to ${EPREFIX}/usr/share/php7/apcu/."
- elog
- elog "If you depend on the apc_* functions,"
- elog "please install dev-php/pecl-apcu_bc as this extension no longer"
- elog "provides backwards compatibility."
- fi
-}
diff --git a/dev-php/pecl-apcu/pecl-apcu-5.1.17-r1.ebuild b/dev-php/pecl-apcu/pecl-apcu-5.1.17-r1.ebuild
deleted file mode 100644
index 19f8e009175b..000000000000
--- a/dev-php/pecl-apcu/pecl-apcu-5.1.17-r1.ebuild
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PHP_EXT_NAME="apcu"
-PHP_EXT_INI="yes"
-PHP_EXT_ZENDEXT="no"
-DOCS=( NOTICE README.md TECHNOTES.txt )
-
-USE_PHP="php7-1 php7-2 php7-3 php7-4"
-
-inherit php-ext-pecl-r3
-
-KEYWORDS="~amd64 ~arm64 ~x86"
-
-DESCRIPTION="Stripped down version of APC supporting only user cache"
-LICENSE="PHP-3.01"
-SLOT="7"
-
-LOCKS="pthreadmutex pthreadrw spinlock semaphore"
-
-LUSE=""
-for l in ${LOCKS}; do
- LUSE+="lock-${l} "
-done
-
-IUSE="+mmap ${LUSE/lock-pthreadrw/+lock-pthreadrw}"
-
-REQUIRED_USE="^^ ( $LUSE )"
-
-src_prepare() {
- php-ext-source-r3_src_prepare
- # Remove broken tests from php 7.4 due to trivial output differences
- if use php_targets_php7-4 ; then
- php_init_slot_env "php7.4"
- rm "${PHP_EXT_S}"/tests/apc_entry_00{2,3}.phpt || die
- fi
-}
-
-src_configure() {
- local PHP_EXT_ECONF_ARGS=(
- --enable-apcu
- $(use_enable mmap apcu-mmap)
- $(use_enable lock-spinlock apcu-spinlocks)
- )
- # Broken upstream autoconf test disables if present at all
- use lock-pthreadrw || PHP_EXT_ECONF_ARGS+=( --disable-apcu-rwlocks )
-
- php-ext-source-r3_src_configure
-}
-
-src_install() {
- php-ext-pecl-r3_src_install
-
- insinto /usr/share/php7/apcu
- doins apc.php
-}
-
-pkg_postinst() {
- elog "The apc.php file shipped with this release of pecl-apcu was"
- elog "installed to ${EPREFIX}/usr/share/php7/apcu/."
- elog
- elog "If you depend on the apc_* functions,"
- elog "please install dev-php/pecl-apcu_bc as this extension no longer"
- elog "provides backwards compatibility."
-}