summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-02-24 16:23:00 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-02-24 16:23:07 +0100
commit3d846545957fb287beb9bec7c69361878eb3a234 (patch)
treeb864a0192afd638d0d26b2f10f8e4ab704266b74
parentdev-libs/softhsm: Added botan[-bindist] dep, should fix #562804 (diff)
downloadgentoo-3d846545957fb287beb9bec7c69361878eb3a234.tar.gz
gentoo-3d846545957fb287beb9bec7c69361878eb3a234.tar.bz2
gentoo-3d846545957fb287beb9bec7c69361878eb3a234.zip
media-libs/libilbc: update to new upstream and add multilib support
Package-Manager: portage-2.2.27 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
-rw-r--r--media-libs/libilbc/Manifest1
-rw-r--r--media-libs/libilbc/libilbc-2.0.2.ebuild29
-rw-r--r--media-libs/libilbc/libilbc-9999.ebuild20
3 files changed, 38 insertions, 12 deletions
diff --git a/media-libs/libilbc/Manifest b/media-libs/libilbc/Manifest
index 6038f79493d0..9fd94aa1351f 100644
--- a/media-libs/libilbc/Manifest
+++ b/media-libs/libilbc/Manifest
@@ -1 +1,2 @@
DIST libilbc-1.1.1.tar.xz 302324 SHA256 c52a3f46cf5671ac67494371e78281fa72c87a1af1fd8b8e1731693b6541be87 SHA512 7c9fa6da4d8b32fd49ea62f9e876e385930501c9caedcafac94ea74b9372722b06dd28062dc4fcca765ad6c519cfb52bb595d396ca50d361f563c715f6679845 WHIRLPOOL 120a041823e58d0db3d05549491c00e1b74340f2eefd51f2903f29aacefbbbc94f12cc821451e772c7434ea21fc86ff0c5f8ff15a26e732d1e698d2e7ef44c0a
+DIST libilbc-2.0.2.tar.bz2 392643 SHA256 88e2dc14e1fccd7b7a0d7f84e96ac22a33c3c86820cee4b0a05e3dcc08c2b096 SHA512 ad0ef3326144fa1e9b6983be9aeefcec0064930a0124980f0fa2b38967f145e4cef7be75d8eae72f4a9650f297f15968944e73ef256e642116125dea326d8ba8 WHIRLPOOL 091280c168f0877e4d05386161db119e3c0ee029488e28c87de15137cbb79d3bc5536dfb9c9b1fe1ca65cb65d7688e4b8784f65107427d62905989f8c4eb992f
diff --git a/media-libs/libilbc/libilbc-2.0.2.ebuild b/media-libs/libilbc/libilbc-2.0.2.ebuild
new file mode 100644
index 000000000000..b056c4a0a7e1
--- /dev/null
+++ b/media-libs/libilbc/libilbc-2.0.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+if [[ ${PV} == 9999 ]] ; then
+ SCM="autotools git-2"
+ EGIT_REPO_URI="https://github.com/TimothyGu/libilbc"
+ SRC_URI=""
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/TimothyGu/libilbc/releases/download/v${PV}/${P}.tar.bz2"
+ KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+fi
+
+inherit eutils multilib ${SCM} autotools-multilib
+
+DESCRIPTION="Packaged version of iLBC codec from the WebRTC project"
+HOMEPAGE="https://github.com/TimothyGu/libilbc"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="static-libs"
+
+src_prepare() {
+ [[ ${PV} == *9999 ]] && eautoreconf
+ autotools-multilib_src_prepare
+}
diff --git a/media-libs/libilbc/libilbc-9999.ebuild b/media-libs/libilbc/libilbc-9999.ebuild
index 232636092892..b056c4a0a7e1 100644
--- a/media-libs/libilbc/libilbc-9999.ebuild
+++ b/media-libs/libilbc/libilbc-9999.ebuild
@@ -2,32 +2,28 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=4
+EAPI=5
if [[ ${PV} == 9999 ]] ; then
SCM="autotools git-2"
- EGIT_REPO_URI="git://github.com/lu-zero/libilbc.git"
+ EGIT_REPO_URI="https://github.com/TimothyGu/libilbc"
SRC_URI=""
KEYWORDS=""
else
- SRC_URI="https://dev.gentoo.org/~lu_zero/${PN}/${P}.tar.xz"
- KEYWORDS="~amd64"
+ SRC_URI="https://github.com/TimothyGu/libilbc/releases/download/v${PV}/${P}.tar.bz2"
+ KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
fi
-inherit eutils multilib ${SCM}
+inherit eutils multilib ${SCM} autotools-multilib
DESCRIPTION="Packaged version of iLBC codec from the WebRTC project"
-HOMEPAGE="https://github.com/dekkers/libilbc"
+HOMEPAGE="https://github.com/TimothyGu/libilbc"
LICENSE="BSD"
SLOT="0"
-IUSE=""
+IUSE="static-libs"
src_prepare() {
[[ ${PV} == *9999 ]] && eautoreconf
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die
- find "${D}"usr/$(get_libdir) -name '*.la' -delete
+ autotools-multilib_src_prepare
}