summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2015-09-13 13:08:31 -0400
committerAlexandre Rostovtsev <tetromino@gentoo.org>2015-09-13 13:09:11 -0400
commit3db1b3b67ceb628afc0284dbe278366190947242 (patch)
tree4b00a85a22efb0a5b81493ecdcb47b62115d0bd8
parentdev-python/botocore: remove version 1.1.8 (diff)
downloadgentoo-3db1b3b67ceb628afc0284dbe278366190947242.tar.gz
gentoo-3db1b3b67ceb628afc0284dbe278366190947242.tar.bz2
gentoo-3db1b3b67ceb628afc0284dbe278366190947242.zip
net-libs/webkit-gtk: cmake syntax is -DRUBY_EXECUTABLE, not RUBY
Package-Manager: portage-2.2.20.1
-rw-r--r--net-libs/webkit-gtk/webkit-gtk-2.6.6.ebuild8
-rw-r--r--net-libs/webkit-gtk/webkit-gtk-2.8.5.ebuild8
2 files changed, 8 insertions, 8 deletions
diff --git a/net-libs/webkit-gtk/webkit-gtk-2.6.6.ebuild b/net-libs/webkit-gtk/webkit-gtk-2.6.6.ebuild
index 0f23ff9e944f..c4d72b73f93d 100644
--- a/net-libs/webkit-gtk/webkit-gtk-2.6.6.ebuild
+++ b/net-libs/webkit-gtk/webkit-gtk-2.6.6.ebuild
@@ -172,13 +172,13 @@ src_configure() {
local ruby_interpreter=""
if has_version "virtual/rubygems[ruby_targets_ruby22]"; then
- ruby_interpreter="RUBY=$(type -P ruby22)"
+ ruby_interpreter="-DRUBY_EXECUTABLE=$(type -P ruby22)"
elif has_version "virtual/rubygems[ruby_targets_ruby21]"; then
- ruby_interpreter="RUBY=$(type -P ruby21)"
+ ruby_interpreter="-DRUBY_EXECUTABLE=$(type -P ruby21)"
elif has_version "virtual/rubygems[ruby_targets_ruby20]"; then
- ruby_interpreter="RUBY=$(type -P ruby20)"
+ ruby_interpreter="-DRUBY_EXECUTABLE=$(type -P ruby20)"
else
- ruby_interpreter="RUBY=$(type -P ruby19)"
+ ruby_interpreter="-DRUBY_EXECUTABLE=$(type -P ruby19)"
fi
# TODO: Check Web Audio support
diff --git a/net-libs/webkit-gtk/webkit-gtk-2.8.5.ebuild b/net-libs/webkit-gtk/webkit-gtk-2.8.5.ebuild
index ae110a9df265..bdd69c138218 100644
--- a/net-libs/webkit-gtk/webkit-gtk-2.8.5.ebuild
+++ b/net-libs/webkit-gtk/webkit-gtk-2.8.5.ebuild
@@ -184,13 +184,13 @@ src_configure() {
local ruby_interpreter=""
if has_version "virtual/rubygems[ruby_targets_ruby22]"; then
- ruby_interpreter="RUBY=$(type -P ruby22)"
+ ruby_interpreter="-DRUBY_EXECUTABLE=$(type -P ruby22)"
elif has_version "virtual/rubygems[ruby_targets_ruby21]"; then
- ruby_interpreter="RUBY=$(type -P ruby21)"
+ ruby_interpreter="-DRUBY_EXECUTABLE=$(type -P ruby21)"
elif has_version "virtual/rubygems[ruby_targets_ruby20]"; then
- ruby_interpreter="RUBY=$(type -P ruby20)"
+ ruby_interpreter="-DRUBY_EXECUTABLE=$(type -P ruby20)"
else
- ruby_interpreter="RUBY=$(type -P ruby19)"
+ ruby_interpreter="-DRUBY_EXECUTABLE=$(type -P ruby19)"
fi
# TODO: Check Web Audio support