summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2017-12-17 04:26:33 +0100
committerLars Wendler <polynomial-c@gentoo.org>2017-12-17 04:28:40 +0100
commit3e0c93bdde8b684243f8abcdf69fe15f1dcaea55 (patch)
tree34aa959aeed0228674db02eed18342ab0223e243
parentdev-python/jsonrpclib: version bump to 0.3.1 (diff)
downloadgentoo-3e0c93bdde8b684243f8abcdf69fe15f1dcaea55.tar.gz
gentoo-3e0c93bdde8b684243f8abcdf69fe15f1dcaea55.tar.bz2
gentoo-3e0c93bdde8b684243f8abcdf69fe15f1dcaea55.zip
media-video/mpv: Fixed compilation against libva2.
Closes: https://bugs.gentoo.org/641384 Package-Manager: Portage-2.3.19, Repoman-2.3.6
-rw-r--r--media-video/mpv/files/mpv-libva2.patch88
-rw-r--r--media-video/mpv/mpv-0.27.0.ebuild3
2 files changed, 90 insertions, 1 deletions
diff --git a/media-video/mpv/files/mpv-libva2.patch b/media-video/mpv/files/mpv-libva2.patch
new file mode 100644
index 000000000000..843e84494541
--- /dev/null
+++ b/media-video/mpv/files/mpv-libva2.patch
@@ -0,0 +1,88 @@
+From 2ecf240b1cd20875991a5b18efafbe799864ff7f Mon Sep 17 00:00:00 2001
+From: Mark Thompson <sw@jkqxz.net>
+Date: Mon, 9 Oct 2017 20:10:26 +0100
+Subject: [PATCH] vaapi: Use libva2 message callbacks
+
+They are no longer global, so they work vaguely sensibly.
+---
+ video/vaapi.c | 32 +++++++++++++++++++++++++++++---
+ 1 file changed, 29 insertions(+), 3 deletions(-)
+
+diff --git a/video/vaapi.c b/video/vaapi.c
+index 6bedbbaa18..3b1cb9cc41 100644
+--- a/video/vaapi.c
++++ b/video/vaapi.c
+@@ -40,9 +40,27 @@ int va_get_colorspace_flag(enum mp_csp csp)
+ return 0;
+ }
+
+-// VA message callbacks are global and do not have a context parameter, so it's
+-// impossible to know from which VADisplay they originate. Try to route them
+-// to existing mpv/libmpv instances within this process.
++#if VA_CHECK_VERSION(1, 0, 0)
++static void va_message_callback(void *context, const char *msg, int mp_level)
++{
++ struct mp_vaapi_ctx *res = context;
++ mp_msg(res->log, mp_level, "libva: %s", msg);
++}
++
++static void va_error_callback(void *context, const char *msg)
++{
++ va_message_callback(context, msg, MSGL_ERR);
++}
++
++static void va_info_callback(void *context, const char *msg)
++{
++ va_message_callback(context, msg, MSGL_V);
++}
++#else
++// Pre-libva2 VA message callbacks are global and do not have a context
++// parameter, so it's impossible to know from which VADisplay they
++// originate. Try to route them to existing mpv/libmpv instances within
++// this process.
+ static pthread_mutex_t va_log_mutex = PTHREAD_MUTEX_INITIALIZER;
+ static struct mp_vaapi_ctx **va_mpv_clients;
+ static int num_va_mpv_clients;
+@@ -77,6 +95,7 @@ static void va_info_callback(const char *msg)
+ {
+ va_message_callback(msg, MSGL_V);
+ }
++#endif
+
+ static void open_lavu_vaapi_device(struct mp_vaapi_ctx *ctx)
+ {
+@@ -108,6 +127,10 @@ struct mp_vaapi_ctx *va_initialize(VADisplay *display, struct mp_log *plog,
+ },
+ };
+
++#if VA_CHECK_VERSION(1, 0, 0)
++ vaSetErrorCallback(display, va_error_callback, res);
++ vaSetInfoCallback(display, va_info_callback, res);
++#else
+ pthread_mutex_lock(&va_log_mutex);
+ MP_TARRAY_APPEND(NULL, va_mpv_clients, num_va_mpv_clients, res);
+ pthread_mutex_unlock(&va_log_mutex);
+@@ -117,6 +140,7 @@ struct mp_vaapi_ctx *va_initialize(VADisplay *display, struct mp_log *plog,
+ #ifdef VA_FOURCC_I010
+ vaSetErrorCallback(va_error_callback);
+ vaSetInfoCallback(va_info_callback);
++#endif
+ #endif
+
+ int major, minor;
+@@ -154,6 +178,7 @@ void va_destroy(struct mp_vaapi_ctx *ctx)
+ if (ctx->destroy_native_ctx)
+ ctx->destroy_native_ctx(ctx->native_ctx);
+
++#if !VA_CHECK_VERSION(1, 0, 0)
+ pthread_mutex_lock(&va_log_mutex);
+ for (int n = 0; n < num_va_mpv_clients; n++) {
+ if (va_mpv_clients[n] == ctx) {
+@@ -164,6 +189,7 @@ void va_destroy(struct mp_vaapi_ctx *ctx)
+ if (num_va_mpv_clients == 0)
+ TA_FREEP(&va_mpv_clients); // avoid triggering leak detectors
+ pthread_mutex_unlock(&va_log_mutex);
++#endif
+
+ talloc_free(ctx);
+ }
diff --git a/media-video/mpv/mpv-0.27.0.ebuild b/media-video/mpv/mpv-0.27.0.ebuild
index 6981ed0d09a2..0edb3df22f3a 100644
--- a/media-video/mpv/mpv-0.27.0.ebuild
+++ b/media-video/mpv/mpv-0.27.0.ebuild
@@ -141,6 +141,7 @@ RDEPEND="${COMMON_DEPEND}
PATCHES=(
"${FILESDIR}/${PN}-0.19.0-make-ffmpeg-version-check-non-fatal.patch"
"${FILESDIR}/${PN}-0.23.0-make-libavdevice-check-accept-libav.patch"
+ "${FILESDIR}/${PN}-libva2.patch" #641384
)
pkg_setup() {
@@ -151,7 +152,7 @@ src_prepare() {
cp "${DISTDIR}/waf-${WAF_PV}" "${S}"/waf || die
chmod +x "${S}"/waf || die
eapply "${FILESDIR}/${PV}"
- default_src_prepare
+ default
}
src_configure() {