summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-07-24 12:41:16 +0200
committerMichał Górny <mgorny@gentoo.org>2018-07-24 14:19:53 +0200
commit3e72daeef9d22cc4af59f43881301d69dfe98332 (patch)
treee3f6abd03441a96d6ac6cf4bfada5c050b696b2f
parentdev-python/dbus-python: Modernize doc install (diff)
downloadgentoo-3e72daeef9d22cc4af59f43881301d69dfe98332.tar.gz
gentoo-3e72daeef9d22cc4af59f43881301d69dfe98332.tar.bz2
gentoo-3e72daeef9d22cc4af59f43881301d69dfe98332.zip
dev-python/dbus-python: Remove redundant configure options
-rw-r--r--dev-python/dbus-python/dbus-python-1.2.6-r2.ebuild9
1 files changed, 1 insertions, 8 deletions
diff --git a/dev-python/dbus-python/dbus-python-1.2.6-r2.ebuild b/dev-python/dbus-python/dbus-python-1.2.6-r2.ebuild
index a79c851ba442..b2f40c7851c9 100644
--- a/dev-python/dbus-python/dbus-python-1.2.6-r2.ebuild
+++ b/dev-python/dbus-python/dbus-python-1.2.6-r2.ebuild
@@ -44,20 +44,13 @@ src_prepare() {
src_configure() {
configuring() {
- local PYTHON_CONFIG
- python_export PYTHON_CONFIG
-
# epydoc is python2-only, bug #447642
local apidocs=--disable-api-docs
[[ ${EPYTHON/.*} = "python2" ]] && apidocs=$(use_enable doc api-docs)
econf \
- --docdir="${EPREFIX}"/usr/share/doc/${PF} \
--disable-html-docs \
- ${apidocs} \
- PYTHON_INCLUDES="$(${PYTHON_CONFIG} --includes)" \
- PYTHON_LIBS="$(${PYTHON_CONFIG} --ldflags)"
- # configure assumes that ${PYTHON}-config executable exists :/
+ ${apidocs}
}
python_foreach_impl run_in_build_dir configuring
}