summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-02-01 15:30:42 +0100
committerJustin Lecher <jlec@gentoo.org>2016-02-01 16:44:20 +0100
commit3ed0c9c36c0c59dd41b154011d8fed435d646e53 (patch)
treefff5561d23f9bbfb21976c0470f54fb63c657737
parentdev-python/pluggy: New package, ebuild written by me (diff)
downloadgentoo-3ed0c9c36c0c59dd41b154011d8fed435d646e53.tar.gz
gentoo-3ed0c9c36c0c59dd41b154011d8fed435d646e53.tar.bz2
gentoo-3ed0c9c36c0c59dd41b154011d8fed435d646e53.zip
dev-python/pytest-xdist: Version Bump
Package-Manager: portage-2.2.27 Signed-off-by: Justin Lecher <jlec@gentoo.org>
-rw-r--r--dev-python/pytest-xdist/Manifest1
-rw-r--r--dev-python/pytest-xdist/pytest-xdist-1.14.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/pytest-xdist/Manifest b/dev-python/pytest-xdist/Manifest
index 2a22275319ee..c7adb6c94a22 100644
--- a/dev-python/pytest-xdist/Manifest
+++ b/dev-python/pytest-xdist/Manifest
@@ -1 +1,2 @@
DIST pytest-xdist-1.13.1.tar.gz 110007 SHA256 4382d7a944c1e2b1dc17fee3fd3575495fb10236a3b6e95cc6955db04984bc3c SHA512 3bb295c0afbcb0f238bdd41dfd1a395f0ba16b8151643aecc25aae13ac7c58d36d26ff4bab197673a9679d1f3436acd05b5ff50107b3128e647de892a6d04e3f WHIRLPOOL 643b23c755eb43c7b6965e588b58547c9ef63d3c225cddb97868c659ab3234bc6bc204575bc48c7f18a498cb0e595b8550928ba92ec5945a936e959f773504b3
+DIST pytest-xdist-1.14.zip 106585 SHA256 4a5e1199122fa29e3017d8d189f59ccc5d82e841474ba2a1eec0e89606153623 SHA512 4cafae77736da6880e8dd42aaa91f68bbc959ff7dabcd231018b144b54f96ccf1b11abb09474e260876bbdf731053005fdbd348ac87461f303d8f8f7af643e36 WHIRLPOOL 7d1f57a6d5cbf08661254f3f47d72c3cfbe931f14985c4b24abb627bd10fdc3f2fa21d05085766c0ed425e74713f991b53bdde957bd64ea4f64a206c2f4feffc
diff --git a/dev-python/pytest-xdist/pytest-xdist-1.14.ebuild b/dev-python/pytest-xdist/pytest-xdist-1.14.ebuild
new file mode 100644
index 000000000000..b71295801a89
--- /dev/null
+++ b/dev-python/pytest-xdist/pytest-xdist-1.14.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Distributed testing and loop-on-failing modes"
+HOMEPAGE="https://pypi.python.org/pypi/pytest-xdist https://bitbucket.org/pytest-dev/pytest-xdist"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ >=dev-python/execnet-1.1[${PYTHON_USEDEP}]
+ >=dev-python/pytest-2.4.2[${PYTHON_USEDEP}]
+ >=dev-python/py-1.4.22[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ "
+
+python_test() {
+ find -name __pycache__ -exec rm -r '{}' + || die
+ py.test -vv -x || die
+}